The pfSense Store

Author Topic: Várias versões do MySQL...  (Read 618 times)

0 Members and 1 Guest are viewing this topic.

Offline elvio.tche

  • Full Member
  • ***
  • Posts: 196
  • Karma: +0/-0
    • View Profile
Várias versões do MySQL...
« on: June 28, 2012, 09:36:53 am »
Olá!

Verifiquei que existem várias versões do MySQL no meu pfSense.
Code: [Select]
[2.0.1-RELEASE][...]: pkg_info | grep mysql
mysql-client-5.1.53 Multithreaded SQL database (client)
mysql-client-5.1.58 Multithreaded SQL database (client)
mysql-client-5.1.61 Multithreaded SQL database (client)
Foram instalados a medida que eu adicionava os "packages".
Seria possível dar um "pkg_delete" nas versões "5.1.53" e "5.1.58" e manter somente a "5.1.61"?
Ou remover todas e instalar apenas a versão "5.5.4"  (mysql-server-5.5.4.tbz)?

grato.

Offline marcelloc

  • Moderator
  • Hero Member
  • *****
  • Posts: 10004
  • Karma: +5/-0
    • View Profile
Re: Várias versões do MySQL...
« Reply #1 on: June 28, 2012, 10:40:27 am »
elvio,

Esta é uma questão delicada, você pode sim remover as outras versões, mas sugiro reinstalar(ou desinstalar/reinstalar) o pacote que tem a versão mais nova depois de arrancar as velhas.

Esta questão de interdependencia de pacotes vai diminuir na versão 2.1 com os pacotes pbi (uma espécie de chroot para os pacotes).

att,
Marcello Coutinho

Offline elvio.tche

  • Full Member
  • ***
  • Posts: 196
  • Karma: +0/-0
    • View Profile
Re: Várias versões do MySQL...
« Reply #2 on: June 28, 2012, 01:02:24 pm »
elvio,

Esta é uma questão delicada, você pode sim remover as outras versões, mas sugiro reinstalar(ou desinstalar/reinstalar) o pacote que tem a versão mais nova depois de arrancar as velhas.

Esta questão de interdependencia de pacotes vai diminuir na versão 2.1 com os pacotes pbi (uma espécie de chroot para os pacotes).

att,
Marcello Coutinho

Opa!

Blz. Vou aguardar a versão 2.1 - até já baixei do snapshots a 2.1 para instalar no meu laboratório pessoal, em casa! Falta tempo, mas ainda vou testar!

abraço.