pfSense Support Subscription

Author Topic: pfSense stürzt regelmäßig ab - kein zugriff über URL/SSH mehr möglich  (Read 2510 times)

0 Members and 1 Guest are viewing this topic.

Offline mojoe

  • Newbie
  • *
  • Posts: 6
    • View Profile
Hallo Zusammen,

ich stehe seit einer geraumen Zeit vor einen schweren Problem mit einem Gerät mit pfSense 2.0.1. Teilweiße täglich stürzt der Porxy meist so ab, dass auch kein Zugriff mehr über die URL oder SSH möglich ist. Manch mal bricht auch nur die WAN Verbindung aus unerklärlichen Gründen ab, dann ist die Zugriff auf das Gerät noch möglich. Das passiert manchmal nur jede Woche, manchmal aber leider auch gleich 3 mal an einem Tag. Nach einem Neustart ist alles wieder funktionsfähig.

Hardwaremässig wurde das gerät quasi fast schon überdimensioniert bestückt, alle Mindestanforderungen sind locker erfüllt. Auch der Internetanbieter hat sich zwischenzeitig geändert, somit wurden auch die Zugangsdaten samt weiteren Einstellungen geändert, leider weiterhin das selbe Problem mit dem WAN.
Hab Ihr vielleicht eine Idee wie ich da an besten vorgehen sollte, habe ich vielleicht irgendwelche Einstellungen übersehen die falsch gesetzt sein könnten? Oder tippt ihr auf einen Hadwaredefekt, bzw. ein Inkompatibilität? Wie könnte ich das ausschließen?

Vielen Dank für Ihre Hilfe!

Moritz

Offline Nachtfalke

  • Hero Member
  • *****
  • Posts: 2753
    • View Profile
Hallo Moritz,

wenn ich mich nicht täusche, hast du in einem anderen Beitrag geschrieben, dass du SQUID nutzt.
Es wäre also ein Anfang, das System ohne SQUID zu testen - ob dann alles problemlos alles funktioniert.

Weiterhin würde mich auch einmal die Systemspezifikationen interesieren, also Netzwerkkarte, CPU, RAM oder fall es ein Komplettsystem ist ein Bezeichnung oder URL.

Weiterhin sind bei SQUID die Einstellungen bei HDD cache und beim memory cache interessant. Wieviel HDD hast du squid zugewiesen und wieviel RAM hast du squid zugewiesen ?

Wie schnell ist deine WAN Verbindung ?

Ist dir eventuell aufgefallen, dass auf dem Dashboard der MBFU Wert sehr hoch ist bzw. am Limit ?

Benutzt du noch andere Pakete außer squid ?

Offline mojoe

  • Newbie
  • *
  • Posts: 6
    • View Profile
Vielen Dank für deine Bemühungen!

Ich habe testweise jetzt mal SQUID abgestellt, das werde ich weiter beobachten.

Das Gerät ist selbst zusammengestellt und zusammengebaut.
Prozessor: Pentium(R) Dual-Core CPU E5700 @ 3.00GHz

Ich weiß gerade nicht wie ich die anderen Hardwareteile anzeigen lassen kann?

Zu SQUID:
Hard disk cache size = 3000 megabytes
Memory cache size = 8 megabytes

Bei der WAN Verbindung handelt es sich um einen Telekom VDSL 50.000 Anschluss. Zuvor war es ein SDSL 2000 Anschluss.

MBFU ist zur Zeit 7664/25600. Ich kann mich jetzt auch nicht errinnern, dass der Wert mal am Anschlag war.

Neben SQUID ist noch das Paket Lightsquid installiert.

Schöne Grüße und noch mal Danke

Moritz

Offline Nachtfalke

  • Hero Member
  • *****
  • Posts: 2753
    • View Profile
Hallo,

wenn du per SSH oder über die Console auf die pfsense gesht, bekommst du ja das Auswahlmenü angezeigt.
Über diesem Menü stehen auch Informationen zu deinen Schnittstellen - das könnte so aussehen:

Code: [Select]
WAN (wan)       -> em0        -> v4/DHCP4: 192.168.42.134/24
 LAN (lan)       -> em1        -> v4: 192.168.0.25/24
in meinem Fall bezeichnet emX den verwendeten Treiber für meine Netzwerkkarte. Hier geht es erstmal darum rauszufinden, was du für eine drinne hast. Evtl. liegt dort der Fehler, bzw. man muss diesbezüglich etwas ändern.

Offline mojoe

  • Newbie
  • *
  • Posts: 6
    • View Profile
Das Menü zeigt folgendes:

Code: [Select]
 WAN (wan)                 -> pppoe4     -> x.x.x.x (PPPoE)
  LAN (lan)                 -> re1        -> 192.168.1.1
  DSLalt (opt1)        -> igb0       -> NONE (PPPoE)
  LAN2 (opt2)               -> igb1       -> 192.168.2.1
  DSLErsatz (opt3)            -> pppoe3     -> x.x.x.x (PPPoE)
  LAN3 (opt4)          -> igb3       -> 192.168.3.1

x.x.x.x = externe IP

Assign Interfaces:

Code: [Select]
igb0  00:xx:xx:xx:xx:xx (down) Intel(R) PRO/1000 Network Connection version - 2.2.3
igb1  00:xx:xx:xx:xx:xx   (up) Intel(R) PRO/1000 Network Connection version - 2.2.3
igb2  00:xx:xx:xx:xx:xx   (up) Intel(R) PRO/1000 Network Connection version - 2.2.3
igb3  00:xx:xx:xx:xx:xx   (up) Intel(R) PRO/1000 Network Connection version - 2.2.3
re0   00:xx:xx:xx:xx:xx   (up) RealTek 8168/8111 B/C/CP/D/DP/E PCIe Gigabit Ethernet
re1   00:xx:xx:xx:xx:xx   (up)

Kannst du daraus vielleicht schon etwas schließen? Die anderen Dinge wie cache Größe und MBFU passen soweit oder?
« Last Edit: July 04, 2012, 07:20:21 am by mojoe »

Offline Nachtfalke

  • Hero Member
  • *****
  • Posts: 2753
    • View Profile
Hallo,

also zum Thema SQUID. Du hast ja fast nur die Standardeinstellungen genommen. Cache Größe von 3000MB für HDD ist kein Problem. Weiterhin hast du nur 8MB vom RAM für den SQUID cache genommen, was letztendlich nicht dazu geführt haben wir, dass dein RAM vollgelaufen wäre. Trotzdem würde ich squid mal eine Weile weg lassen, um das Problem besser eingrenzen zu können.

MBFU sollte auch ok sein, zumindest der Wert, den du gepostet hast.

Bei deinen Netzwerkkarten:
Die igbX Karten sind alles Intel Karten, diese sind eigentlich gut geeignet und machen wenige Probleme. die reX Karten - Realtek Netzwerkkarten - die sind leider oftmals Schund.

Was du probieren kannst:
SYSTEM -> Advanced -> Network -> Disable hardware checksum offload aktivieren. Eventuell das Systen neustarten und testen.
Wenn das nichts bringt, wieder den Haken raus nehmen und mit der nächsten Option probieren:

SYSTEM -> Advanced -> Network -> Enable device polling (Kann sein, dass es nicht unterstützt wird, weiss ich aber nicht genau. Die Beschreibung würde zumindest etwas auf deine Probleme passen). Hilft auch das nicht, wieder den Haken raus nehmen und folgendes probieren:

http://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards#Intel_igb.284.29_and_em.284.29_Cards
Code: [Select]
Intel igb(4) and em(4) Cards

Certain intel igb cards, especially multi-port cards, can very easily/quickly exhaust mbufs and cause panics, especially on amd64. The following tweaks should help:

In /boot/loader.conf.local - Add the following (or create the file if it does not exist):

kern.ipc.nmbclusters="131072"
hw.igb.num_queues=1

That will increase the amount of network memory buffers, and make the card use one queue instead of multiple queues, to reduce the strain on the system.
Also die im text benannte Dtaei loader.conf.local erstellen und darin eben die obigen beiden Werte eintragen, speichern, system neu booten.


PS: Wieviel MB RAM hat denn das System verbaut ?

Offline mojoe

  • Newbie
  • *
  • Posts: 6
    • View Profile
Vielen Dank, das ist doch schon mal ein sehr guter Ansatz für mich, das werde ich die nächsten Tage Schritt für Schritt durchprobieren!

Der betroffene WAN hängt auch gerade an dieser Realtek Netzwerkkarte, da macht es Sinn den Port mal auf die Intelkarte zu legen oder?

Ich meine 1 GB RAM sind verbaut, wo kann ich das noch mal nachschauen?


Offline Nachtfalke

  • Hero Member
  • *****
  • Posts: 2753
    • View Profile
Vielen Dank, das ist doch schon mal ein sehr guter Ansatz für mich, das werde ich die nächsten Tage Schritt für Schritt durchprobieren!

Der betroffene WAN hängt auch gerade an dieser Realtek Netzwerkkarte, da macht es Sinn den Port mal auf die Intelkarte zu legen oder?

Ich meine 1 GB RAM sind verbaut, wo kann ich das noch mal nachschauen?
Optimal wäre es natürlich, wenn du alle Schnittstellen auf die Intel Karten legen könntest. Dann können wir die Realtek-Problematik schonmal ausschließen.

Ansonsten kannst du dir den RAM anzeigen lassen, unter DIAGNOSTICS -> SYSTEM ACTIVITY. Dort steht es nicht direkt, aber oben steht, wieviel RAM genutzt und wieviel frei ist. Grundsätzlich reicht es aber erstmal, wenn du auf der Startseite (Dashboard), die RAM Ausnutzung nicht über 80% hast und dass die SWAP size optimalerweise bei 0% liegt.

Offline shavenne

  • Newbie
  • *
  • Posts: 6
    • View Profile
Hab das gleiche Problem. Bei mir läuft das ganze auf einer VMware ESXi Maschine. Ich habe allerdings KEIN Squid am laufen.
Häufig ists so, dass alles nacheinander verreckt. Erst funktioniert das OpenVPN nicht mehr, dann versuch ich aufs Webinterface zu gehen, da funktioniert dann meistens das Dashboard noch, aber sobald ich woanders hinklick, bleibt auch das Webinterface hängen. SSH Zugriff ist meistens dann auch nicht mehr möglich. Irgendwann geht dann auch das Internet nicht mehr. Wenn ich dann direkt auf die Maschine gehe und sage Reboot, dann bleibt er auch da hängen. Irgendwie alles komisch das ganze. Passiert auch häufig, wenn ich gar nicht zuhause bin, dass der Router sich aufhängt.
Version bei mir: 2.1-BETA0. Immer wieder mal geupdatet, aber das Problem bleibt.
« Last Edit: July 12, 2012, 01:54:41 am by shavenne »