The pfSense Store

Author Topic: No Internet Access with PPTP VPN connected?  (Read 13032 times)

0 Members and 1 Guest are viewing this topic.

Offline accordk

  • Newbie
  • *
  • Posts: 7
    • View Profile
No Internet Access with PPTP VPN connected?
« on: July 30, 2007, 04:35:03 am »
Hi!

I have set up PPTP VPN.
I can access shared files and servers all right.
However, I can't surf Internet with the connection to the VPN. I could even open the management of pfSense firewall with its public IP address. Of course, its private IP is working well.
I followed the direction from MonoWall Handbook and the VPN works great inside the LAN.
I appreciate your help in advance.

Offline dotdash

  • Hero Member
  • *****
  • Posts: 1282
    • View Profile
Re: No Internet Access with PPTP VPN connected?
« Reply #1 on: July 30, 2007, 09:19:59 am »
If you uncheck the 'use default gateway on remote network' box, you won't try to access the Internet over the VPN. (Networking. IP, advanced). Otherwise, you will need firewall rules allowing the PPTP clients out.

Offline accordk

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: No Internet Access with PPTP VPN connected?
« Reply #2 on: August 01, 2007, 11:34:49 pm »
Thanks, dotdash

it's ok now....

Offline whitty

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: No Internet Access with PPTP VPN connected?
« Reply #3 on: August 11, 2007, 05:48:21 pm »
I still seem to have this very same issue, how did you fix it?

Offline Brasse

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: No Internet Access with PPTP VPN connected?
« Reply #4 on: August 14, 2007, 12:49:40 am »
Im borrowing the thread :)
I also have that problem, it works good to uncheck the "use default gateway"-box, but it would be nice if you dont need to do that.
How would the firewall settings look like if VPN-users should be able to access internet?

Yes, I am new to pFsense :)

Offline mikeisfly

  • Full Member
  • ***
  • Posts: 252
    • View Profile
Re: No Internet Access with PPTP VPN connected?
« Reply #5 on: November 11, 2007, 06:43:50 pm »
I had the same problem, and even though this thread is old maybe this will help someone else out there that see this. You need to setup a rule allowing traffic out of your pptp. Here is the trick if you are using advance outbound nat then you need to setup a rule for your pptp clients to get out as well. Now this where it gets a little tricky. If you look at your network settings you will see that your subnet mask is /32 so basically you would have to setup a NAT rule for all of your possible VPN connections or you could do any (Under Source Type).



Hope this helps.