The pfSense Store

Author Topic: Kernel: Arp moved from - to  (Read 3574 times)

0 Members and 1 Guest are viewing this topic.

Offline Jason Litka

  • Hero Member
  • *****
  • Posts: 937
    • View Profile
    • Utter Ramblings
Re: Kernel: Arp moved from - to
« Reply #15 on: February 04, 2013, 07:38:47 am »
If we disable the sleep proxy "feature" on all the MACs will the errors go away?

No. The issue is with the TC and AE, not the Macs, and you can't disable that feature on them.

If you just want those messages not to appear in the log add the system tunable "net.link.ether.inet.log_arp_movements" and set its value to 0.

I actually think the Suppress ARP messages setting will do it as well. If memory serves I didn't add a manual tunable.
I can break anything.

Offline bardelot

  • Full Member
  • ***
  • Posts: 176
    • View Profile
Re: Kernel: Arp moved from - to
« Reply #16 on: February 04, 2013, 07:50:52 am »
I actually think the Suppress ARP messages setting will do it as well. If memory serves I didn't add a manual tunable.

Yes it sets the same tunable and also net.link.ether.inet.log_arp_wrong_iface="0" .

Offline tojoski

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Kernel: Arp moved from - to
« Reply #17 on: February 05, 2013, 01:37:41 pm »
This is happening on my Home Server as well.. I have 2 Gigabit Ethernet ports that are teamed to a single connection.

Feb 5 12:33:22
 
kernel: arp: 10.1.1.5 moved from 00:e0:81:ba:57:c4 to 00:e0:81:ba:57:c5 on em0
 
Feb 5 12:33:22
 
kernel: arp: 10.1.1.5 moved from 00:e0:81:ba:57:c5 to 00:e0:81:ba:57:c4 on em0

Will this create an issue? It seems to be working ok

Offline cmb

  • Administrator
  • Hero Member
  • *****
  • Posts: 6296
    • LinkedIn
    • Twitter
    • View Profile
    • Chris Buechler
Re: Kernel: Arp moved from - to
« Reply #18 on: February 05, 2013, 02:21:10 pm »
This is happening on my Home Server as well.. I have 2 Gigabit Ethernet ports that are teamed to a single connection.

Feb 5 12:33:22
 
kernel: arp: 10.1.1.5 moved from 00:e0:81:ba:57:c4 to 00:e0:81:ba:57:c5 on em0
 
Feb 5 12:33:22
 
kernel: arp: 10.1.1.5 moved from 00:e0:81:ba:57:c5 to 00:e0:81:ba:57:c4 on em0

Will this create an issue? It seems to be working ok


That's a different scenario, that's what you see when using certain types of NIC bonding. It's fine.

Offline joako

  • Full Member
  • ***
  • Posts: 139
    • View Profile
Re: Kernel: Arp moved from - to
« Reply #19 on: February 15, 2013, 09:21:23 pm »
If we disable the sleep proxy "feature" on all the MACs will the errors go away?

No. The issue is with the TC and AE, not the Macs, and you can't disable that feature on them.

If you just want those messages not to appear in the log add the system tunable "net.link.ether.inet.log_arp_movements" and set its value to 0.

I actually think the Suppress ARP messages setting will do it as well. If memory serves I didn't add a manual tunable.

I don't have any Time Capsule or Airport Express. Only Apple TV, 2x MacBook that are here sometimes and probably a few PCs with iTunes installed, if that matters.

But I still get the errors in the pfSense log.

Offline cmb

  • Administrator
  • Hero Member
  • *****
  • Posts: 6296
    • LinkedIn
    • Twitter
    • View Profile
    • Chris Buechler
Re: Kernel: Arp moved from - to
« Reply #20 on: February 17, 2013, 08:47:53 pm »
I don't have any Time Capsule or Airport Express. Only Apple TV, 2x MacBook that are here sometimes and probably a few PCs with iTunes installed, if that matters.

But I still get the errors in the pfSense log.

You don't need either of those, anything with the sleep proxy does it.

Offline xbipin

  • Hero Member
  • *****
  • Posts: 1220
    • View Profile
Re: Kernel: Arp moved from - to
« Reply #21 on: April 09, 2013, 06:55:07 am »
isnt this arp moved thing related to using wifi repeaters?

Offline cmb

  • Administrator
  • Hero Member
  • *****
  • Posts: 6296
    • LinkedIn
    • Twitter
    • View Profile
    • Chris Buechler
Re: Kernel: Arp moved from - to
« Reply #22 on: April 09, 2013, 07:37:10 pm »
isnt this arp moved thing related to using wifi repeaters?

Most often, no. It can be. Some of them will translate the source MAC, which if someone roams from one wifi repeater to another will generate this kind of log.

Offline xbipin

  • Hero Member
  • *****
  • Posts: 1220
    • View Profile
Re: Kernel: Arp moved from - to
« Reply #23 on: April 10, 2013, 03:35:50 am »
if so then wouldnt it cause issues with internet drops when a static dhcp lease is set with static arp for a client wifi mac id

Offline cmb

  • Administrator
  • Hero Member
  • *****
  • Posts: 6296
    • LinkedIn
    • Twitter
    • View Profile
    • Chris Buechler
Re: Kernel: Arp moved from - to
« Reply #24 on: April 10, 2013, 04:51:35 am »
if so then wouldnt it cause issues with internet drops when a static dhcp lease is set with static arp for a client wifi mac id

It shouldn't. The DHCP requests should be relayed so the DHCP server still gets the client's actual MAC. Otherwise only one client behind the repeater would work on DHCP.

Offline xbipin

  • Hero Member
  • *****
  • Posts: 1220
    • View Profile
Re: Kernel: Arp moved from - to
« Reply #25 on: April 25, 2013, 10:53:24 am »
well i have a problem with the same, i have bridged lan to wifi on pfsense and static mac id/ip pairs set with static arp and deny unknown client ticked, i use a tp link TL-WA850RE wifi range entender and wifi clients get the proper ip but with staic arp wifi clients r not able to surf at all untill i untick that, any solution to this