Retired > 2.1 Snapshot Feedback and Problems - RETIRED

HEADS UP: OpenSSL 1.0.1_4 (1.0.1c), OpenVPN, and ipsec-tools, and others.

(1/4) > >>

jimp:
To upgrade ipsec-tools to 0.8.1, we had to pull in OpenSSL 1.0.1_4 (1.0.1c) from the FreeBSD ports repository.

Because many aspects of the system rely on OpenSSL, such as IPsec, OpenVPN, Certificate Management, GUI access, Backup encryption, Vouchers, etc. There could be some unexpected fallout from changing OpenSSL.

I have already fixed a few issues on the current snapshot, notably OpenVPN using the padlock engine and Certificate generation.

If you find something else has suddenly broken with OpenVPN or IPsec, or another encryption-related area that had been working in snaps before the change, let us know.

There are more fixes coming in the next snapshot that should be available later this evening, so if you find something before then, wait until after the next new snapshot to test again and report it broken.

OpenSSL 1.0.x is also supposed to contain better support for AES-NI, so it may help those who had been trying to use it but not seeing any real performance gains.
Additionally there is a new engine in it called "rsax" that supposedly improves speed on amd64 for 1024-bit RSA operations. Not sure if we'll really find much use for that though these days.

dhatz:
I think you meant to say 1.0.1_4 from http://www.freshports.org/security/openssl/

There is no openssl 1.0.4 as far as I can tell from the openssl.org site, latest version is 1.0.1c (May-2012).

jimp:

--- Quote from: dhatz on January 27, 2013, 04:36:17 pm ---I think you meant to say 1.0.1_4 from http://www.freshports.org/security/openssl/

There is no openssl 1.0.4 as far as I can tell from the openssl.org site, latest version is 1.0.1c (May-2012).

--- End quote ---

Yep, you're right.

marcelloc:
getting this while trying to create an internal CA.


2.1-BETA1 (amd64)
built on Fri Jan 25 17:45:36 EST 2013

The following input errors were detected:

openssl library returns: error:0E064002:configuration file routines:CONF_load:system lib

jimp:
Old snap. Already fixed on current snaps.

Navigation

[0] Message Index

[#] Next page

Go to full version