Netgate SG-1000 microFirewall

Author Topic: Hardwarefeedback CB-6971B-050  (Read 1624 times)

0 Members and 1 Guest are viewing this topic.

Offline tmueko

  • Jr. Member
  • **
  • Posts: 32
  • Karma: +0/-0
    • View Profile
Hardwarefeedback CB-6971B-050
« on: August 16, 2007, 03:52:38 am »
I managed to let pfSense run on this Hardware:
I an 500MHz AMD Geode with 7 Ethernetconnectors: re0-2 are indipendent Interfaces, re3 is a 4-Port switch. Price is < 200€ from distributor without RAM.

Problem: Hardware panic with standard kernel!
Solution: Build own kernel without USB2 support (ehci)
This is no pfSense problem but a FreeBSD problem, so I submittet a bugreport to FreeBSD ...

Second small Problem was: the germany distributor is not worse while! They are no help any more once the have your money but wants to sell non-standart monitor- and ps2 adapter for > 50€ (which I build by myself with 2€ Hardware, a soldering rod and the docs from

I think it is interesting Hardware as it has this 4-Ports switch which is great for a DMZ.

Tom Müller-Kortkamp

dmesg for those interesting in it..

Copyright (c) 1992-2007 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 6.2-RELEASE-p4 #7: Wed Jun 13 17:45:16 CEST 2007
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Geode(TM) Integrated Processor by AMD PCS (499.91-MHz 586-class CPU)
  Origin = "AuthenticAMD"  Id = 0x5a2  Stepping = 2
  AMD Features=0xc0400000<MMX+,3DNow+,3DNow>
real memory  = 528154624 (503 MB)
avail memory = 507404288 (483 MB)
kbd1 at kbdmux0
K6-family MTRR support enabled (2 registers)
ath_hal: (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
cpu0 on motherboard
pcib0: <Host to PCI bridge> pcibus 0 on motherboard
pci0: <PCI bus> on pcib0
pci0: <display, VGA> at device 1.1 (no driver attached)
pci0: <encrypt/decrypt, entertainment crypto> at device 1.2 (no driver attached)
re0: <RealTek 8139C+ 10/100BaseTX> port 0xf600-0xf6ff mem 0xeffff000-0xeffff0ff irq 10 at device 9.0 on pci0
miibus0: <MII bus> on re0
rlphy0: <RealTek internal media interface> on miibus0
rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
re0: Ethernet address: 00:0d:48:38:01:81
re0: [FAST]
re1: <RealTek 8139C+ 10/100BaseTX> port 0xfc00-0xfcff mem 0xefffe000-0xefffe0ff irq 11 at device 10.0 on pci0
miibus1: <MII bus> on re1
rlphy1: <RealTek internal media interface> on miibus1
rlphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
re1: Ethernet address: 00:0d:48:38:01:82
re1: [FAST]
re2: <RealTek 8139C+ 10/100BaseTX> port 0xfa00-0xfaff mem 0xefffd000-0xefffd0ff irq 7 at device 11.0 on pci0
miibus2: <MII bus> on re2
rlphy2: <RealTek internal media interface> on miibus2
rlphy2:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
re2: Ethernet address: 00:0d:48:38:01:83
re2: [FAST]
re3: <RealTek 8139C+ 10/100BaseTX> port 0xf800-0xf8ff mem 0xefffc000-0xefffc0ff irq 5 at device 12.0 on pci0
miibus3: <MII bus> on re3
rlphy3: <RealTek internal media interface> on miibus3
rlphy3:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
re3: Ethernet address: 00:0d:48:38:01:84
re3: [FAST]
isab0: <PCI-ISA bridge> port 0x6000-0x6007,0x6100-0x61ff,0x6200-0x623f,0x9d00-0x9d7f,0x9c00-0x9c3f at device 15.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <GENERIC ATA controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xff00-0xff0f at device 15.2 on pci0
ata0: <ATA channel 0> on atapci0
ata1: <ATA channel 1> on atapci0
ohci0: <OHCI (generic) USB controller> mem 0xefffb000-0xefffbfff irq 10 at device 15.4 on pci0
usb0: OHCI version 1.0, legacy support
usb0: SMM does not respond, resetting
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: AMD OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 4 ports with 4 removable, self powered
pci0: <serial bus, USB> at device 15.5 (no driver attached)
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xc7fff,0xef000-0xeffff on isa0
fdc0: <Enhanced floppy controller> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
fdc0: [FAST]
ppc0: parallel port not found.
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x30 on isa0
sio0: type 16550A, console
sio1 at port 0x2f8-0x2ff irq 3 on isa0
sio1: type 16550A
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
atkbdc1: <Keyboard controller (i8042)> at port 0x60,0x64 irq 1 on isa0
device_attach: atkbdc1 attach returned 12
speaker0: <PC speaker> at port 0x61 on isa0
unknown: <PNP0c01> can't assign resources (memory)
unknown: <PNP0c02> can't assign resources (memory)
unknown: <PNP0501> can't assign resources (port)
unknown: <PNP0700> can't assign resources (port)
unknown: <PNP0501> can't assign resources (port)
Timecounter "TSC" frequency 499905053 Hz quality 800
Timecounters tick every 10.000 msec
Fast IPsec: Initialized Security Association Processing.
ad0: 488MB <SanDisk SDCFB-512 Rev 0.00> at ata0-master PIO4
GEOM_LABEL: Label for provider ad0a is ufs/pfSense.
GEOM_LABEL: Label for provider ad0d is ufs/pfSenseCfg.
Trying to mount root from ufs:/dev/ufs/pfSense