Retired > 2.1 Snapshot Feedback and Problems - RETIRED

HEADS UP: 2.1-RC0 Branched, you MUST fix your update URL.

(1/3) > >>

jimp:
[Alternate title: It's-a me, RC0]

HEADS UP - RC0 tagged on 2.1, and RELENG_2_1 is branched. The builders have been fixed to build RC0 images from that branch.

All commits in RELENG_2_1 from now on must be fixes for a problem, not new features.

Because of the branch, the snapshots URL changed. I updated the manifest and the snapshot pages to match.

To see the RC0 snapshot as an upgrade, you'll need to visit System > Firmware on the Updater Settings tab, and either pick the 2.1-RC entry form the drop-down, or change HEAD to RELENG_2_1 in your update URL. Once that change has been saved, Auto Update will pick up RC0.

If you use gitsync (especially the automated gitsync-after-update), you MUST specify RELENG_2_1 as the branch, or you'll end up with the wrong code. Also make sure you have the repository URL set to git://github.com/pfsense/pfsense.git - and consider stopping the use of the gitsync after update feature. It was mostly useful during early 2.1 development and now that snapshots are regular and things are in the RC phase, it is more likely to hurt than to help.

Currently the master branch is labeled 2.2-ALPHA but we are still focusing on polishing up 2.1 at the moment, there are no 2.2 snapshots, and the 2.2 code is NOT considered stable as it is now open to commits that can render it unstable/broken in the name of long-term progress.

Enjoy!

dhatz:

--- Quote from: jimp on May 23, 2013, 07:02:54 am ---To see the RC0 snapshot as an upgrade, you'll need to visit System > Firmware on the Updater Settings tab, and either pick the 2.1-RC entry form the drop-down, or change HEAD to RELENG_2_1 in your update URL. Once that change has been saved, Auto Update will pick up RC0.

--- End quote ---

So the System > Firmware > Settings > Firmware Auto Update URL needs to be either:
http://snapshots.pfsense.org/FreeBSD_RELENG_8_3/i386/pfSense_RELENG_2_1/.updaters
http://snapshots.pfsense.org/FreeBSD_RELENG_8_3/amd64/pfSense_RELENG_2_1/.updaters
(i386/amd64 depending on your architecture)

jimp:
Yes, that's right, either one of those.

I updated my first post in the thread with some other info. Notably the warning for gitsync after update being harmful.

phil.davis:
On my systems, the Default Auto Update URLs dropdown does not show 2.1-RC. It only shows the usual "stable updates" and "2.1 Development" options. I thought that the dropdown list is built at run-time from an online source, so should do its thing automatically. Am I missing something or?

razzfazz:
Seeing the same thing on my embedded install; works fine on a full install, though.

Navigation

[0] Message Index

[#] Next page

Go to full version