pfSense Gold Subscription

Author Topic: Snapshot builder not looping  (Read 2885 times)

0 Members and 1 Guest are viewing this topic.

Offline phil.davis

  • Hero Member
  • *****
  • Posts: 4612
  • Karma: +550/-3
    • View Profile
    • International Nepal Fellowship
Snapshot builder not looping
« on: March 14, 2014, 01:03:40 am »
The 12 March build works nicely (at least for me at home on an Alix with dual-WAN failover). Chris and Renato have committed a few big and/or important (packages URL) things since that snapshot, that would be useful for people to independently try/test from out in real life. Rather than put gitsync on the Alix, I was thinking the snapshot builder loop would have woken up by now and be making more snapshots.
Is it stuck? Needs a kick?
As the Greek philosopher Isosceles used to say, "There are 3 sides to every triangle."
If I helped you, then help someone else - buy someone a gift from the INF catalog http://secure.inf.org/gifts/usd/

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 21378
  • Karma: +1431/-26
    • View Profile
Re: Snapshot builder not looping
« Reply #1 on: March 14, 2014, 07:28:03 am »
They're going again now
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline Tikimotel

  • Full Member
  • ***
  • Posts: 201
  • Karma: +11/-0
    • View Profile
Re: Snapshot builder not looping
« Reply #2 on: March 19, 2014, 01:13:52 pm »
AMD64 builder stuck again? (last build is from 17th of March)
See logs for the i386 version for 19th or March and tar.gz builds for that ...

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 21378
  • Karma: +1431/-26
    • View Profile
Re: Snapshot builder not looping
« Reply #3 on: March 19, 2014, 02:17:56 pm »
It hit a snag, they're both trying again now.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline doktornotor

  • Hero Member
  • *****
  • Posts: 8553
  • Karma: +956/-278
  • Not a pfSense employee, they cannot fire me...
    • View Profile
Re: Snapshot builder not looping
« Reply #4 on: March 22, 2014, 07:26:19 am »
Looks like stuck again (both)... Plus, looking at the times it normally takes to upload the snapshot's images, wondering if this thing is somewhere on dialup?
Do NOT PM for help!

Offline phil.davis

  • Hero Member
  • *****
  • Posts: 4612
  • Karma: +550/-3
    • View Profile
    • International Nepal Fellowship
Re: Snapshot builder not looping
« Reply #5 on: March 22, 2014, 08:19:32 pm »
Code: [Select]
Thu Mar 20 14:44:57 EDT 2014 -|- >>> Copying files to snapshots.pfsense.org
Thu Mar 20 14:45:08 EDT 2014 -|- sending incremental file list
Thu Mar 20 14:45:10 EDT 2014 -|- pfSense-LiveCD-2.1.1-PRERELEASE-i386-20140320-1158.iso.gz
Thu Mar 20 14:59:44 EDT 2014 -|- pfSense-LiveCD-2.1.1-PRERELEASE-i386-20140320-1158.iso.gz.md5
Thu Mar 20 14:59:46 EDT 2014 -|- pfSense-LiveCD-2.1.1-PRERELEASE-i386-20140320-1158.iso.gz.sha256
Thu Mar 20 14:59:46 EDT 2014 -|- sent 82,634,986 bytes  received 193 bytes  94,063.95 bytes/sec
Thu Mar 20 14:59:46 EDT 2014 -|- total size is 82,614,572  speedup is 1.00
Thu Mar 20 14:59:46 EDT 2014 -|- sending incremental file list
Thu Mar 20 14:59:46 EDT 2014 -|- pfSense-memstick-2.1.1-PRERELEASE-i386-20140320-1158.img.gz
Thu Mar 20 15:14:13 EDT 2014 -|- sending incremental file list
Thu Mar 20 15:14:14 EDT 2014 -|- pfSense-Full-Update-2.1.1-PRERELEASE-i386-20140320-1158.tgz
Thu Mar 20 15:29:07 EDT 2014 -|- pfSense-Full-Update-2.1.1-PRERELEASE-i386-20140320-1158.tgz.md5
Thu Mar 20 15:29:09 EDT 2014 -|- pfSense-Full-Update-2.1.1-PRERELEASE-i386-20140320-1158.tgz.sha256
Thu Mar 20 15:29:09 EDT 2014 -|- sent 76,363,300 bytes  received 193 bytes  85,084.67 bytes/sec
Thu Mar 20 15:29:09 EDT 2014 -|- total size is 76,344,420  speedup is 1.00
Thu Mar 20 15:29:10 EDT 2014 -|- sending incremental file list
Thu Mar 20 15:29:12 EDT 2014 -|- pfSense-2.1.1-PRERELEASE-1g-i386-nanobsd-20140320-1159.img.gz
Thu Mar 20 16:03:27 EDT 2014 -|- pfSense-2.1.1-PRERELEASE-1g-i386-nanobsd-20140320-1159.img.gz.md5
This last run seemed to have stopped after just a couple of snaps were copied up to snapshots.pfsene.org. I guess the build machine got rebooted or? and nothing has run since.
Quote
Plus, looking at the times it normally takes to upload the snapshot's images, wondering if this thing is somewhere on dialup?
Yes, when copying it seems to be on a 1Mbps pace. It is tedious when I can see a new snap has finished building but it takes many hours before the nanoBSD update images (at the end) actually get to the server. It uses the same amount of data quota if it runs at 1Mbps or at 2, 5, 10Mbps - is it possible to make the snapshot upload faster?
As the Greek philosopher Isosceles used to say, "There are 3 sides to every triangle."
If I helped you, then help someone else - buy someone a gift from the INF catalog http://secure.inf.org/gifts/usd/

Offline xbipin

  • Hero Member
  • *****
  • Posts: 1631
  • Karma: +6/-0
    • View Profile
Re: Snapshot builder not looping
« Reply #6 on: March 23, 2014, 01:22:27 am »
i would recommend uploading the snaps for the firmware update available check on dashboard page first then followed by the individual file so this way nanobsd etc get the update first followed by the individual files for manual flashing

Offline doktornotor

  • Hero Member
  • *****
  • Posts: 8553
  • Karma: +956/-278
  • Not a pfSense employee, they cannot fire me...
    • View Profile
Re: Snapshot builder not looping
« Reply #7 on: March 26, 2014, 01:26:02 am »
The thing apparently lacks even basic sanity checking, uploading complete junk

https://forum.pfsense.org/index.php?topic=74119.0
https://forum.pfsense.org/index.php?topic=74046.0
Do NOT PM for help!

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 21378
  • Karma: +1431/-26
    • View Profile
Re: Snapshot builder not looping
« Reply #8 on: March 26, 2014, 01:34:17 pm »
Snapshot server moved and things are syncing a bit differently now, plus we're preparing for the 2.1.1 release so don't be too shocked if the 2.1.1 snapshots disappear.

...or something else appears... *cough*
« Last Edit: March 26, 2014, 03:04:34 pm by jimp »
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!