Netgate SG-1000 microFirewall

Author Topic: pfSense 2.3 on Nutanix CE  (Read 131 times)

0 Members and 1 Guest are viewing this topic.

Offline Ntandrup

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
pfSense 2.3 on Nutanix CE
« on: March 22, 2017, 09:54:46 am »
I have had a few problems with getting pfSense to run on Nutanix Community Edition (AHV).

When i started i had this problem
-----------------------
Timercounter "TSC-low" frequency 1646220606 Hz quality 800
Timercounter "Hyper-V" frequency 10000000 Hz quality 10000000
Event timer "HyperV" frequency 10000000 Hz quality 1000
kernel trap 9 with interrupts disabled

Fatal trap 9: general protection fault while in kernel mode
cpuid - 0; apic id - 00
----------------------------

As you can see it also shows a Hyper-V Timecounter error. This timecounter is the real problem so here is how to solve it.
the solution comes from Nutanix KB3258

In AHV the Hyper-V clock is enabled by default. so here is how to disable it.
1. power off the VM
2. Log into any Controller VM and access acli.
         nutanix@cvm$ acli
3. type vm.list and find the VM
         <acropolis> vm.list
         VM name      VM UUID
         pfSense      xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx

4. type vm.update <vm_name> extra_flags="enable_hyperv_clock=False"
          <acropolis> vm.update pfSense extra_flags="enable_hyperv_clock=False"
          pfSense: complete

5. power on the VM

Now it just work. at least for me.