Development/Documentation > Documentation

Howto: TeamSpeak 3 server in pfSense 2.x(Now with scripts x86/x64) v1.2

(1/14) > >>

kevev:
I am posting a new thread so that we don't confuse the new easy script with the old difficult way of installing TeamSpeak on pfSense(reminder, this is a very bad idea if you worry about security).


*****Please do no ask for help if you have already tried installing TeamSpeak another way and haven't cleaned up first. Wipe your pf box, reload pfSense, try the script, then ask for help.*****


(Current Versions)
x86 v.1.2  https://drive.google.com/file/d/0B2M_XoBZxi1icVdkbFFrZm1xNEk/view?usp=sharing

x64 v.1.2  https://drive.google.com/file/d/0B2M_XoBZxi1iS1VNMk5ET0QwYm8/view?usp=sharing


1.) Depending on your architecture download the install scripts from above & teamspeak 3 FreeBSD archive from http://www.teamspeak.com

2.) Upload install scripts & archive to /root

3.)  `chmod +x /root/pfsense-teamspeak-install*.sh`

4.)  Run the install script for your architecture

         `./pfsense-teamspeak-install_x86.sh`

      or

         `./pfsense-teamspeak-install_amd64.sh`

6.) Check the output for errors. If no errors, Reboot your pfSense box(This is important)! :)

7.) Open the appropriate network ports for local and remote access to the teamspeak server:

   WAN UDP 9987

8.) After 5-10 minutes check the logs for your ServerAdmin privilege key(It takes a while for the key to be generated):

         /usr/local/lib/teamspeak3-server_freebsd-x86/logs

     or

         /usr/local/lib/teamspeak3-server_freebsd-amd64/logs

     ***Check the logs for your key. It is usually in the second log created. But not always.***

ex:
   ServerAdmin privilege key created, please use the line below
   token=v1H32gAavrEI8U718bK0WZssL9Cl39OxktQS2Q3Z

9.) When connecting your Client enter this token in the "One-Time Privelege Key:" field.

   You are now the Admin of this TS server.

kevev:
Upgrading:

1.) Shutdown the teamspeak server:

   a.) `/usr/local/etc/rc.d/teamspeak3-server.sh forcestop`

2.) `cd /usr/local/lib/`

3.) Backup the teamspeak server:

   a.) `tar -pczvf teamspeak3-server_freebsd-x86.tar.gz teamspeak3-server_freebsd-x86`

             or

   a.) `tar -pczvf teamspeak3-server_freebsd-amd64.tar.gz teamspeak3-server_freebsd-amd64`

4.) Verify the backup contains our server files:

   a.) `tar -ztvf teamspeak3-server_freebsd-x86.tar.gz`

             or

   a.) `tar -ztvf teamspeak3-server_freebsd-amd64.tar.gz`

5.) Download teamspeak 3 FreeBSD x86 or amd64 archive from http://www.teamspeak.com

6.) Upload arcive to /root

7.) `cd /root`

8.) Extract:

        a.) `tar -xzvf teamspeak3-server_freebsd-x86-*.tar.gz -C /usr/local/lib`

             or

        a.) `tar -xzvf teamspeak3-server_freebsd-amd64-*tar.gz -C /usr/local/lib`

9.) Change Ownership:

        a.) `chown -R teamspeak:teamspeak /usr/local/lib/teamspeak3-server_freebsd-x86`

             or

        a.) `chown -R teamspeak:teamspeak /usr/local/lib/teamspeak3-server_freebsd-amd64`

10.) Start the teamspeak server and verify everything works:

   a.) `/usr/local/etc/rc.d/teamspeak3-server start`

11.) If you wish to, restart the router and verify the teamspeak server starts as expected.


Migrating: https://forum.pfsense.org/index.php?topic=86681.msg481345#msg481345
*Thank You Tong.  ;)

opjohnny:
Thanks kevev!  Will be giving this a try after work today.

unKn0wn:
My ts3 not started

--- Quote ---/root(6): /usr/local/etc/rc.d/teamspeak3-server onestart
Starting teamspeak3.
su: unknown login: teamspeak
/usr/local/etc/rc.d/teamspeak3-server: WARNING: failed to start teamspeak3

--- End quote ---
need creat new user? How to do it this?
From old manual

--- Quote ---5.)  `pw user add -n teamspeak -c "TeamSpeak User" -d /usr/local/lib/teamspeak3-server_freebsd-x86 -s /usr/sbin/nologin`

6.)  `passwd teamspeak`  (Set the user's password for added security even though it will not be used because the shell is nologin`

7.)  `chown -R teamspeak:teamspeak /usr/local/lib/teamspeak3-server_freebsd-x86`

--- End quote ---
Shell i try it?

Log Ts3:

--- Quote ---2015-01-13 20:12:13.017480|INFO    |ServerLibPriv |   | TeamSpeak 3 Server  (1970-01-01 00:00:00)
2015-01-13 20:12:13.018583|INFO    |ServerLibPriv |   | SystemInformation: FreeBSD 8.3-RELEASE-p16 FreeBSD 8.3-RELEASE-p16 #0: Mon Aug 25 08:25:41 EDT 2014     root@pf2_1_1_i386.pfsense.org:/usr/obj.i386/usr/pfSensesrc/src/sys/pfSense_SMP.8 i386 Binary: 32bit
2015-01-13 20:12:13.033088|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
2015-01-13 20:12:13.033553|INFO    |DatabaseQuery |   | dbPlugin version: 3.6.21
2015-01-13 20:12:13.037913|INFO    |DatabaseQuery |   | checking database integrity (may take a while)
2015-01-13 20:12:13.206552|INFO    |SQL           |   | db_CreateTables() tables created


--- End quote ---

tong:
New user, brand new and very green to this and anything outside of Windows but here's what I got.

 Just picked up an apu device, installed pfsense on it (8g SD soon to be 30g msata). Followed these directions (first post so far), got #6 done with no errors, rebooted, configured #7 (both lan and wan), but when I got to #8, there was no log folder, tried connecting anyways but no success (thought maybe only after a connect would there be a log folder/file). I can watch the machine boot through serial console and I've seen it say starting team speak, but can't connect and there's no log file.



Another question I had is, if we have a 64bit capable machine and are using a 64bit install of pfsense, can/should we install the freebsd64 bit version of team speak instead of the x86?

Thanks a ton for doing this and trying to make it simple for beginners like me, it was your old thread instructions that finally convinced me to buy one of these and start this process of a serious net security device.


Navigation

[0] Message Index

[#] Next page

Go to full version