Netgate SG-1000 microFirewall

Author Topic: Update 2.1.5 -> 2.2.2 leads to errors  (Read 1143 times)

0 Members and 1 Guest are viewing this topic.

Offline 0tt0

  • Full Member
  • ***
  • Posts: 278
  • Karma: +0/-0
    • View Profile
Update 2.1.5 -> 2.2.2 leads to errors
« on: April 25, 2015, 04:54:54 pm »
I was updating a virtual pfS and unfortunately I was to lazy to start a snapshot..

After the update there's garbled letters on dashboard|services status|openvpn and the OpenVPN choice under VPN cannot be used, a blank page with this is the only thing that comes up:

"Fatal error: Can't use function return value in write context in /usr/local/www/vpn_openvpn_server.php on line 805 "

It is not possible to enter the OpenVPN section at all that is.


The error report that pfS wants to send contains:

PHP Errors:
[25-Apr-2015 21:45:29 Europe/Stockholm] PHP Fatal error:  Can't use function return value in write context in /usr/local/www/vpn_openvpn_server.php on line 805


2.2.2-RELEASE (i386)


Offline stephenw10

  • Administrator
  • Hero Member
  • *****
  • Posts: 12009
  • Karma: +474/-15
    • View Profile
Re: Update 2.1.5 -> 2.2.2 leads to errors
« Reply #1 on: April 25, 2015, 06:20:12 pm »
Did the VM successfully reboot after the update?
What FreeBSD kernel version is shown on the dashboard?
Did you accidentally switch to a 64bit version?

Those are things that can cause that error. Running the old kernel in a new filesystem due to reboot failure.

When did you run the update?
See: https://forum.pfsense.org/index.php?topic=92737.0

Steve

Offline 0tt0

  • Full Member
  • ***
  • Posts: 278
  • Karma: +0/-0
    • View Profile
Re: Update 2.1.5 -> 2.2.2 leads to errors
« Reply #2 on: April 25, 2015, 06:38:10 pm »
Hi,

I have done some more tests also on another VM and have now been able to update both and the error is gone.

It seems that the VMs are not being rebooted correctly, when looking at the console the menu just sits there and if you hit enter a logon prompt comes up that I wasn't able to logon to for some reason.

I tried to reset the VM but that didn't work at first but did so when doing it from the Inventory menu (ESXi).

Then after another boot the VM finally seems updated.

There seems to be something broken in the update/boot procedure.

Both VMs behaved the same way, did update through option 13 in console, auto URL.


2.2.2-RELEASE (i386)
built on Mon Apr 13 20:10:33 CDT 2015
FreeBSD 10.1-RELEASE-p9



Offline stephenw10

  • Administrator
  • Hero Member
  • *****
  • Posts: 12009
  • Karma: +474/-15
    • View Profile
Re: Update 2.1.5 -> 2.2.2 leads to errors
« Reply #3 on: April 25, 2015, 06:41:52 pm »
Hmm, interesting.
The most common cause of not rebooting is accidentally switching from 32 to 64bit or vice versa. You were running 32bit before I assume?
What hypervisor are you using?

Steve

Offline 0tt0

  • Full Member
  • ***
  • Posts: 278
  • Karma: +0/-0
    • View Profile
Re: Update 2.1.5 -> 2.2.2 leads to errors
« Reply #4 on: April 26, 2015, 05:02:33 am »
Hi,


Well as I said I used the built-in auto update via console/URL so I didn't fetch the wrong file manually.

These two VMs have been 32bit all along, have another that's newly installed that's 64 though.

Using ESXi 5.5.x but the VMs may have been running on another ESXi (5.1.x) earlier.

Thanx,


Offline 0tt0

  • Full Member
  • ***
  • Posts: 278
  • Karma: +0/-0
    • View Profile
Re: Update 2.1.5 -> 2.2.2 leads to errors
« Reply #5 on: April 26, 2015, 05:08:47 am »
This seems related:

https://forum.pfsense.org/index.php?topic=92737.0


But I did not enter the command given here but simply rebooted/reset the VM.


Offline stephenw10

  • Administrator
  • Hero Member
  • *****
  • Posts: 12009
  • Karma: +474/-15
    • View Profile
Re: Update 2.1.5 -> 2.2.2 leads to errors
« Reply #6 on: April 26, 2015, 07:31:45 am »
Yeah, that was my first thought but that's been fixed since 21st Apr so if you only updated yesterday you should not be running into that.
Odd.

Steve