pfSense Support Subscription

Author Topic: Development bootstrap fails with missing pear (6.2->6.3)  (Read 7113 times)

0 Members and 1 Guest are viewing this topic.

Offline skon

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Development bootstrap fails with missing pear (6.2->6.3)
« on: May 15, 2008, 12:40:53 pm »
Hi,

I recently needed to move my custom build to a new ALIX board.  However, the development install is based on FreeBSD 6.2, and the support files for this version is gone, so the build fails.

I thus did:
setenv PACKAGESITE ftp://ftp4.freebsd.org/pub/FreeBSD/ports/i386/packages-6-stable/Latest/

to get it to use 6.3.  However, now pear seem to be needed, but is missing:

> Executing /home/pfsense/tools/builder_scripts/build_iso.sh...
Warning: require_once(config.inc): failed to open stream: No such file or directory in /etc/rc.banner on line 34
Fatal error: require_once(): Failed opening required 'config.inc' (include_path='.:/usr/local/share/pear') in /etc/rc.banner on line 34


I tried to install pear:
cd /usr/ports/devel/pear
make install clean distclean


The the needed file fails to appear.

Any idea how to get the development system to build?

Thanks,
Jim

Offline Cry Havok

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2818
  • Karma: +5/-0
  • Backup: n. What you should have done yesterday.
    • View Profile
Re: Development bootstrap fails with missing pear (6.2->6.3)
« Reply #1 on: May 15, 2008, 01:07:51 pm »
Caution, binaries and libraries (which is what the packages contain) built on a later version may not work, or may work unpredictably, on earlier versions.

There is a post containing details of the appropriate package location - somebody here took a mirror.  I don't have a link to it to hand, but I'd expect you'd find it in the Packages forum.
If you're planning on PMing me to ask me to look at a thread, or for individual support, don't.