pfSense English Support > 2.4 Development Snapshots

OpenVPN Client Export for OpenVPN 2.4

(1/1)

jimp:
A new version of OpenVPN client export for pfSense 2.4 with OpenVPN 2.4 is up now for testing.

Key changes:
* OpenVPN 2.4 is available to download. There is only one OpenVPN 2.4 installer, but it works on both 64 and 32 bit versions of Windows. This installer requires Windows Vista or later and will not work on Windows XP
* The manager option for Windows has been removed from the export package and installer. The native OpenVPN-GUI uses the new service in OpenVPN 2.4 for managing connections, meaning unprivileged users can use OpenVPN and it will add routes properly. (Note that admin access is still required to install the OpenVPN client)
* OpenVPN 2.3.x client options remain in the export package for the time being, and they have been updated to 2.3.14
* The export package will handle many of the newly added OpenVPN 2.4 features from pfSense 2.4, such as the new compression options, TLS Encryption+Authentication, and the new protocol selection.

The exporter is not smart enough to know if you are using features specific to OpenVPN 2.4 when exporting, so it's possible you could export a 2.3 windows installer that can never work. As much as I'd like to code around this, as well as the OpenVPN 2.4 version is working I don't know how long the 2.3 installers will stick around.

If you have not yet activated any features specific to 2.4, it will work fine exporting older versions.

The same code should even work fine on pfSense 2.3.x but it needs more testing time first.

maverick_slo:
Hey Jimp.
Is Android export updated to reflect 2.4 changes as well?

Thanks!

jimp:
That shouldn't matter, but I haven't tried it yet.

If you're on pfSense 2.4 and you activate a feature that is new in OpenVPN 2.4, the exported configuration will have it no matter which type you choose. (Except NCP if you check 'legacy' when exporting).

johnkeates:
Works well over here!

Navigation

[0] Message Index

Go to full version