pfSense Gold Subscription

Author Topic: System is on a later version than the official release / Latest 0.18_1  (Read 5517 times)

0 Members and 1 Guest are viewing this topic.

Offline Cybdex

  • Jr. Member
  • **
  • Posts: 49
  • Karma: +2/-0
    • View Profile
Re: System is on a later version than the official release / Latest 0.18_1
« Reply #30 on: March 03, 2017, 02:14:25 pm »
Yeah.. since i pressed the update key in the notion of "nothing bad will happen", i was NOT expecting a full reboot.......

But well.. A couple of unhappy faces can be survived on a late friday i guess  ::)

C

Offline RonpfS

  • Hero Member
  • *****
  • Posts: 684
  • Karma: +96/-2
    • View Profile
Re: System is on a later version than the official release / Latest 0.18_1
« Reply #31 on: March 03, 2017, 05:36:38 pm »
I've pushed a fix, it's on pfSense-upgrade 0.19.

pfSense-upgrade was considering its new version as a new firmware version. The issue is harmless and if you finish the upgrade nothing bad will happen.

Fix is on version 0.19. As soon as it's available it's safe to manually run 'pkg upgrade pfSense-upgrade' on console to go to latest verssion.

This issue is being tracked at https://redmine.pfsense.org/issues/7343

Sorry for the inconvenience
So the only way to fix this "issue" is to run pkg upgrade pfSense-upgrade from the console?
And it won't reboot the box ?
2.3.5-RELEASE (amd64)
Intel Core2 Quad CPU Q8400 @ 2.66GHz 8GB
pfBlockerNG 2.1.2_1/Dev, suricata 4.0.1

Offline Cybdex

  • Jr. Member
  • **
  • Posts: 49
  • Karma: +2/-0
    • View Profile
Re: System is on a later version than the official release / Latest 0.18_1
« Reply #32 on: March 04, 2017, 05:51:22 am »
Dunno about the console command, but running the upgrade on the web-gui updated AND rebooted... But showing "you are on the latest version" now, so its "good" :)

C

Offline phil.davis

  • Hero Member
  • *****
  • Posts: 4612
  • Karma: +550/-3
    • View Profile
    • International Nepal Fellowship
Re: System is on a later version than the official release / Latest 0.18_1
« Reply #33 on: March 04, 2017, 08:52:39 am »
Mine also showed the "upgrade" to 0.20 and after pressing Confirm to let it do it, all is well reporting 2.3.3

The issue is that there are multiple "parts/packages" that make up "pfSense". Normally "parts" would be released along with actual new code that has a "proper" release version. So it would find the "main" version to display and say that "2.3.4" (for example) is available. But in this case there have been some changes/fixes to the bit called pfsense-upgrade going from about 0.16 to 0.20. The GUI code sees that 0.20<2.3.3 and thus says that the system 2.3.3 is newer than what it thinks is the release version (0.20).

I guess the code that parses the results of checking for upgrades needs to be smarter, and understand what pieces might come separately from the complete release. Then it needs to work out how to explain to the user that the "main" version is still 2.3.3 but that some component(s) upgrade is available.
As the Greek philosopher Isosceles used to say, "There are 3 sides to every triangle."
If I helped you, then help someone else - buy someone a gift from the INF catalog http://secure.inf.org/gifts/usd/

Offline kpa

  • Hero Member
  • *****
  • Posts: 1188
  • Karma: +132/-6
    • View Profile
Re: System is on a later version than the official release / Latest 0.18_1
« Reply #34 on: March 04, 2017, 09:05:45 am »
The proper solution to this would be to present two types of updates to the user, one that is the "firmware" level update and one that only updates the individual packages within a version of the firmware.

Offline java007md

  • Newbie
  • *
  • Posts: 18
  • Karma: +4/-0
    • View Profile
Re: System is on a later version than the official release / Latest 0.18_1
« Reply #35 on: March 04, 2017, 11:35:53 am »
I've pushed a fix, it's on pfSense-upgrade 0.19.

pfSense-upgrade was considering its new version as a new firmware version. The issue is harmless and if you finish the upgrade nothing bad will happen.

Fix is on version 0.19. As soon as it's available it's safe to manually run 'pkg upgrade pfSense-upgrade' on console to go to latest verssion.

This issue is being tracked at https://redmine.pfsense.org/issues/7343

Sorry for the inconvenience
So the only way to fix this "issue" is to run pkg upgrade pfSense-upgrade from the console?
And it won't reboot the box ?

Using the GUI upgrade button will fix this, but will reboot.

Using the console 'pkg upgrade pfSense-upgrade' will fix this and does not require a reboot.

Offline RonpfS

  • Hero Member
  • *****
  • Posts: 684
  • Karma: +96/-2
    • View Profile
Re: System is on a later version than the official release / Latest 0.18_1
« Reply #36 on: March 04, 2017, 01:49:09 pm »
Code: [Select]
[2.3.3-RELEASE][root@somewhere.local]/root: pkg upgrade pfSense-upgrade
Updating pfSense-core repository catalogue...
pfSense-core repository is up-to-date.
Updating pfSense repository catalogue...
pfSense repository is up-to-date.
All repositories are up-to-date.
The following 1 package(s) will be affected (of 0 checked):

Installed packages to be UPGRADED:
        pfSense-upgrade: 0.17 -> 0.20 [pfSense]

Number of packages to be upgraded: 1

11 KiB to be downloaded.

Proceed with this action? [y/N]: y
Fetching pfSense-upgrade-0.20.txz: 100%   11 KiB  11.5kB/s    00:01
Checking integrity... done (0 conflicting)
[1/1] Upgrading pfSense-upgrade from 0.17 to 0.20...
[1/1] Extracting pfSense-upgrade-0.20: 100%
[2.3.3-RELEASE][root@somewhere.local]/root:
2.3.5-RELEASE (amd64)
Intel Core2 Quad CPU Q8400 @ 2.66GHz 8GB
pfBlockerNG 2.1.2_1/Dev, suricata 4.0.1

Offline nipstech

  • Jr. Member
  • **
  • Posts: 89
  • Karma: +0/-0
    • View Profile
    • NIPSTech
Re: System is on a later version than the official release / Latest 0.18_1
« Reply #37 on: March 05, 2017, 07:14:41 am »
I'm seeing the same thing as well but am showing the latest base system as 0.20. Looked at the issue tracking and saw I'm not the only one who sees 0.20.

Offline phil.davis

  • Hero Member
  • *****
  • Posts: 4612
  • Karma: +550/-3
    • View Profile
    • International Nepal Fellowship
Re: System is on a later version than the official release / Latest 0.18_1
« Reply #38 on: March 05, 2017, 08:16:25 am »
I'm seeing the same thing as well but am showing the latest base system as 0.20. Looked at the issue tracking and saw I'm not the only one who sees 0.20.
That is true. Just do the suggested "upgrade". It will install that component that is v0.20. Then it will understand that the system as a whole is up-to-date running 2.3.3.

The logic there just needs to know that components might be needing an update, not the "system as a whole", and have a way to "explain" that to the user.
As the Greek philosopher Isosceles used to say, "There are 3 sides to every triangle."
If I helped you, then help someone else - buy someone a gift from the INF catalog http://secure.inf.org/gifts/usd/

Offline aGeekHere

  • Sr. Member
  • ****
  • Posts: 523
  • Karma: +41/-1
    • View Profile
Re: System is on a later version than the official release / Latest 0.18_1
« Reply #39 on: March 06, 2017, 02:46:43 am »
The system is on a later version than
the official release.

Current Base System
2.3.3
Latest Base System
0.20
Confirm Update

Going to try the update

Strange, it just fixed itself before I could run the update
The system is on the latest version.
« Last Edit: March 06, 2017, 02:50:07 am by aGeekHere »
Never Fear, A Geek is Here!

Offline JMarch

  • Newbie
  • *
  • Posts: 5
  • Karma: +1/-0
    • View Profile
Re: System is on a later version than the official release / Latest 0.18_1
« Reply #40 on: March 06, 2017, 09:17:54 am »
If you don't have console access just go to Diagnostics --> Command Prompt and in "Execute Shell Command" type

pkg upgrade --yes pfsense-upgrade

This will upgrade you from 0.17 to 0.20 without needing console access or to reboot.

Offline HardChargin

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: System is on a later version than the official release / Latest 0.18_1
« Reply #41 on: March 06, 2017, 08:30:57 pm »
Thanks all.  I too was caught by this and in System/Update seeing current base system 2.3.3, latest base system .20.  After reading the posts here, got the confidence to hit the confirm button, let it do it's thing, it rebooted, and now I'm back up and working along with showing 2.3.3 and system is on the latest version.

Offline johnpoz

  • Hero Member
  • *****
  • Posts: 14466
  • Karma: +1340/-200
  • Not a pfSense employee, they cannot fire me...
    • View Profile
Re: System is on a later version than the official release / Latest 0.18_1
« Reply #42 on: March 08, 2017, 05:50:48 am »
"System rebooted afterwards"

You mean you rebooted - that update pfsense-upgrade wouldn't cause a reboot.
- An intelligent man is sometimes forced to be drunk to spend time with his fools.
- Please don't PM me for personal help
- if you want to say thanks applaud or https://www.freebsdfoundation.org/donate/
1x SG-2440 2.3.4_p1 (work)
1x SG-4860 2.4.2-RELEASE-p1 (home)

Offline bimmerdriver

  • Sr. Member
  • ****
  • Posts: 507
  • Karma: +19/-3
    • View Profile
Re: System is on a later version than the official release / Latest 0.18_1
« Reply #43 on: March 08, 2017, 09:26:26 pm »
I've pushed a fix, it's on pfSense-upgrade 0.19.

pfSense-upgrade was considering its new version as a new firmware version. The issue is harmless and if you finish the upgrade nothing bad will happen.

Fix is on version 0.19. As soon as it's available it's safe to manually run 'pkg upgrade pfSense-upgrade' on console to go to latest verssion.

This issue is being tracked at https://redmine.pfsense.org/issues/7343

Sorry for the inconvenience
So the only way to fix this "issue" is to run pkg upgrade pfSense-upgrade from the console?
And it won't reboot the box ?

Using the GUI upgrade button will fix this, but will reboot.

Using the console 'pkg upgrade pfSense-upgrade' will fix this and does not require a reboot.
The console command worked for me. It did not require a reboot, as you said.

Offline jwt

  • Administrator
  • Sr. Member
  • *****
  • Posts: 344
  • Karma: +101/-31
    • View Profile
Re: System is on a later version than the official release / Latest 0.18_1
« Reply #44 on: March 09, 2017, 07:37:25 pm »
fixed in 2.3.3_p1