pfSense Gold Subscription

Author Topic: I have a problem with my Portal captif  (Read 143 times)

0 Members and 1 Guest are viewing this topic.

Offline yfarouq

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
I have a problem with my Portal captif
« on: July 17, 2017, 05:19:30 am »
Hello,

Im trying to use Portal captif and active directory authentication, but i didn't succeded on it, I think my configuration is wrong, I try to search for help but nothing
Could u please help me :)

This is my config :
Server Address : 192.168.xx.xx
Server Port : 389
Identity : CN=Yassine xxx,OU=Employees,OU=Domain Users,DC=xxx,DC=com
Password :
Base DN : DC=xxx,DC=com
Filter : (samAccountName=%{Stripped-User-Name}: -% {User-Name}})
Base Filter : (&(objectCategory=Person)(samAccountName=*)(memberOf=OU=Employees,OU=Domain Users,DC=xxx,DC=com))

Online Gertjan

  • Hero Member
  • *****
  • Posts: 1948
  • Karma: +158/-6
    • View Profile
Re: I have a problem with my Portal captif
« Reply #1 on: July 17, 2017, 05:59:41 am »
.....
This is my config :
Server Address : 192.168.xx.xx
Server Port : 389
Identity : CN=Yassine xxx,OU=Employees,OU=Domain Users,DC=xxx,DC=com
Password :
Base DN : DC=xxx,DC=com
Filter : (samAccountName=%{Stripped-User-Name}: -% {User-Name}})
Base Filter : (&(objectCategory=Person)(samAccountName=*)(memberOf=OU=Employees,OU=Domain Users,DC=xxx,DC=com))
Nice, but what is the problem ?
Please, saying "doesn't work" won't do. Just a few people use AD authentication, even less visit this forum and a sub-part of that would be able to post IF they could understand what the problem is.

Offline yfarouq

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: I have a problem with my Portal captif
« Reply #2 on: July 17, 2017, 06:06:31 am »
When I tried to authenticate with a user from AD, it doesn't work, while when i create a user into freeradius and try to authenticate with it works.

I think my problem is "Filter" and "Base Filter"

Offline yfarouq

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: I have a problem with my Portal captif
« Reply #3 on: July 17, 2017, 07:20:24 am »
Could someone help me please ??????