Netgate SG-1000 microFirewall

Author Topic: none2@pci - missing wireless device  (Read 348 times)

0 Members and 1 Guest are viewing this topic.

Offline wifiuk

  • Jr. Member
  • **
  • Posts: 80
  • Karma: +1/-0
    • View Profile
none2@pci - missing wireless device
« on: August 04, 2017, 10:45:19 am »
i have recently got a new box to put my pfsense on (moving from an old pc to a dedicated box)

anyway the all in one box, like the SG-2440 has an inbuilt wireless card


when i run

Quote
pciconf -l -v

i can see the device as

Quote
none2@pci0:4:0:0 blah blah etc

But i can't see this at all anywhere in the pfsense  GUI, how do i add this as the wireless interface?


IIRC , the wireless card is 802.11ac, assuming this might be a driver problem?
« Last Edit: August 04, 2017, 10:49:46 am by wifiuk »

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 21387
  • Karma: +1432/-26
    • View Profile
Re: none2@pci - missing wireless device
« Reply #1 on: August 14, 2017, 02:39:06 pm »
That means there is no driver available for that card.

You can try a 2.4 snapshot, but it's possible that there is no driver for FreeBSD at all, or perhaps that it isn't present in our builds.

Do you know what make/model card that is, specifically? If you post the full "pciconf -lvb" output for it, the card and chipid should let you find what it is.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline wifiuk

  • Jr. Member
  • **
  • Posts: 80
  • Karma: +1/-0
    • View Profile
Re: none2@pci - missing wireless device
« Reply #2 on: August 14, 2017, 03:47:03 pm »
there are a few none@

but the none2@pci is as follows:-

Code: [Select]
none2@pci0:4:0:0: class=0x028000 card=0x00708086 chip=0x08b38086 rev=0x83 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Wireless 3160'
    class      = network
    bar   [10] = type Memory, range 64, base 0xf7900000, size 8192, enabled

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 21387
  • Karma: +1432/-26
    • View Profile
Re: none2@pci - missing wireless device
« Reply #3 on: August 15, 2017, 07:16:15 am »
We don't have a driver for that one, but it may make it into 2.4.x at some point: https://redmine.pfsense.org/issues/7725
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline wifiuk

  • Jr. Member
  • **
  • Posts: 80
  • Karma: +1/-0
    • View Profile
Re: none2@pci - missing wireless device
« Reply #4 on: October 13, 2017, 02:18:30 pm »
just updated, still not supported  :(


fingers crossed in a future build....