The pfSense Store

Author Topic: Atheros WiFi mini PCI-E AR5B95 HELP  (Read 223 times)

0 Members and 1 Guest are viewing this topic.

Offline gelcom

  • Jr. Member
  • **
  • Posts: 55
  • Karma: +0/-0
    • View Profile
Atheros WiFi mini PCI-E AR5B95 HELP
« on: September 04, 2017, 08:12:30 am »
Guys, I've been trying for the last 2 weeks install a WiFi mini PCI-E Atheros Ar5b95 in my PFsense box with no success. The card is not recognized by the system by any ways.

My pfsense is 2.3.4-RELEASE-p1 (amd64)

My /boot/loader.conf.local is like above:
Code: [Select]
kern.cam.boot_delay=10000
legal.intel_ipw.license_ack=1
legal.intel_wpi.license_ack=1
legal.intel_iwi.license_ack=1
if_ath_load="YES"
if_ath_pci_load="YES"
if_ath_hal_load="YES"
hw.ath.debug="1"
hw.ath.hal.debug="1"


dmesg:
Code: [Select]
Copyright (c) 1992-2016 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 10.3-RELEASE-p19 #1 76a12c4e6(RELENG_2_3_4): Fri Jul 14 15:02:35 CDT 2017
    root@ce23-amd64-builder:/builder/pfsense-234/tmp/obj/builder/pfsense-234/tmp/FreeBSD-src/sys/pfSense amd64
FreeBSD clang version 3.4.1 (tags/RELEASE_34/dot1-final 208032) 20140512
CPU: Intel(R) Core(TM) i7-4790T CPU @ 2.70GHz (2693.82-MHz K8-class CPU)
  Origin="GenuineIntel"  Id=0x306c3  Family=0x6  Model=0x3c  Stepping=3
  Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
  Features2=0x7ffafbff<SSE3,PCLMULQDQ,DTES64,MON,DS_CPL,VMX,SMX,EST,TM2,SSSE3,SDBG,FMA,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,TSCDLT,AESNI,XSAVE,OSXSAVE,AVX,F16C,RDRAND>
  AMD Features=0x2c100800<SYSCALL,NX,Page1GB,RDTSCP,LM>
  AMD Features2=0x21<LAHF,ABM>
  Structured Extended Features=0x2fbb<FSGSBASE,TSCADJ,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,NFPUSG>
  XSAVE Features=0x1<XSAVEOPT>
  VT-x: PAT,HLT,MTF,PAUSE,EPT,UG,VPID
  TSC: P-state invariant, performance statistics
real memory  = 4294967296 (4096 MB)
avail memory = 4025741312 (3839 MB)
Event timer "LAPIC" quality 600
ACPI APIC Table: <ALASKA A M I>
FreeBSD/SMP: Multiprocessor System Detected: 8 CPUs
FreeBSD/SMP: 1 package(s) x 4 core(s) x 2 SMT threads
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
 cpu2 (AP): APIC ID:  2
 cpu3 (AP): APIC ID:  3
 cpu4 (AP): APIC ID:  4
 cpu5 (AP): APIC ID:  5
 cpu6 (AP): APIC ID:  6
 cpu7 (AP): APIC ID:  7
random: <Software, Yarrow> initialized
ioapic0 <Version 2.0> irqs 0-23 on motherboard
wlan: mac acl policy registered
netmap: loaded module
kbd1 at kbdmux0
cryptosoft0: <software crypto> on motherboard
padlock0: No ACE support.
acpi0: <ALASKA A M I> on motherboard
acpi0: Power Button (fixed)
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
cpu2: <ACPI CPU> on acpi0
cpu3: <ACPI CPU> on acpi0
cpu4: <ACPI CPU> on acpi0
cpu5: <ACPI CPU> on acpi0
cpu6: <ACPI CPU> on acpi0
cpu7: <ACPI CPU> on acpi0
hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
Timecounter "HPET" frequency 14318180 Hz quality 950
Event timer "HPET" frequency 14318180 Hz quality 550
atrtc0: <AT realtime clock> port 0x70-0x77 irq 8 on acpi0
atrtc0: Warning: Couldn't map I/O.
Event timer "RTC" frequency 32768 Hz quality 0
attimer0: <AT timer> port 0x40-0x43,0x50-0x53 irq 0 on acpi0
Timecounter "i8254" frequency 1193182 Hz quality 0
Event timer "i8254" frequency 1193182 Hz quality 100
Timecounter "ACPI-fast" frequency 3579545 Hz quality 900
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1808-0x180b on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> irq 16 at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
igb0: <Intel(R) PRO/1000 Network Connection, Version - 2.5.3-k> port 0xe060-0xe07f mem 0xf7580000-0xf75fffff,0xf760c000-0xf760ffff irq 16 at device 0.0 on pci1
igb0: Using MSIX interrupts with 9 vectors
igb0: Ethernet address: 00:90:27:e1:2d:93
igb0: Bound queue 0 to cpu 0
igb0: Bound queue 1 to cpu 1
igb0: Bound queue 2 to cpu 2
igb0: Bound queue 3 to cpu 3
igb0: Bound queue 4 to cpu 4
igb0: Bound queue 5 to cpu 5
igb0: Bound queue 6 to cpu 6
igb0: Bound queue 7 to cpu 7
igb0: netmap queues/slots: TX 8/1024, RX 8/1024
igb1: <Intel(R) PRO/1000 Network Connection, Version - 2.5.3-k> port 0xe040-0xe05f mem 0xf7500000-0xf757ffff,0xf7608000-0xf760bfff irq 17 at device 0.1 on pci1
igb1: Using MSIX interrupts with 9 vectors
igb1: Ethernet address: 00:90:27:e1:2d:94
igb1: Bound queue 0 to cpu 0
igb1: Bound queue 1 to cpu 1
igb1: Bound queue 2 to cpu 2
igb1: Bound queue 3 to cpu 3
igb1: Bound queue 4 to cpu 4
igb1: Bound queue 5 to cpu 5
igb1: Bound queue 6 to cpu 6
igb1: Bound queue 7 to cpu 7
igb1: netmap queues/slots: TX 8/1024, RX 8/1024
igb2: <Intel(R) PRO/1000 Network Connection, Version - 2.5.3-k> port 0xe020-0xe03f mem 0xf7480000-0xf74fffff,0xf7604000-0xf7607fff irq 18 at device 0.2 on pci1
igb2: Using MSIX interrupts with 9 vectors
igb2: Ethernet address: 00:90:27:e1:2d:95
igb2: Bound queue 0 to cpu 0
igb2: Bound queue 1 to cpu 1
igb2: Bound queue 2 to cpu 2
igb2: Bound queue 3 to cpu 3
igb2: Bound queue 4 to cpu 4
igb2: Bound queue 5 to cpu 5
igb2: Bound queue 6 to cpu 6
igb2: Bound queue 7 to cpu 7
igb2: netmap queues/slots: TX 8/1024, RX 8/1024
igb3: <Intel(R) PRO/1000 Network Connection, Version - 2.5.3-k> port 0xe000-0xe01f mem 0xf7400000-0xf747ffff,0xf7600000-0xf7603fff irq 19 at device 0.3 on pci1
igb3: Using MSIX interrupts with 9 vectors
igb3: Ethernet address: 00:90:27:e1:2d:96
igb3: Bound queue 0 to cpu 0
igb3: Bound queue 1 to cpu 1
igb3: Bound queue 2 to cpu 2
igb3: Bound queue 3 to cpu 3
igb3: Bound queue 4 to cpu 4
igb3: Bound queue 5 to cpu 5
igb3: Bound queue 6 to cpu 6
igb3: Bound queue 7 to cpu 7
igb3: netmap queues/slots: TX 8/1024, RX 8/1024
vgapci0: <VGA-compatible display> port 0xf000-0xf03f mem 0xf7000000-0xf73fffff,0xe0000000-0xefffffff irq 16 at device 2.0 on pci0
agp0: <Haswell desktop GT2> on vgapci0
agp0: aperture size is 256M, detected 32764k stolen memory
vgapci0: Boot video device
hdac0: <Intel Haswell HDA Controller> mem 0xf7f10000-0xf7f13fff irq 16 at device 3.0 on pci0
xhci0: <Intel Lynx Point USB 3.0 controller> mem 0xf7f00000-0xf7f0ffff irq 16 at device 20.0 on pci0
xhci0: 32 bytes context size, 64-bit DMA
xhci0: Port routing mask set to 0xffffffff
usbus0 on xhci0
pci0: <simple comms> at device 22.0 (no driver attached)
ehci0: <Intel Lynx Point USB 2.0 controller USB-B> mem 0xf7f18000-0xf7f183ff irq 16 at device 26.0 on pci0
usbus1: EHCI version 1.0
usbus1 on ehci0
pcib2: <ACPI PCI-PCI bridge> irq 16 at device 28.0 on pci0
pci2: <ACPI PCI bus> on pcib2
em0: <Intel(R) PRO/1000 Network Connection 7.6.1-k> port 0xd000-0xd01f mem 0xf7e00000-0xf7e1ffff,0xf7e20000-0xf7e23fff irq 16 at device 0.0 on pci2
em0: Using MSIX interrupts with 3 vectors
em0: Ethernet address: 00:90:28:01:2e:f1
em0: netmap queues/slots: TX 1/1024, RX 1/1024
pcib3: <ACPI PCI-PCI bridge> irq 17 at device 28.1 on pci0
pci3: <ACPI PCI bus> on pcib3
em1: <Intel(R) PRO/1000 Network Connection 7.6.1-k> port 0xc000-0xc01f mem 0xf7d00000-0xf7d1ffff,0xf7d20000-0xf7d23fff irq 17 at device 0.0 on pci3
em1: Using MSIX interrupts with 3 vectors
em1: Ethernet address: 00:90:28:01:2e:f2
em1: netmap queues/slots: TX 1/1024, RX 1/1024
pcib4: <ACPI PCI-PCI bridge> irq 18 at device 28.2 on pci0
pci4: <ACPI PCI bus> on pcib4
em2: <Intel(R) PRO/1000 Network Connection 7.6.1-k> port 0xb000-0xb01f mem 0xf7c00000-0xf7c1ffff,0xf7c20000-0xf7c23fff irq 18 at device 0.0 on pci4
em2: Using MSIX interrupts with 3 vectors
em2: Ethernet address: 00:90:28:01:2e:f3
em2: netmap queues/slots: TX 1/1024, RX 1/1024
pcib5: <ACPI PCI-PCI bridge> irq 19 at device 28.3 on pci0
pci5: <ACPI PCI bus> on pcib5
em3: <Intel(R) PRO/1000 Network Connection 7.6.1-k> port 0xa000-0xa01f mem 0xf7b00000-0xf7b1ffff,0xf7b20000-0xf7b23fff irq 19 at device 0.0 on pci5
em3: Using MSIX interrupts with 3 vectors
em3: Ethernet address: 00:90:28:01:2e:f4
em3: netmap queues/slots: TX 1/1024, RX 1/1024
pcib6: <ACPI PCI-PCI bridge> irq 16 at device 28.4 on pci0
pci6: <ACPI PCI bus> on pcib6
em4: <Intel(R) PRO/1000 Network Connection 7.6.1-k> port 0x9000-0x901f mem 0xf7a00000-0xf7a1ffff,0xf7a20000-0xf7a23fff irq 16 at device 0.0 on pci6
em4: Using MSIX interrupts with 3 vectors
em4: Ethernet address: 00:90:28:01:2e:f5
em4: netmap queues/slots: TX 1/1024, RX 1/1024
pcib7: <ACPI PCI-PCI bridge> irq 17 at device 28.5 on pci0
pci7: <ACPI PCI bus> on pcib7
em5: <Intel(R) PRO/1000 Network Connection 7.6.1-k> port 0x8000-0x801f mem 0xf7900000-0xf791ffff,0xf7920000-0xf7923fff irq 17 at device 0.0 on pci7
em5: Using MSIX interrupts with 3 vectors
em5: Ethernet address: 00:90:28:01:2e:f6
em5: netmap queues/slots: TX 1/1024, RX 1/1024
pcib8: <ACPI PCI-PCI bridge> irq 18 at device 28.6 on pci0
pci8: <ACPI PCI bus> on pcib8
em6: <Intel(R) PRO/1000 Network Connection 7.6.1-k> port 0x7000-0x701f mem 0xf7800000-0xf781ffff,0xf7820000-0xf7823fff irq 18 at device 0.0 on pci8
em6: Using MSIX interrupts with 3 vectors
em6: Ethernet address: 00:90:28:01:2e:f7
em6: netmap queues/slots: TX 1/1024, RX 1/1024
pcib9: <ACPI PCI-PCI bridge> irq 19 at device 28.7 on pci0
pci9: <ACPI PCI bus> on pcib9
em7: <Intel(R) PRO/1000 Network Connection 7.6.1-k> port 0x6000-0x601f mem 0xf7700000-0xf771ffff,0xf7720000-0xf7723fff irq 19 at device 0.0 on pci9
em7: Using MSIX interrupts with 3 vectors
em7: Ethernet address: 00:90:28:01:2e:f8
em7: netmap queues/slots: TX 1/1024, RX 1/1024
ehci1: <Intel Lynx Point USB 2.0 controller USB-A> mem 0xf7f17000-0xf7f173ff irq 23 at device 29.0 on pci0
usbus2: EHCI version 1.0
usbus2 on ehci1
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
ahci0: <Intel Lynx Point AHCI SATA controller> port 0xf0b0-0xf0b7,0xf0a0-0xf0a3,0xf090-0xf097,0xf080-0xf083,0xf060-0xf07f mem 0xf7f16000-0xf7f167ff irq 19 at device 31.2 on pci0
ahci0: AHCI v1.30 with 6 6Gbps ports, Port Multiplier not supported
ahcich1: <AHCI channel> at channel 1 on ahci0
ahciem0: <AHCI enclosure management bridge> on ahci0
acpi_button0: <Power Button> on acpi0
acpi_tz0: <Thermal Zone> on acpi0
acpi_tz1: <Thermal Zone> on acpi0
uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
uart1: <16550 or compatible> port 0x2f8-0x2ff irq 3 on acpi0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
ppc0: cannot reserve I/O port range
est0: <Enhanced SpeedStep Frequency Control> on cpu0
est1: <Enhanced SpeedStep Frequency Control> on cpu1
est2: <Enhanced SpeedStep Frequency Control> on cpu2
est3: <Enhanced SpeedStep Frequency Control> on cpu3
est4: <Enhanced SpeedStep Frequency Control> on cpu4
est5: <Enhanced SpeedStep Frequency Control> on cpu5
est6: <Enhanced SpeedStep Frequency Control> on cpu6
est7: <Enhanced SpeedStep Frequency Control> on cpu7
Timecounters tick every 1.000 msec
hdacc0: <Intel Haswell HDA CODEC> at cad 0 on hdac0
hdaa0: <Intel Haswell Audio Function Group> at nid 1 on hdacc0
pcm0: <Intel Haswell (HDMI/DP 8ch)> at nid 3 on hdaa0
random: unblocking device.
usbus0: 5.0Gbps Super Speed USB v3.0
usbus1: 480Mbps High Speed USB v2.0
usbus2: 480Mbps High Speed USB v2.0
ugen2.1: <Intel> at usbus2
uhub0: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus2
ugen1.1: <Intel> at usbus1
uhub1: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus1
ugen0.1: <0x8086> at usbus0
uhub2: <0x8086 XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus0
uhub0: 2 ports with 2 removable, self powered
uhub1: 2 ports with 2 removable, self powered
uhub2: 21 ports with 21 removable, self powered
ugen2.2: <vendor 0x8087> at usbus2
uhub3: <vendor 0x8087 product 0x8000, class 9/0, rev 2.00/0.05, addr 2> on usbus2
ugen1.2: <vendor 0x8087> at usbus1
uhub4: <vendor 0x8087 product 0x8008, class 9/0, rev 2.00/0.05, addr 2> on usbus1
uhub4: 6 ports with 6 removable, self powered
uhub3: 8 ports with 8 removable, self powered
ses0 at ahciem0 bus 0 scbus1 target 0 lun 0
ses0: <AHCI SGPIO Enclosure 1.00 0001> SEMB S-E-S 2.00 device
ses0: SEMB SES Device
ada0 at ahcich1 bus 0 scbus0 target 0 lun 0
ada0: <INTEL SSDSC2BW120H6 RG20> ACS-3 ATA SATA 3.x device
ada0: Serial Number CVTR523204PX120AGN
ada0: 600.000MB/s transfers (SATA 3.x, UDMA6, PIO 8192bytes)
ada0: Command Queueing enabled
ada0: 114473MB (234441648 512 byte sectors)
ada0: quirks=0x1<4K>
ada0: Previously was known as ad4
SMP: AP CPU #1 Launched!
SMP: AP CPU #2 Launched!
SMP: AP CPU #5 Launched!
SMP: AP CPU #6 Launched!
SMP: AP CPU #4 Launched!
SMP: AP CPU #3 Launched!
SMP: AP CPU #7 Launched!
Timecounter "TSC-low" frequency 1346911190 Hz quality 1000
Trying to mount root from ufs:/dev/ufsid/597c9240b1c6b067 [rw]...
WARNING: / was not properly dismounted
padlock0: No ACE support.
aesni0: <AES-CBC,AES-XTS,AES-GCM,AES-ICM> on motherboard
coretemp0: <CPU On-Die Thermal Sensors> on cpu0
coretemp1: <CPU On-Die Thermal Sensors> on cpu1
coretemp2: <CPU On-Die Thermal Sensors> on cpu2
coretemp3: <CPU On-Die Thermal Sensors> on cpu3
coretemp4: <CPU On-Die Thermal Sensors> on cpu4
coretemp5: <CPU On-Die Thermal Sensors> on cpu5
coretemp6: <CPU On-Die Thermal Sensors> on cpu6
coretemp7: <CPU On-Die Thermal Sensors> on cpu7
vlan0: changing name to 'em5_vlan5'
vlan1: changing name to 'em5_vlan6'
vlan2: changing name to 'em5_vlan7'
vlan3: changing name to 'em5_vlan9'
em5: link state changed to UP
em5_vlan5: link state changed to UP
em5_vlan6: link state changed to UP
em5_vlan7: link state changed to UP
em5_vlan9: link state changed to UP
em0: link state changed to UP
igb0: link state changed to UP
bridge0: Ethernet address: 02:47:8c:95:a5:00
bridge0: link state changed to UP
em5: promiscuous mode enabled
em5_vlan7: promiscuous mode enabled
em3: promiscuous mode enabled
tun1: changing name to 'ovpns1'
ovpns1: link state changed to UP
pflog0: promiscuous mode enabled
em1: link state changed to UP
ipfw2 (+ipv6) initialized, divert loadable, nat loadable, default to accept, logging disabled
DUMMYNET 0 with IPv6 initialized (100409)
load_dn_sched dn_sched FIFO loaded
load_dn_sched dn_sched QFQ loaded
load_dn_sched dn_sched RR loaded
load_dn_sched dn_sched WF2Q+ loaded
load_dn_sched dn_sched PRIO loaded
em2: link state changed to UP
em6: promiscuous mode enabled
em6: link state changed to UP


pciconf -lv :
Code: [Select]
hostb0@pci0:0:0:0: class=0x060000 card=0x0c008086 chip=0x0c008086 rev=0x06 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '4th Gen Core Processor DRAM Controller'
    class      = bridge
    subclass   = HOST-PCI
pcib1@pci0:0:1:0: class=0x060400 card=0x0c018086 chip=0x0c018086 rev=0x06 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = 'Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller'
    class      = bridge
    subclass   = PCI-PCI
vgapci0@pci0:0:2:0: class=0x030000 card=0x04128086 chip=0x04128086 rev=0x06 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller'
    class      = display
    subclass   = VGA
hdac0@pci0:0:3:0: class=0x040300 card=0x0c0c8086 chip=0x0c0c8086 rev=0x06 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller'
    class      = multimedia
    subclass   = HDA
xhci0@pci0:0:20:0: class=0x0c0330 card=0x8c318086 chip=0x8c318086 rev=0x05 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '8 Series/C220 Series Chipset Family USB xHCI'
    class      = serial bus
    subclass   = USB
none0@pci0:0:22:0: class=0x078000 card=0x8c3a8086 chip=0x8c3a8086 rev=0x04 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '8 Series/C220 Series Chipset Family MEI Controller'
    class      = simple comms
ehci0@pci0:0:26:0: class=0x0c0320 card=0x8c2d8086 chip=0x8c2d8086 rev=0x05 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '8 Series/C220 Series Chipset Family USB EHCI'
    class      = serial bus
    subclass   = USB
pcib2@pci0:0:28:0: class=0x060400 card=0x8c108086 chip=0x8c108086 rev=0xd5 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '8 Series/C220 Series Chipset Family PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
pcib3@pci0:0:28:1: class=0x060400 card=0x8c128086 chip=0x8c128086 rev=0xd5 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '8 Series/C220 Series Chipset Family PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
pcib4@pci0:0:28:2: class=0x060400 card=0x8c148086 chip=0x8c148086 rev=0xd5 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '8 Series/C220 Series Chipset Family PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
pcib5@pci0:0:28:3: class=0x060400 card=0x8c168086 chip=0x8c168086 rev=0xd5 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '8 Series/C220 Series Chipset Family PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
pcib6@pci0:0:28:4: class=0x060400 card=0x8c188086 chip=0x8c188086 rev=0xd5 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '8 Series/C220 Series Chipset Family PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
pcib7@pci0:0:28:5: class=0x060400 card=0x8c1a8086 chip=0x8c1a8086 rev=0xd5 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '8 Series/C220 Series Chipset Family PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
pcib8@pci0:0:28:6: class=0x060400 card=0x8c1c8086 chip=0x8c1c8086 rev=0xd5 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '8 Series/C220 Series Chipset Family PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
pcib9@pci0:0:28:7: class=0x060400 card=0x8c1e8086 chip=0x8c1e8086 rev=0xd5 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '8 Series/C220 Series Chipset Family PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
ehci1@pci0:0:29:0: class=0x0c0320 card=0x8c268086 chip=0x8c268086 rev=0x05 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '8 Series/C220 Series Chipset Family USB EHCI'
    class      = serial bus
    subclass   = USB
isab0@pci0:0:31:0: class=0x060100 card=0x8c4a8086 chip=0x8c4a8086 rev=0x05 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'H87 Express LPC Controller'
    class      = bridge
    subclass   = PCI-ISA
ahci0@pci0:0:31:2: class=0x010601 card=0x8c028086 chip=0x8c028086 rev=0x05 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode]'
    class      = mass storage
    subclass   = SATA
none1@pci0:0:31:3: class=0x0c0500 card=0x8c228086 chip=0x8c228086 rev=0x05 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '8 Series/C220 Series Chipset Family SMBus Controller'
    class      = serial bus
    subclass   = SMBus
igb0@pci0:1:0:0: class=0x020000 card=0x00008086 chip=0x150f8086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82580 Gigabit Fiber Network Connection'
    class      = network
    subclass   = ethernet
igb1@pci0:1:0:1: class=0x020000 card=0x00008086 chip=0x150f8086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82580 Gigabit Fiber Network Connection'
    class      = network
    subclass   = ethernet
igb2@pci0:1:0:2: class=0x020000 card=0x00008086 chip=0x150f8086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82580 Gigabit Fiber Network Connection'
    class      = network
    subclass   = ethernet
igb3@pci0:1:0:3: class=0x020000 card=0x00008086 chip=0x150f8086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82580 Gigabit Fiber Network Connection'
    class      = network
    subclass   = ethernet
em0@pci0:2:0:0: class=0x020000 card=0x6c401462 chip=0x10d38086 rev=0x00 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82574L Gigabit Network Connection'
    class      = network
    subclass   = ethernet
em1@pci0:3:0:0: class=0x020000 card=0x6c401462 chip=0x10d38086 rev=0x00 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82574L Gigabit Network Connection'
    class      = network
    subclass   = ethernet
em2@pci0:4:0:0: class=0x020000 card=0x6c401462 chip=0x10d38086 rev=0x00 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82574L Gigabit Network Connection'
    class      = network
    subclass   = ethernet
em3@pci0:5:0:0: class=0x020000 card=0x6c401462 chip=0x10d38086 rev=0x00 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82574L Gigabit Network Connection'
    class      = network
    subclass   = ethernet
em4@pci0:6:0:0: class=0x020000 card=0x6c401462 chip=0x10d38086 rev=0x00 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82574L Gigabit Network Connection'
    class      = network
    subclass   = ethernet
em5@pci0:7:0:0: class=0x020000 card=0x6c401462 chip=0x10d38086 rev=0x00 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82574L Gigabit Network Connection'
    class      = network
    subclass   = ethernet
em6@pci0:8:0:0: class=0x020000 card=0x6c401462 chip=0x10d38086 rev=0x00 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82574L Gigabit Network Connection'
    class      = network
    subclass   = ethernet
em7@pci0:9:0:0: class=0x020000 card=0x6c401462 chip=0x10d38086 rev=0x00 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82574L Gigabit Network Connection'
    class      = network
    subclass   = ethernet

No atheros here either...

What am I doing wrong? I suppose this Atheros chipset is fully compatible with Pfsense.

I have 4 different Ar5b95 mini pci-e boards in here and none of them seems to work.

Any help is appreciated...

kind regards
GWR

Offline gelcom

  • Jr. Member
  • **
  • Posts: 55
  • Karma: +0/-0
    • View Profile
Re: Atheros WiFi mini PCI-E AR5B95 HELP
« Reply #1 on: September 05, 2017, 03:11:52 pm »
I've just ordered a new Atheros Ar5bxb72 and the same: not recognized either.

Any help is appreciated!

kind regards

Offline Gertjan

  • Hero Member
  • *****
  • Posts: 2071
  • Karma: +166/-9
    • View Profile
Re: Atheros WiFi mini PCI-E AR5B95 HELP
« Reply #2 on: September 06, 2017, 10:09:29 am »
Hi,

Before buying ANY device, first check if it support by the 'FreeBSD OS''.
Then, and I can't actually tell you how to do so, but  : check if the needed drivers are actually complied in - or, if they can be added afterwards ...
Default : use an external AP.

Offline gelcom

  • Jr. Member
  • **
  • Posts: 55
  • Karma: +0/-0
    • View Profile
Re: Atheros WiFi mini PCI-E AR5B95 HELP
« Reply #3 on: September 06, 2017, 12:10:04 pm »
According to FreeBSD website most of Atheros chipsets work:

https://www.freebsd.org/releases/10.3R/hardware.html#wlan
Quote
The ath(4) driver supports all Atheros Cardbus and PCI cards, except those that are based on the AR5005VL chipset.

Atheros Ar5b95 and Ar5bxb72 are reported to work according to PfSense forum users:

Atheros Ar5b95:
Just installed a Atheros AR5B95 in the firewall today. No problems being recognized and seems to be working fine in 2.1. I bought from Ebay.

http://www.ebay.com/itm/400518805326?ssPageName=STRK:MEWAX:IT&_trksid=p3984.m1423.l2649

Any ideas on how to investigate whats the problem in here?

As I tested 4 different pci boards I'm quite sure this is not an issue of wifi malfunction.

kind regards

Offline dotdash

  • Hero Member
  • *****
  • Posts: 1915
  • Karma: +99/-2
    • View Profile
Re: Atheros WiFi mini PCI-E AR5B95 HELP
« Reply #4 on: September 06, 2017, 12:43:51 pm »
Try the card in a different box, it could be an issue with the motherboard, I've used AR5B95 cards before. You don't need any of that stuff in the loader.conf.local, try removing it.
What is the box? It might be easier to put an external AP off of one of your twelve nics.

Offline gelcom

  • Jr. Member
  • **
  • Posts: 55
  • Karma: +0/-0
    • View Profile
Re: Atheros WiFi mini PCI-E AR5B95 HELP
« Reply #5 on: September 06, 2017, 01:51:41 pm »
Try the card in a different box, it could be an issue with the motherboard, I've used AR5B95 cards before. You don't need any of that stuff in the loader.conf.local, try removing it.
all cards work ok in a different box (not pfsense). Maybe this is an issue with FreeBSD not recognizing the board as pciconf -lv not even show the mini pcie board in there. This is really strange.
loader.conf.local cleared... still no good.

What is the box? It might be easier to put an external AP off of one of your twelve nics.
This is the box with this expansion card.

It might be easier to put an external AP off of one of your twelve nics.
This is the current setup but I would like to move to a 'all in one' box and no external AP to 'simplifly' my setup.

Is there a way to debug why  pciconf -lv shows no Atheros PCIe card?

I noticed also that I have 'none0' and none1' in pciconf. Maybe some missing PCIe bus drivers?
Quote
none0@pci0:0:22:0:   class=0x078000 card=0x8c3a8086 chip=0x8c3a8086 rev=0x04 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '8 Series/C220 Series Chipset Family MEI Controller'
    class      = simple comms

none1@pci0:0:31:3:   class=0x0c0500 card=0x8c228086 chip=0x8c228086 rev=0x05 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '8 Series/C220 Series Chipset Family SMBus Controller'
    class      = serial bus
    subclass   = SMBus

kind regards
« Last Edit: September 06, 2017, 01:55:49 pm by gelcom »

Offline dotdash

  • Hero Member
  • *****
  • Posts: 1915
  • Karma: +99/-2
    • View Profile
Re: Atheros WiFi mini PCI-E AR5B95 HELP
« Reply #6 on: September 06, 2017, 02:16:13 pm »
all cards work ok in a different box (not pfsense). Maybe this is an issue with FreeBSD not recognizing the board as pciconf -lv not even show the mini pcie board in there. This is really strange.
I think there is something incompatible with the motherboard. I'd try loading another OS on it (Linux live bootstick?) and see if it recognizes the card. The chipset in general shouldn't be a problem with FreeBSD, is it possible the unit has a bad mini-pcie slot?

Offline gelcom

  • Jr. Member
  • **
  • Posts: 55
  • Karma: +0/-0
    • View Profile
Re: Atheros WiFi mini PCI-E AR5B95 HELP
« Reply #7 on: September 13, 2017, 08:30:22 am »
I think there is something incompatible with the motherboard. I'd try loading another OS on it (Linux live bootstick?) and see if it recognizes the card. The chipset in general shouldn't be a problem with FreeBSD, is it possible the unit has a bad mini-pcie slot?

Indeed. This unit has a mini-pci slot that only accepts WWLAN 3G/4G cards and not WiFi cards. I got this info from motherboard supplier.

Thanks for the help!! :)

kind regards