International Support > Polish

wydajność kart sieciowych

(1/1)

wloczykij78:
Witam serdecznie.
Postawiłem niedawno pfsense na dość leciwym Dellu (Pentium 4 2.80 GHz, 2GB RAM). Kilkanaście VLANów, wychodzących na dwa WANY (DSL i Neo, oba po około 40Mbit/s. Na pokładzie zintegrowana 10/100 , plus 4 realteki 8139 - dwa nieużywane, jeden do LAN drugi do WAN1, WAN2 wpięty do zintegrowanej.

Problem jest następujący - przy większym ruchu, dochodzącym do mniej więcej 10-15Mbit/s na łącze, transmisja zaczyna się sypać. Straty pakietów na obu bramach zaczynają dochodzić do 30-40% i następuje zwiecha transmisji. Wskaźniki obciążenia RAM,CPU i "czegośtam" w okolicy 20% w szczycie, więc nie ma nic niepokojącego. Podejrzewam, że nieszczęsne karty sieciowe najzwyczajniej w świecie się zapychają. Kable sprawdzałem, zresztą na obu wanach sygnalizuje połączenie 100Mbit. Po odcięciu połowy sieci, czyli zmniejszeniu ilości połączeń jest to samo - dochodzi do 10-15Mbit i zaczyna się lawinowa utrata pakietów.

Spotkał się ktoś z Was z czymś podobnym?

W międzyczasie postawiłem tą samą konfigurację na virtualboxie na mocniejszej maszynie z gigabitowymi kartami (tam akurat pfsense na czysto nie pójdzie bo sprzęt mu się nie podoba). Jak będzie się sprawować - okaże się, jak wyeliminuję problem 100% zużycia procesora na biegu jałowym :-)

--
Pozdrawiam,
Krzysztof

Przemyslaw85:
Zwykłe karty sieciowe nie nadają się do dużego obciążenia.
Z sieci lokalnej zapuść ping do bramy (na pfsense) i obserwuj czy tu nie ma strat. Jak są to tylko wymiana tych kart może rozwiązać problem.
Rozumiem że łącze jest stabilne i nie ma  z nim żadnych problemów (podpinając bezpośrednio pod dowolny komputer)?

wloczykij78:
Problem rozwiązany.

Otóż: pingi z lokalnej do pfsense idą bez problemu, problem zaczyna się, gdy próbuję pingować z lokalnej bramy. Dokładnie to samo dzieje się, gdy wepnę kabelek bezpośrednio do urządzeń dostępowych. Więc: to nie karty sieciowe się nie wyrabiają, a urządzenia dostępowe operatora zostały zarżnięte ilością pakietów. Cóż, pozostaje mi jedynie wyłączyć balancing i rutować poszczególne podsieci osobno na bramy.

Dzięki za cenną wskazówkę :-)

Przemyslaw85:
Doproś się od operatora wymiany tego wynalazku na model znacznie wydajniejszy.

Navigation

[0] Message Index

Go to full version