pfSense Gold Subscription

Author Topic: CAPTIVE Portal is very slow.  (Read 109 times)

0 Members and 1 Guest are viewing this topic.

Offline Ratnateja

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
CAPTIVE Portal is very slow.
« on: October 12, 2017, 09:42:14 am »
Hi Team,

I am using Dual core PC with 4 GB RAM. Everything works like charm. But when I create captive portal with local database authentication. It takes more than 1 minute to load the portal. Is there any way to fix this?

FYI I am using default captive portal. Nothing custom.

Thanks in advance

Offline Gertjan

  • Hero Member
  • *****
  • Posts: 2021
  • Karma: +165/-9
    • View Profile
Re: CAPTIVE Portal is very slow.
« Reply #1 on: October 12, 2017, 04:12:22 pm »
Hi,

What are your firewall rules on the interface used by the captive portal (if it's the default LAN interface with the default "pass all" rule then all will be fine).

What is the IP / gateway / DNS that pfSense gave (DHCP server running on pfSense) to the device you use to test the portal ?

Use also this https://doc.pfsense.org/index.php/Captive_Portal_Troubleshooting

Offline Munir

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: CAPTIVE Portal is very slow.
« Reply #2 on: October 20, 2017, 07:44:09 am »
same problem here!!

Offline Gertjan

  • Hero Member
  • *****
  • Posts: 2021
  • Karma: +165/-9
    • View Profile
Re: CAPTIVE Portal is very slow.
« Reply #3 on: October 20, 2017, 09:02:31 am »
Well ...
As usual : ten of thousands have a working situation.
You haven't

A fact : You and I have the same software.
Only the settings are different.
Our settings are ok - because it "works".
Yours ..... well ..... this is what we have :
One word.
"Problem".

Should I detail my settings ?
Or you ?
Chose wisely  ;)