Netgate SG-1000 microFirewall

Author Topic: How to completely disable Squid caching  (Read 835 times)

0 Members and 1 Guest are viewing this topic.

Offline PakiFo

  • Newbie
  • *
  • Posts: 5
  • Karma: +1/-0
    • View Profile
How to completely disable Squid caching
« on: October 20, 2017, 07:00:37 pm »
Hello,

Is there any way to completely disable the caching option in the Squid proxy server ?
I looked for this option and I just couldn't find it.

If you are curious about the reason i'm asking, I just found out that my Suricata (IPS) detects malicious sites as expected when it finds it, but squid still provide the malicious content to other computers from its cache in case they are also trying to access the malicious site (even when it is in Suricata's block list !)

Any help to disable the squid caching will be highly appreciated !

* I'm running the latest versions of pfSense (2.4.0) and Squid (0.4.42)

Offline doktornotor

  • Hero Member
  • *****
  • Posts: 8551
  • Karma: +964/-278
  • Not a pfSense employee, they cannot fire me...
    • View Profile
Re: How to completely disable Squid caching
« Reply #1 on: October 21, 2017, 03:16:06 am »
Set the Hard Disk Cache System to null.
Do NOT PM for help!

Offline PakiFo

  • Newbie
  • *
  • Posts: 5
  • Karma: +1/-0
    • View Profile
Re: How to completely disable Squid caching
« Reply #2 on: October 21, 2017, 03:32:55 am »
Set the Hard Disk Cache System to null.

Already tried it without success.
I also tried to set the "Maximum Object Size" to 0 and it still had something cached somewhere.

I assume that even though it is not caching to the disk, it still caches something in the RAM.

Offline doktornotor

  • Hero Member
  • *****
  • Posts: 8551
  • Karma: +964/-278
  • Not a pfSense employee, they cannot fire me...
    • View Profile
Re: How to completely disable Squid caching
« Reply #3 on: October 21, 2017, 03:36:48 am »
Well then set the RAM cache size to 1 or whatever.
Do NOT PM for help!

Offline PakiFo

  • Newbie
  • *
  • Posts: 5
  • Karma: +1/-0
    • View Profile
Re: How to completely disable Squid caching
« Reply #4 on: October 21, 2017, 04:13:12 am »
Well then set the RAM cache size to 1 or whatever.

Even with:
- "Hard Disk Cache System" - Null
- "Maximum Object Size" - 0
- "Memory Cache Size" - 0
- "Maximum Object Size in RAM" - 0

I'm still getting malicious cached content from squid  >:(

Offline doktornotor

  • Hero Member
  • *****
  • Posts: 8551
  • Karma: +964/-278
  • Not a pfSense employee, they cannot fire me...
    • View Profile
Re: How to completely disable Squid caching
« Reply #5 on: October 21, 2017, 04:17:29 am »
Eh, 0 is not a valid value. Use https://github.com/pfsense/FreeBSD-ports/pull/438 if you really cannot live with superdangerous 1MB cache in RAM.  ::)
Do NOT PM for help!

Offline MarcoP

  • Jr. Member
  • **
  • Posts: 31
  • Karma: +0/-0
    • View Profile
Re: How to completely disable Squid caching
« Reply #6 on: December 13, 2017, 03:01:46 pm »
Eh, 0 is not a valid value. Use https://github.com/pfsense/FreeBSD-ports/pull/438 if you really cannot live with superdangerous 1MB cache in RAM.  ::)

Looking at the commits, does it means we will be able to use "all" inside the "Do Not Cache" textarea in "Local Cache" tab?