The pfSense Store

Author Topic: upgrade to 2.4.1 cant connect to pppoe wan over vlan  (Read 3144 times)

0 Members and 1 Guest are viewing this topic.

Offline Satras

  • Full Member
  • ***
  • Posts: 142
  • Karma: +3/-0
    • View Profile
Re: upgrade to 2.4.1 cant connect to pppoe wan over vlan
« Reply #15 on: October 26, 2017, 07:39:02 am »
That's what I have planned for tomorrow.

What is the best way to roll back? Do a clean install and use the config backup of 2.4.0 version?

Offline wishy

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: upgrade to 2.4.1 cant connect to pppoe wan over vlan
« Reply #16 on: October 26, 2017, 11:05:13 am »
TBH, douche move to do this in a maintenance release. Broke PPP. Rolled back via VM Snapshot...

I didn't read the release notes fully, but it's a maint release shortly after a major release. The below came in the newsletter - so basically I expected a KRACK patch and stability fix. Not to have the PPP stack entirely borked, which was found in tested and pushed out anyway.

PPP might not be all that widely used, but I *expected* things to break in 2.4.0 and planned accordingly, as would the people who did the upgrade to 2.4.0 and found the VLAN problems. I didn't expect the same from 2.4.1

Quote
pfSense software version 2.4.1 release

We are excited to announce the release of pfSense software version 2.4.1, now available for new installations and upgrades!

pfSense software version 2.4.1 is a maintenance release bringing security patches and stability fixes for issues discovered in pfSense 2.4.0-RELEASE, including a patch for the recently announced WPA-2 KRACK vulnerability.

pfSense 2.4.1-RELEASE updates and installation images are available now!
« Last Edit: October 26, 2017, 11:09:07 am by wishy »

Offline ivor

  • Administrator
  • Sr. Member
  • *****
  • Posts: 583
  • Karma: +134/-125
    • View Profile
    • Netgate
Re: upgrade to 2.4.1 cant connect to pppoe wan over vlan
« Reply #17 on: October 26, 2017, 11:12:57 am »
It was allegedly done because of some ARM nonsense where some genius decided to name the interface mvneta and they found that it was too long after beginning to sell hardware with those.

I suggest you fix your attitude.

Those are the SG3100 units than can be recycled as paperweight once your one year support has ended and you need to reinstall, since there are no public ARM images available.

This is incorrect. You can always reinstall your SG-1000 using its image that's available on portal.pfsense.org. After 1 year, portal access, not support as no support is bundled with the device, is locked out BUT you can still use SG-1000, continue to update it or reinstall it using the image. Please refrain from making such wrong conclusions.
« Last Edit: October 26, 2017, 11:25:53 am by ivor »
Need help fast? Commercial support: https://www.netgate.com/support/

Offline ivor

  • Administrator
  • Sr. Member
  • *****
  • Posts: 583
  • Karma: +134/-125
    • View Profile
    • Netgate
Re: upgrade to 2.4.1 cant connect to pppoe wan over vlan
« Reply #18 on: October 26, 2017, 11:16:14 am »
TBH, douche move to do this in a maintenance release. Broke PPP. Rolled back via VM Snapshot...

I didn't read the release notes fully, but it's a maint release shortly after a major release.

Then start reading the release notes or at least the announcement blog post. "douche move" remark is not nice.
Need help fast? Commercial support: https://www.netgate.com/support/

Offline jwt

  • Administrator
  • Sr. Member
  • *****
  • Posts: 342
  • Karma: +101/-31
    • View Profile
Re: upgrade to 2.4.1 cant connect to pppoe wan over vlan
« Reply #19 on: October 26, 2017, 11:36:36 am »
for now i had to rename all igb.20 to igb1_20 to make it connect, why would they release it with such a bug

It was allegedly done because of some ARM nonsense where some genius decided to name the interface mvneta and they found that it was too long after beginning to sell hardware with those. (Those are the SG3100 units than can be recycled as paperweight once your one year support has ended and you need to reinstall, since there are no public ARM images available.)

Renaming interfaces is about the most critical thing you can mess with on a networking gear such as firewall. So, of course a minor bugfix release is an excellent opportunity to change those, completely untested and after 2.4 has been tested for ~1 year. Sigh.

Once again, reading the release notes is important: https://www.netgate.com/blog/pfsense-2-4-1-release-now-available.html

https://redmine.pfsense.org/issues/7981

Yeah, once again, noone sane makes and expects such changes at this time point.

Doktornotor,

Point in-fact the "too long" was due to some work done (by people who are now gone) to use "interfacename<unit>_vlan<number>" in pfSense.

What we did is to repair the pfSenes code to use the FreeBSD standard "interfacename<unit>.<number> where <number here is the vlan tag".

As you should be well-aware, choices made over the last decade mean that pfSense can be quite difficult to maintain.

This did not occur "after beginning to sell hardware" as you assert.  You are 100% wrong on this point, and you need to retract.   2.4.0-RELEASE occurred prior to SG-3100 entering a shipping state, and, in fact, the earliest release of pfSense for the SG-3100 is 2.4.1-RELEASE.

This "mvneta" name did not come from us, it came from Semihalf, via FreeBSD.
Many people are misinformed about being able to get reload images for Netgate platforms.  You perpetuate the myth, and I think only to gain advantage.

You've made several false statements in the above, and denigrated members of the team.

We've been here before.  Back down the rhetoric, and retract the above, or go somewhere else.

You have zero more chances, and I am 100% serious on this point.  Criticism is fine, but lying is not.



Offline Apo

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: upgrade to 2.4.1 cant connect to pppoe wan over vlan
« Reply #20 on: October 26, 2017, 03:03:13 pm »
I've upgraded my SG-4860 to 2.4.1 and lost my internet connection.

I tried to modify my config, renaming all `igb1.11` to `igb1_11` but this results in the system not coming up at all anymore. I had to factory reset and reload the original config to connect again.

What else can I do to get my connection running again?

Offline PiBa

  • Hero Member
  • *****
  • Posts: 728
  • Karma: +123/-1
  • PiBa-NL(on IRC)
    • View Profile
Re: upgrade to 2.4.1 cant connect to pppoe wan over vlan
« Reply #21 on: October 26, 2017, 03:42:57 pm »
While its running run on console "ifconfig igb1.11 name igb1_11" then from webgui edit the pppoe interface to select the right interface to run on. That should afaik allow for internet access. Until reboot that is..
Should probably be possible to upgrade to 2.4.2development which should fix the pppoe+vlan issue, though i am not 100% sure if it wont complain during boot then yet again.. due to the changed config for a then not existing interface with that name..

Offline Apo

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: upgrade to 2.4.1 cant connect to pppoe wan over vlan
« Reply #22 on: October 26, 2017, 04:38:02 pm »
While its running run on console "ifconfig igb1.11 name igb1_11" then from webgui edit the pppoe interface to select the right interface to run on. That should afaik allow for internet access. Until reboot that is..

That did the trick, thank you very much!!!

Offline doktornotor

  • Hero Member
  • *****
  • Posts: 8553
  • Karma: +957/-278
  • Not a pfSense employee, they cannot fire me...
    • View Profile
Re: upgrade to 2.4.1 cant connect to pppoe wan over vlan
« Reply #23 on: October 26, 2017, 06:17:15 pm »
This "mvneta" name did not come from us, it came from Semihalf, via FreeBSD.
Many people are misinformed about being able to get reload images for Netgate platforms.  You perpetuate the myth, and I think only to gain advantage.

I perpetuate nothing. I responded to your email, sadly no response to that. So let me restate this in public - noone gives a horse shit about who's responsible for the interface naming brainfart. You are breaking stable releases because of this nonsense. 2.4.0 RC, 2.4.1, the 2.4.2 snapshots...

WTH you keep threatening contributors to this project What kind of advantage am I supposed to gain from this? Being threatened here, being threatened via email, as a reward for contributing tens of thousand LOCs to the project?

Go see a shrink doctor, ASAP. This paranoia is pathologic.
Do NOT PM for help!

Offline ivor

  • Administrator
  • Sr. Member
  • *****
  • Posts: 583
  • Karma: +134/-125
    • View Profile
    • Netgate
Re: upgrade to 2.4.1 cant connect to pppoe wan over vlan
« Reply #24 on: October 26, 2017, 06:19:22 pm »
That's it, your continuous abuse ends now. You were warned many times.
« Last Edit: October 26, 2017, 06:46:17 pm by ivor »
Need help fast? Commercial support: https://www.netgate.com/support/

Offline Satras

  • Full Member
  • ***
  • Posts: 142
  • Karma: +3/-0
    • View Profile
Re: upgrade to 2.4.1 cant connect to pppoe wan over vlan
« Reply #25 on: October 27, 2017, 03:26:13 pm »
Just did a fresh install of 2.4.0 and restored my backup config... all up and running now.. waiting for 2.4.2 for now, or maybe 2.5.x ...

still damn unhappy about how this all went down... such change in an Minor upgrade.. unbelievable

Offline MAW

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: upgrade to 2.4.1 cant connect to pppoe wan over vlan
« Reply #26 on: October 27, 2017, 10:53:29 pm »
My solution workflow that got our 2.4.1 box with this issue back online.......

a) Had upgraded from 2.4.0 to 2.4.1
b) System came back up fine after the upgrade reboot, but no internet connection anymore with existing VLAN/PPPoE configuration.
c) Logged into WebGUI
d) Went to Diagnotstics --> Edit File --> Browse. Choose "Conf" folder. Choose Config.xml file.
e) Place cursor in text window. Go to the Web browser's menu to choose the "find" content facility. Search for each occurrence of "interfacename.vlannumber" in config.xml and change the . to _ then save the edited config.xml file. For example igb0.900 to igb0_900
f) Reboot PfSense.
g) System came back up without issue and connected the PPPoE connection immediately. Job done. 15 minutes work max.

Hope that helps as another interim solution option. I had to do this remotely (200+ Km away), with the keyboard assistance of an inexperienced person at the system's site. The pfSense system was installed at a Radiology practice, so the situation was business critical.

It was an inconvenience yes, but not a show stopper.

The bottom line in all this, is that I failed to appreciated the release notes content regarding the VLAN/PPPoE issue, in as much as I forgot that this problem configuration existed on the system I upgraded. So I have no one else to blame but myself. I see that some people are rather disguntled by the circumstances of their own demise with this issue. Yes one could sook that the upgrade was released broken I suppose, but it gets a bit rich to complain about this, when the release notes forewarn of the issue for a specific configuration and then that warning is not heeded.

Cheers
« Last Edit: October 27, 2017, 11:53:46 pm by MAW »

Offline epek

  • Jr. Member
  • **
  • Posts: 70
  • Karma: +1/-6
    • View Profile
Re: upgrade to 2.4.1 cant connect to pppoe wan over vlan
« Reply #27 on: October 29, 2017, 06:24:55 am »
@MAW: if I follow that advise, pfSense will have troubles assigning it's vlans (on that appliance: vtnet0.*, vtnet0_* respectively) to logical interfaces (OPT*) at reboot. If I only change that within the vlan and pppoe sessions, assignments still work, but pppoe still fails.

Offline jahonix

  • Hero Member
  • *****
  • Posts: 2403
  • Karma: +144/-14
  • volunteer since 2006
    • View Profile
Re: upgrade to 2.4.1 cant connect to pppoe wan over vlan
« Reply #28 on: October 29, 2017, 01:30:39 pm »
... I had to do this remotely (200+ Km away) ... at a Radiology practice, so the situation was business critical ... It was an inconvenience yes, but not a show stopper.
What?
A point release that kills functionality IS a show stopper. Period.
Work in the live entertainment industry like I do and you'll get this pretty soon. Or get fired before you even know why.
Chris

The issue with IPv6 jokes is that almost no one understands them and no one is using them yet.

Offline alex17857

  • Newbie
  • *
  • Posts: 4
  • Karma: +2/-1
    • View Profile
Re: upgrade to 2.4.1 cant connect to pppoe wan over vlan
« Reply #29 on: October 29, 2017, 03:36:51 pm »
I upgraded to 2.4.1 and lost my PPPOE WAN connection too. Whoever implemented this system breaking change smoked far too much crack.