The pfSense Store

Author Topic: 2.4.1 is killing me  (Read 336 times)

0 Members and 1 Guest are viewing this topic.

Offline rscrub

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
2.4.1 is killing me
« on: November 07, 2017, 07:34:48 am »
Ever since I updated, it crashes almost every day and will not shutdown/startup. I keep getting this message


There were error(s) loading the rules: pfctl: DIOCXCOMMIT: Device busy - The line in question reads
  • : @ 2017-11-07 07:02:41


and...

PF was wedged/busy and has been reset.   @ 2017-11-07 07:02:36

I can't figure out what is going on. Please help!!!

Offline kejianshi

  • Hero Member
  • *****
  • Posts: 4956
  • Karma: +197/-41
  • Debugging...
    • View Profile
Re: 2.4.1 is killing me
« Reply #1 on: November 07, 2017, 07:42:40 am »
For me, that just means I'm on pfsense.  I see those two every day and it dosn't cause me any crashes or hangs that I've noticed. 

We are talking for years. 

BlueKobold

  • Guest
Re: 2.4.1 is killing me
« Reply #2 on: November 07, 2017, 07:51:33 am »
Quote
Ever since I updated, it crashes almost every day and will not shutdown/startup. I keep getting this message
If 2.4.1 is not a must be, I would roll back to 2.4.0 or an earlier version where you was not getting any problems in, and
if the version 2.4.2 is out you could try it again! So if you are not pressed to use this version perhaps better to wait
until 2.4.2 is out.

Some VLAN labeling problems were there and the VLANs on the WAN interface using PPP is also broken. as
I am informed right.


Offline Birke

  • Jr. Member
  • **
  • Posts: 56
  • Karma: +12/-0
    • View Profile
Re: 2.4.1 is killing me
« Reply #3 on: November 07, 2017, 07:52:02 am »
regarding that DIOCXCOMMIT-errormessage a quick google-search offered me this possible solution:
There were error(s) loading the rules: pfctl: DIOCXCOMMIT: Device busy – The line in question reads [ 0 ]

Here’s what worked for me:
Rather than allowing your NICs to autoselect speed, duplex and flow control, I locked these in on each interface to the highest possible setting and configured the firewall to be the master controller of these settings.

In my case that’s 1000baseT full-duplex,flowcontrol,master

C’est tout.
=)D
have you tried that already?

I get the second message on my pf too, but it never crashed. The only thing is, that the gui is unavailable for some seconds.

Offline rscrub

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: 2.4.1 is killing me
« Reply #4 on: November 07, 2017, 09:26:05 pm »
Quote
Ever since I updated, it crashes almost every day and will not shutdown/startup. I keep getting this message
If 2.4.1 is not a must be, I would roll back to 2.4.0 or an earlier version where you was not getting any problems in, and
if the version 2.4.2 is out you could try it again! So if you are not pressed to use this version perhaps better to wait
until 2.4.2 is out.

Some VLAN labeling problems were there and the VLANs on the WAN interface using PPP is also broken. as
I am informed right.


I cant figure out how to roll back?

Offline Derelict

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9247
  • Karma: +1053/-308
    • View Profile
Re: 2.4.1 is killing me
« Reply #5 on: November 07, 2017, 09:29:45 pm »
You reinstall the old version and restore the configuration backup you took before you upgraded.
Las Vegas, Nevada, USA
Use this diagram to describe your issue.
The pfSense Book is now available for just $24.70!
Do Not PM For Help! NO_WAN_EGRESSTM