pfSense Support Subscription

Author Topic: Guest VLAN - no internet access  (Read 162 times)

0 Members and 1 Guest are viewing this topic.

Offline tgreen

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Guest VLAN - no internet access
« on: November 08, 2017, 12:47:10 pm »
Hi there,

I have an issue with a VLAN I want to create for a guest network.  I'm still pretty green in the VLAN world

I have a Unifi AP setup with a network assigned to VLAN 5. 
When I connect my phone to the 'guest' wifi, I get the appropriate VLAN address and it shows up in the pfSense Leases.
Leases in use show LAN and Guest

I can ping the Guest IP from the LAN (don't have any restrictions on LAN right now).
I cannot ping a LAN IP from the guest (from my phone)

The firewall rules for the Guest VLAN is wide open as well
IPv4 TCP   *   *   *   *   *   none   

Really unsure of what I'm missing here

I should also mention that I have an unmanaged switch and LAN/VLAN are out on the same pfSense port (trunked)
The Guest VLAN is addressed 10.2.5.1, no upstream gateway
Unifi AP assigns the VLAN 5, but DHCP is handled in pfSense

Little baffled here



Offline KOM

  • Hero Member
  • *****
  • Posts: 5370
  • Karma: +668/-19
    • View Profile
Re: Guest VLAN - no internet access
« Reply #1 on: November 08, 2017, 01:36:29 pm »
Change your protocol from TCP to * or you will lose DNS, which is likely your problem.

Offline tgreen

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: Guest VLAN - no internet access
« Reply #2 on: November 08, 2017, 11:54:09 pm »
All sorted now.  I allowed TCP/UDP, didn't want to allow all as it is a guest network and should be limited in use

Pretty nice software overall once you get used to navigation and knowing where things are

Thanks!