pfSense English Support > Packages

HAProxy + ACME [FIXED]

(1/4) > >>

uwscia:
I have to say I've tried multiple different tuts trying to get this working...
It seems that there is just 1 thing every tut is missing cause it doesn't matter which one I used nothing seems to work...
Currently getting a 503 which makes me think that haproxy is working... but... This is as close as I've come.

Installed

* pfsense 2.4.2
* haproxy package 0.54_2
* acme package 0.1.23
Looking to setup multiple sub domains to pass through firewall

* www.domain.com
* cloud.domain.com
* vpn.domain.comAnd also setup multiple local domains

* plex.local or plex.domain.local
* http1.local
* http2.local
And I would like to get ACME to server SSL certs for them all.

PiBa:
A nice wish-list, only need 3 steps:
- configure pfSense so it works
- configure haproxy so it works
- configure acme package so it works
And your done :o , besides what you 'want', it is important for me to know what you 'did'.

As currently there is just to little information here to tell what setting you might have missed that causes a 503.
Please share haproxy.cfg (from bottom of haproxy settings tab) and some additional screenshots that you have for acme configuration. Also check and tell what haproxy's stats page LastChk is telling about the servers, are they marked as 'down' ?

https://github.com/PiBa-NL/pfsense-haproxy-package-doc/wiki/haproxy_troubleshooting

Other than that, acme cannot provide certificates for your http1.local's domain as it wont be able to check for its existence / ownership on pubic accessible http webserver or public dns txt records..

uwscia:
I'm sitting with clean install, and the packages installed...

PiBa:
Ok so your sitting, that seems like a safe position.. and now what do you expect will happen.?

Have you tried anything else?

uwscia:
As stated, I've tried multiple tutorials...
and to clear my many attempts I cleared everything, Cause I was still seeing squid in the menu even though I had removed it.
I wanted a fresh install to start from.

Navigation

[0] Message Index

[#] Next page

Go to full version