Netgate SG-1000 microFirewall

Author Topic: Error after updating pfSense to 2.3.5  (Read 103 times)

0 Members and 1 Guest are viewing this topic.

Offline Smokeshow

  • Newbie
  • *
  • Posts: 17
  • Karma: +1/-0
    • View Profile
Error after updating pfSense to 2.3.5
« on: December 04, 2017, 10:53:02 am »
I updated one of our routers last week, and now I'm getting this error every hour:

PHP ERROR: Type: 1, File: /usr/local/www/pfblockerng/pfblockerng.php, Line: 195, Message: Call to undefined function curl_init()

Any ideas? Everything seems to work except for the constant nagging.

Offline RonpfS

  • Hero Member
  • *****
  • Posts: 684
  • Karma: +96/-2
    • View Profile
Re: Error after updating pfSense to 2.3.5
« Reply #1 on: December 04, 2017, 10:58:17 am »
Try to reinstall pfblockerNG.

If the error persist, then you may have to reinstall pfsense as curl_init is a basic pfsense curl function.
You may probably be able to recover without reinstalling, check the Installation and upgrade forum https://forum.pfsense.org/index.php?board=4.0.
« Last Edit: December 04, 2017, 11:15:37 am by RonpfS »
2.3.5-RELEASE (amd64)
Intel Core2 Quad CPU Q8400 @ 2.66GHz 8GB
pfBlockerNG 2.1.2_1/Dev, suricata 4.0.1