Netgate SG-1000 microFirewall

Author Topic: Asterisk + pfsense, Some calls dropped after 30 sec  (Read 116 times)

0 Members and 1 Guest are viewing this topic.

Offline ramous

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Asterisk + pfsense, Some calls dropped after 30 sec
« on: January 31, 2018, 11:53:11 am »
Hi all,


I have a NAT Issue for my Asterisk behind my pfsense, i have checked all old related posts, but none helped me.
!!!
I have 4 SIP provider and without pfsense just with NAT in router config everything works fine.
!!!
and below my config:
my subnet (172.16.10.0/24) use Pfsense WAN address for internet 196.X.X.11
 
my asterisk (192.168.1.200) is natted through pfsense with VIP 196.X.X.10
  1:1 NAT  196.X.X.10 -- 192.168.1.200
   Manual Outbound: 192.168.1.200 --- to any -- 196.X.X.10 with dynamic port.

Rules:
on WAN Interface rules no restriction to 192.168.1.200
on Server Interface rules no restriction for 192.168.1.200

with firewall optimization set to Normal: I get the issue of one way audio
with firewall optimization set to Conservative:  some call work fine and some dropped after 30 sec

Need your Help Please.

Offline ramous

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Asterisk + pfsense, Some calls dropped after 30 sec
« Reply #1 on: February 02, 2018, 08:40:34 am »
Issue solved

Problem related to SIP ALG in the router which must be disabled.

in my case i have a cisco router, so I entred:
#no ip nat service sip tcp port 5060
#no ip nat service sip udp port 5060
and everything started working as expected.