Netgate Store

Author Topic: live 0.94.4 boot  (Read 5055 times)

0 Members and 1 Guest are viewing this topic.

Offline mpapec

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
live 0.94.4 boot
« on: November 21, 2005, 04:47:21 am »
During the boot pfsense finds config.xml on usb drive but later when runing some .inc script complains that it can't find /cf/conf/config.xml when looking for it.

Is it possible that config.xml gets deleted during boot? (config.xml if from 0.90)


Offline sullrich

  • Hero Member
  • *****
  • Posts: 5110
  • Karma: +7/-2348
    • View Profile
    • pfSense
Re: live 0.94.4 boot
« Reply #1 on: November 21, 2005, 09:41:59 am »
During the boot pfsense finds config.xml on usb drive but later when runing some .inc script complains that it can't find /cf/conf/config.xml when looking for it.

Is it possible that config.xml gets deleted during boot? (config.xml if from 0.90)

This has been fixed.  It's cosmetic.

Offline luvrig

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: live 0.94.4 boot
« Reply #2 on: November 21, 2005, 04:27:37 pm »
During the boot pfsense finds config.xml on usb drive but later when runing some .inc script complains that it can't find /cf/conf/config.xml when looking for it.

Is it possible that config.xml gets deleted during boot? (config.xml if from 0.90)

This has been fixed.  It's cosmetic.

Which version is this fixed in?  I also tried 0.94.4 and it looks like it wipes everything on my flash when it boots, not just the config.xml.

Offline sullrich

  • Hero Member
  • *****
  • Posts: 5110
  • Karma: +7/-2348
    • View Profile
    • pfSense
Re: live 0.94.4 boot
« Reply #3 on: November 21, 2005, 04:29:08 pm »
During the boot pfsense finds config.xml on usb drive but later when runing some .inc script complains that it can't find /cf/conf/config.xml when looking for it.

Is it possible that config.xml gets deleted during boot? (config.xml if from 0.90)

This has been fixed.  It's cosmetic.

Which version is this fixed in?  I also tried 0.94.4 and it looks like it wipes everything on my flash when it boots, not just the config.xml.

0.94.8

Offline mpapec

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: live 0.94.10 boot
« Reply #4 on: November 23, 2005, 09:53:00 am »
It seems that error is still there,
Now "fopen" can't open /conf/config.xml and config.xml gets wiped from floppy.


btw,
df -h outputs strange mounts,
Code: [Select]
Filesystem              Size    Used   Avail Capacity  Mounted on
/dev/iso9660/pfSense     36M     36M      0B   100%    /
devfs                   1.0K    1.0K      0B   100%    /dev
/dev/md0.uzip            74M     64M    4.2M    94%    /usr
/dev/md1                 31M    958K     27M     3%    /var
/dev/md2                 19M     10K     18M     0%    /tmp
/dev/md3                 19M    2.1M     15M    12%    /etc
/dev/md4                 19M     16K     18M     0%    /root
/dev/fd0                1.4M     10K    1.4M     1%    /tmp/mnt/cf
/tmp/mnt/cf             1.4M     10K    1.4M     1%    /cf/conf
/tmp/mnt/cf             1.4M     10K    1.4M     1%    /conf

/dev/fd0 device is on /tmp/mnt/cf, that's fine,
but /tmp/mnt/cf is twice mounted later as a device..
Should that be some kind of mount loopback, or something went wrong?

pfsense is live 0.94.10

Offline satu

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
  • Builder man
    • View Profile
Re: live 0.94.4 boot
« Reply #5 on: November 23, 2005, 01:00:10 pm »
df -h outputs strange mounts,
Code: [Select]
Filesystem Size Used Avail Capacity Mounted on
/dev/iso9660/pfSense 36M 36M 0B 100% /
devfs 1.0K 1.0K 0B 100% /dev
/dev/md0.uzip 74M 64M 4.2M 94% /usr
/dev/md1 31M 958K 27M 3% /var
/dev/md2 19M 10K 18M 0% /tmp
/dev/md3 19M 2.1M 15M 12% /etc
/dev/md4 19M 16K 18M 0% /root
/dev/fd0 1.4M 10K 1.4M 1% /tmp/mnt/cf
/tmp/mnt/cf 1.4M 10K 1.4M 1% /cf/conf
/tmp/mnt/cf 1.4M 10K 1.4M 1% /conf

/dev/fd0 device is on /tmp/mnt/cf, that's fine,
but /tmp/mnt/cf is twice mounted later as a device..
Should that be some kind of mount loopback, or something went wrong?

It is mount_nullfs. Could you post the `mount' output?

Offline mpapec

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: live 0.94.4 boot
« Reply #6 on: November 24, 2005, 11:10:09 am »
here ..
Code: [Select]
/dev/iso9660/pfSense on / (cd9660, local, read-only)
devfs on /dev (devfs, local)
/dev/md0.uzip on /usr (ufs, local, read-only)
/dev/md1 on /var (ufs, local)
/dev/md2 on /tmp (ufs, local)
/dev/md3 on /etc (ufs, local)
/dev/md4 on /root (ufs, local)
/dev/fd0 on /tmp/mnt/cf (msdosfs, local)
/tmp/mnt/cf on /cf/conf (nullfs, local)
/tmp/mnt/cf on /conf (nullfs, local)

and all files on floppy get wiped  :o

Offline satu

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
  • Builder man
    • View Profile
Re: live 0.94.4 boot
« Reply #7 on: November 25, 2005, 08:41:32 pm »
Just fixed by Scott. See http://cvstrac.pfsense.com/tktview?tn=703,6. Hopefully there will not be the problem in next release.