The pfSense Store

Author Topic: problem in squid 2.6  (Read 1413 times)

0 Members and 1 Guest are viewing this topic.

Offline abd2002390

  • Jr. Member
  • **
  • Posts: 34
  • Karma: +0/-0
    • View Profile
problem in squid 2.6
« on: April 25, 2009, 02:12:57 pm »
i have installed squid package and run it with transparent mode and evry thing is ok
but after 1 day he has block the web browsing and he redirect me to the web server and ask for user name and pass
when i cancelled it or run it on non transparent mode the web browsing is ok
how can i fix it

Offline jigpe

  • Sr. Member
  • ****
  • Posts: 371
  • Karma: +0/-0
    • View Profile
Re: problem in squid 2.6
« Reply #1 on: April 27, 2009, 05:16:46 am »
Did you add ports 80/8080/443/53 in your Rules LAN ? Try save and restart your pfsense see if that works.
jigp
Davao City

Offline mhab12

  • Hero Member
  • *****
  • Posts: 649
  • Karma: +0/-0
    • View Profile
Re: problem in squid 2.6
« Reply #2 on: April 28, 2009, 11:04:50 am »
Set your webGUI to run on HTTPS port 443.

Offline chudy

  • Full Member
  • ***
  • Posts: 149
  • Karma: +0/-0
    • View Profile
    • lusca for pfsense
Re: problem in squid 2.6
« Reply #3 on: May 10, 2009, 06:03:56 am »
It happens when your squid die's within transparent mode. If this thing happen again. open your shell and run squid -Nd1 then youll see whats the problem. :>
currently using lusca-HEAD(patched) for CDN(youtube vidoes) caching, bandwidth throttling(throttle if file is bigger than 32KB) and aggressive caching.

lusca and SRG for pfsense and some patch
http://code.google.com/p/pfsense-cacheboy

Offline jigpe

  • Sr. Member
  • ****
  • Posts: 371
  • Karma: +0/-0
    • View Profile
Re: problem in squid 2.6
« Reply #4 on: May 13, 2009, 05:14:40 am »
OT: Is there a way to change the proxy:port into private proxy_ip:port ? Been exploring the squid+squidguard packages but no luck.. Anyone knows how to configure and set private_proxy_ip:port? Currently im using a local proxy:port default of pfsense squid..
jigp
Davao City

Offline dvserg

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4785
  • Karma: +0/-0
    • View Profile
    • My Homepage
Re: problem in squid 2.6
« Reply #5 on: May 13, 2009, 05:21:01 am »
OT: Is there a way to change the proxy:port into private proxy_ip:port ? Been exploring the squid+squidguard packages but no luck.. Anyone knows how to configure and set private_proxy_ip:port? Currently im using a local proxy:port default of pfsense squid..
jigp
Davao City
Via squid > Custom options

Offline jigpe

  • Sr. Member
  • ****
  • Posts: 371
  • Karma: +0/-0
    • View Profile
Re: problem in squid 2.6
« Reply #6 on: May 13, 2009, 05:34:48 am »
Hi.Thanks for the quick reply..My Proxy server: General settings >Suppress Squid Versio   (checked) > Custom Options : Squid redirect_program /usr/local/bin/squidGuard -c /usr/local/etc/squidGuard/squidGuard.conf;redirector_bypass on;redirect_children 10... Where to put my private_proxy:port sir? Kindly you me the way.. Ive tried locating in command line using /var/squid/acl but nothing there..even in the cache and log directory... Thanks
jigp
Davao City