pfSense Gold Subscription

Author Topic: CALL FOR TESTING: NanoBSD Packages  (Read 15389 times)

0 Members and 1 Guest are viewing this topic.

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 20797
  • Karma: +1311/-24
    • View Profile
Re: CALL FOR TESTING: NanoBSD Packages
« Reply #15 on: November 24, 2009, 06:47:18 am »
Most people on this forum prefer to keep things in the public forums, and are turned off by PMs.

You might try the support mailing list, or IRC.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline bartgrefte

  • Full Member
  • ***
  • Posts: 108
  • Karma: +0/-0
    • View Profile
Re: CALL FOR TESTING: NanoBSD Packages
« Reply #16 on: November 24, 2009, 07:58:23 am »
Not getting any response there either, that's why I tried PM's.

Uhm, support mailing list?
edit: found it

Offline MrHorizontal

  • Jr. Member
  • **
  • Posts: 60
  • Karma: +0/-0
    • View Profile
Re: CALL FOR TESTING: NanoBSD Packages
« Reply #17 on: November 25, 2009, 06:53:07 pm »
These 2 not very big packages, but packages nonetheless work fine:
- iperf
- blinkled

Fit123 doesn't work though (seems to expect a RW filesystem):
- installs correctly, but switching any of the features on/off have no effect
- themes work fine
- error when selecting DDNS tab in Fit123: Warning: fopen(/usr/local/pkg/Fit123/ddns/ddns.php): failed to open stream: Read-only file system in /usr/local/pkg/fit123.inc on line 164

Hardware: 2 carped ALIX 2D3's / pfSense 1.2.3 RC3 and 4GB CF cards.

Offline Sylhouette

  • Jr. Member
  • **
  • Posts: 45
  • Karma: +0/-0
    • View Profile
Re: CALL FOR TESTING: NanoBSD Packages
« Reply #18 on: November 26, 2009, 12:52:28 am »
Hello all

i use the 1.2. 1G images for testing.
Now i see that the full versions and the 4G versions are still beeing updated, but the 1G version is still from 14 Nov
both the update and the new to install versions.

Are the 1 GB version obsolete?

regards,
Johan

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 20797
  • Karma: +1311/-24
    • View Profile
Re: CALL FOR TESTING: NanoBSD Packages
« Reply #19 on: November 26, 2009, 09:25:22 am »
Sylhouette,

That is unrelated to this topic, please start a new thread for a different question.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline MrHorizontal

  • Jr. Member
  • **
  • Posts: 60
  • Karma: +0/-0
    • View Profile
Re: CALL FOR TESTING: NanoBSD Packages
« Reply #20 on: November 29, 2009, 05:15:36 am »
Fit123 doesn't work though (seems to expect a RW filesystem):
- installs correctly, but switching any of the features on/off have no effect
- themes work fine
- error when selecting DDNS tab in Fit123: Warning: fopen(/usr/local/pkg/Fit123/ddns/ddns.php): failed to open stream: Read-only file system in /usr/local/pkg/fit123.inc on line 164

Further to this, it's clear that Fit123 isn't calling /etc/rc.conf_mount_r[w|o] when doing it's thing. I don't use DDNS (and perhaps the error is caused because DDNS is disabled?), and even so by calling /etc/rc.conf_mount_rw before visiting the Fit123 doesn't get rid of the DDNS tab error. However the Fit123 tab works fine - here's a workaround:
1: Open 2 tabs both visiting the pfsense box. This is important.
2: Install the Fit123 package as normal (System -> Packages)
3: Go to Diagnostics -> Command and run /etc/rc.conf_mount_rw and leave it
4: In the 2nd tab, go to Status -> Fit 123, select the settings as required and save
5: Check that it's applied the settings: System -> General should have 4 DNS server fields, Status -> System should have current time. If not, run /etc/rc.conf_mount_rw in one of the tabs again, and save Fit123 settings again (it took 2 goes for it's magic to work for me for some reason)
6: Once settings have been applied to your satisfaction, run /etc/rc.conf_mount_ro in Diagnostics -> Command

For some reason even with /etc/rc.conf_mount_rw run and the FS as writeable, the DDNS tab in Fit123 *still* says the fopen() warning, leading me to believe there are actually 2 bugs here:
1. That /etc/rc.conf_mount_r[w|o] needs to be called for it to be properly NanoBSD compatible
2. That the DDNS tab has a further bug, which may be due to the actual DDNS service (Services -> Dynamic DNS) being disabled on my pfSense.