pfSense Gold Subscription

Author Topic: [Share] MULTIWAN dengan VLAN di PFSENSE  (Read 16863 times)

0 Members and 1 Guest are viewing this topic.

Offline spc

  • Full Member
  • ***
  • Posts: 159
  • Karma: +6/-1
    • View Profile
[Share] MULTIWAN dengan VLAN di PFSENSE
« on: November 19, 2010, 08:49:06 am »
I. VLAN Overview
VLAN memberikan pengelompokan logis dari stasiun atau port switch,dan memungkinkan komunikasi  terjadi seolah-olah semua stasiun atau port berada di segmen LAN fisik yang sama. Termasuk juga stasiun atau port yang secara fisik berbeda tetapi dijembatani oleh LAN. Secara teknis, masing-masing VLAN hanyalah sebuah broadcast domain. broadcast domain VLAN dikonfigurasikan  melalui perangkat lunak bukan  perangkat keras, sehingga jika mesin dipindahkan ke lokasi lain, broadcast domain VLAN tetap sama tanpa harus mengkonfigurasi ulang hardware.

VLAN Tagged (Penandaan VLAN)
Saat ini ada banyak bentuk penandaan VLAN (VLAN Tagged), yang dikategorikan berdasarkan algoritma tertentu , antara lain sebagai berikut :

•   Port-Based VLAN
Tagging berdasarkan port switch. Sebagai contoh, Anda mungkin mengekelompokan port 1 sampai 2 ke VLAN 10 untuk departemen A dan port 6 sampai 12 ke VLAN 20 untuk departemen B. Jenis konfigurasi ini adalah yang paling sederhana. Namun, tidak fleksibel untuk workstation bergerak, karena akan selalu membutuhkan penggantian konfigurasi switch.

•   MAC-Base VLAN
Tagging berdasarkan pada layer 2 alamat MAC address. Hal ini membutuhkan  konfigurasi awal yang lebih signifikan dari switch. Namun, pelacakan otomatis akan lebih mudah dilakukan  setelah switch  dikonfigurasikan.

•   Protocol-Base VLAN
Tagging berdasarkan address di  protocol transport layer 3, layer 4 dan layer yang lebih tinggi.
 
•   Policy-Base VLAN
Tagging berdasarkan kebijakan tertentu dan konfigurasi dari user. Ini mungkin melibatkan mengelompokkan lalu lintas jaringan ke dalam kelompok-kelompok  dan prioritas penugasan QoS dan ID VLAN pada setiap kelompok.

II. Manfaat dari penggunaan VLAN

•   Partisi dan Konfigurasi yang lebih  fleksibel dari  Jaringan
Menggunakan VLAN, jaringan dapat dipartisi berdasarkan pengelompokan logis , tidak didasarkan pada topologi fisik. Misalnya, Anda dapat memindahkan pengguna dari ruangan A  ke ruangan B,dengan  pengelompokan logis yang  tetap sama meskipun topologi fisik telah berubah.

•   Peningkatan Kinerja
Protokol TCP/IP dan protokol lainnya akan membroadcast frame berkala untuk mengenali dan melakukan aktivitas dalam jaringan. Pada jaringan tradisional, frame menjangkau seluruh host pada jaringan. Ini dapat memiliki dampak yang signifikan terhadap kinerja jaringan bila Anda memiliki sejumlah besar end user. Dengan VLAN lalu lintas broadcast akan dibatasi ke sebuah subset dari port switch tertentu atau ke pengguna akhir tertentu. Hal ini akan menghemat sejumlah besar bandwidth jaringan dan waktu pemrosesan.

•   Penghematan Biaya
Administrator jaringan akan melakukan beberapa broadcast domain dengan menggunakan router diantara segmen-segmen jaringan yang dimilikinya. Namun, router yang bagus lebih harganya cukup mahal dan waktu penundaan yang dimiliki router lebih lama dari pada menggunakan konfigurasi VLAN.

Dibawah adalah gambar perbedaan algoritma penggunaan VLAN pada switch Managed dan jaringan tradisional pada switch unmanaged.



LANGKAH-LANGKAH SETTING VLAN DI SWITCH MANAGED

Untuk melakukan setting VLAN dalam switch Managed ( Cisco Catalyst 2950 series) dicontohkan pada langkah-langkah dibawah :
1.   Fitur VLAN yang mempunyai tagged frame hanya disupport pada kebanyakan switch managed, tidak pada switch unmanaged yang seluruh portnya untagged.
2.   Diasumsikan untuk membangun topologi jaringan seperti gambar dibawah ini .



3.   Mengkonfigurasikan Switch Catalyst 2950 dengan login melalui port serial, menggunakan program terminal untuk melakukan command line configuration , dalam situasi ini menggunakan Putty.Cara setting putty seperti gambar di bawah.



Dibawah list keseluruhan command yang harus diinputkan :

Switch>enable
Switch#config t
Switch(config)#enable secret admin
Switch(config)#line vty 0 15
Switch(config-line)#password admin
Switch(config-line)#login
Switch(config-line)#interface vlan1
Switch(config-if)#ip address 192.168.1.2 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#ip default-gateway 192.168.1.1
Switch(config)#exit
Switch#vlan database
Switch(vlan)#vlan 2 name WAN
Switch(vlan)#vlan 3 name OPT2
Switch(vlan)#apply
Switch(vlan)#exit
Switch#show vlan
Switch#config t
Switch(config)#interface fa0/2
Switch(config-if)#description trunk link ke pfsense
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport trunk allowed vlan all
Switch(config-if)#interface fa0/3
Switch(config-if)#switchport access vlan 2
Switch(config-if)#interface fa0/4
Switch(config-if)#switchport access vlan 3
Switch(config-if)#end
Switch#copy running-config startup-config
Switch#

4.   Selanjutnya adalah penjelasan fungsi command diatas .Setting yang dilakukan dalam situasi ini merupakan setting standart. Dimana password administrator switch diset admin. Sedangkan  port 1 dikonfigurasikan sebagai VLAN 1 secara default oleh Switch. Langkah selanjutnya adalah memberikan IP address dari VLAN 1 yang ada pada port 1 yaitu 192.168.1.2 , sedangkan IP default gateway 192.168.1.1 merupakan IP webconfigurator mesin pfsense. Jadi administrator switch dan pfsense bisa diakses melalui port 1 ini, dengan menggunakan computer yang mempunyai network ID yang sama 192.168.1.0 (192.168.1.3 sampai 192.168.1.254).

Switch>enable
Switch#config t
Switch(config)#enable secret admin
Switch(config)#line vty 0 15
Switch(config-line)#password admin
Switch(config-line)#login
Switch(config-line)#interface vlan1
Switch(config-if)#ip address 192.168.1.2 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#ip default-gateway 192.168.1.1
Switch(config)#exit

5.   Perintah selanjutnya adalah perintah untuk memberikan nama masing-masing VLAN.VLAN 2 diberi nama WAN dan VLAN 3 diberi nama OPT1. Langkah ini bisa dilewatkan, karena switch akan memberikan penamaan secara default seperti vlan0001 untuk VLAN 1, vlan0002 untuk VLAN 2 dan selanjutnya.


Switch#vlan database
Switch(vlan)#vlan 2 name WAN
Switch(vlan)#vlan 3 name OPT1
Switch(vlan)#apply
Switch(vlan)#exit

6.   Perintah selanjutnya adalah perintah untuk mengkonfigurasikan port yang dijadikan Trunk. Perintah dibawah menunjukan port 2 sebagai Trunk, dimana kode fa0/2 artinya port 2 pada switch.

Switch#config t
Switch(config)#interface fa0/2
Switch(config-if)#description trunk link ke pfsense
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport trunk allowed vlan all

7.   Perintah selanjutnya adalah perintah untuk membuat VLAN 2 pada Port 3 dengan konfigurasi default. VLAN  2  pada  Port 3  untuk mengakses/berkomunikasi dengan VLAN 2 pada pfsense dan modem 1.

Switch(config-if)#interface fa0/3
Switch(config-if)#switchport access vlan 2

8.   Perintah selanjutnya adalah perintah untuk membuat VLAN 3 pada Port 4 dengan konfigurasi default. VLAN  3  pada Port 4  untuk mengakses/berkomunikasi dengan VLAN 3 pada pfsense dan modem 2. Perintah selanjutnya untuk mengakhiri dan menyimpan konfigurasi yang telah dibuat.

Switch(config-if)#interface fa0/4
Switch(config-if)#switchport access vlan 3
Switch(config-if)#end
Switch#copy running-config startup-config
Switch#

9.   Gambar dibawah adalah contoh Swith dengan  VLAN yang dikonfigurasikan dengan Web Configurator. Contoh Switch yang digunakan Gigabit 5 port RB250GS dan D-Link DGS-1248T.





10.   Sekarang sudah banyak dijual Switch Managed yang menggunakan Web Configurator dengan harga terjangkau dan mudah diperoleh. Biasanya bermerk Web Smart. Dibawah contoh berbagai Switch Managed yang ada dipasaran mulai dari yang 5 port hingga yang 24 port.

Gigabit 5 port RB250GS
Harga RP. 390.000,-


TP-Link TL-SL2210 WEB 8+2G GIGABIT-UPLINK WEB SMART 8 Port
Harga : Rp. 690.000,-


TL-SL2218 WEB 16+2G GIGABIT-UPLINK WEB SMART 16 Port
Harga : Rp.730.000,-


TL-SL2428 WEB 2 Web 24+4G Gigabit-UP Link Web Smart 24 Port
Harga : Rp. 1.066.000,-

 
ASUS GigaX-1026I 24 Port
Harga : Rp. 1.150.000,-

 
 
11.   Untuk setting VLAN di pfsense bisa dilihat pada document pfsense pada alamat http://doc.pfsense.org/index.php/Multi-WAN_using_VLANs_with_pfSense , atau thread http://forum.pfsense.org/index.php?topic=29870.0



« Last Edit: December 09, 2010, 01:17:36 am by spc »

Offline spc

  • Full Member
  • ***
  • Posts: 159
  • Karma: +6/-1
    • View Profile
Re: [Share] MULTIWAN dengan VLAN di PFSENSE
« Reply #1 on: February 23, 2011, 07:54:17 am »
REFRESH

Offline spc

  • Full Member
  • ***
  • Posts: 159
  • Karma: +6/-1
    • View Profile
Re: [Share] MULTIWAN dengan VLAN di PFSENSE
« Reply #2 on: April 03, 2011, 09:00:28 am »
-- Refresh --

Offline DeSastro

  • Sr. Member
  • ****
  • Posts: 311
  • Karma: +3/-4
    • View Profile
Re: [Share] MULTIWAN dengan VLAN di PFSENSE
« Reply #3 on: April 04, 2011, 09:06:58 am »
Vlan dengan static IP dapat berjalan dengan baik. Ketika Vlan di set PPPoe ini akan menjadi kendala gak berjalan.. ada ide..?

Offline serangku

  • Sr. Member
  • ****
  • Posts: 467
  • Karma: +1/-5
    • View Profile
Re: [Share] MULTIWAN dengan VLAN di PFSENSE
« Reply #4 on: April 05, 2011, 05:30:38 am »
menarik nih om @pfz ...

pppoe gak running di iface vlan ...
itu pk pf yg RC1 ?

hasil log dari pppoe nya seperti apa?


Offline DeSastro

  • Sr. Member
  • ****
  • Posts: 311
  • Karma: +3/-4
    • View Profile
Re: [Share] MULTIWAN dengan VLAN di PFSENSE
« Reply #5 on: April 05, 2011, 08:24:32 am »
di RC 1. 31 Maret. .. waduh.. mengenai log.. lupa gak di save... Cuma. vlan 10. 20 dsb. di terbaca.. tapi ketika di set PPPoe jadi blank.. sepertinya interface. gak dikenal.. ..cma kerana keburu di kejar target.. maka ujicoba terhenti sementara..  ;D.

Kalo untuk VPN mobile. pun bisa runing dengan baik... hanya kendala di operator nya.

Offline DeSastro

  • Sr. Member
  • ****
  • Posts: 311
  • Karma: +3/-4
    • View Profile
Re: [Share] MULTIWAN dengan VLAN di PFSENSE
« Reply #6 on: April 14, 2011, 11:55:21 am »
 ;D sundul

Offline DeSastro

  • Sr. Member
  • ****
  • Posts: 311
  • Karma: +3/-4
    • View Profile
Re: [Share] MULTIWAN dengan VLAN di PFSENSE
« Reply #7 on: April 29, 2011, 11:18:49 am »
segarkan...  ;D

Offline spc

  • Full Member
  • ***
  • Posts: 159
  • Karma: +6/-1
    • View Profile
Re: [Share] MULTIWAN dengan VLAN di PFSENSE
« Reply #8 on: May 04, 2011, 09:20:31 am »
Refresh ...

Offline DeSastro

  • Sr. Member
  • ****
  • Posts: 311
  • Karma: +3/-4
    • View Profile
Re: [Share] MULTIWAN dengan VLAN di PFSENSE
« Reply #9 on: May 20, 2011, 12:17:13 am »
Stick..

Offline kambeeng

  • Moderator
  • Full Member
  • *****
  • Posts: 284
  • Karma: +1/-10
    • View Profile
Re: [Share] MULTIWAN dengan VLAN di PFSENSE
« Reply #10 on: May 21, 2011, 08:31:33 am »
lanjutkan