pfSense Support Subscription

Author Topic: [Share] PFSense LANCard Tunggal untuk Proxy Server  (Read 30592 times)

0 Members and 1 Guest are viewing this topic.

Offline garenjeng

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: [Share] PFSense LANCard Tunggal untuk Proxy Server
« Reply #30 on: April 20, 2015, 11:55:46 pm »
Makasih sharenya om...

bagaimana jika kondisi squidnya tidak mode transparent ?

Offline xsqrt

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: [Share] PFSense LANCard Tunggal untuk Proxy Server
« Reply #31 on: June 07, 2015, 07:24:17 am »
kalo sett nya begini ,

ip modem : 192.168.0.1
ip client : 192.168.1.1 (gateway client)
ip proxy : 192.168.2.1 (di port mikrotik) ntar proxy nya dikasih ip 192.168.2.2

Lancard tunggal, gmn settingan pfsense dan mikrotiknya?

Offline 91X

  • Full Member
  • ***
  • Posts: 159
  • Karma: +5/-2
  • Keep respect to all people!
    • View Profile
Re: [Share] PFSense LANCard Tunggal untuk Proxy Server
« Reply #32 on: June 07, 2015, 07:57:24 pm »
sama persis punya ane gan, ane pakai mark routing di mikrotiknya

Offline 91X

  • Full Member
  • ***
  • Posts: 159
  • Karma: +5/-2
  • Keep respect to all people!
    • View Profile
Re: [Share] PFSense LANCard Tunggal untuk Proxy Server
« Reply #33 on: June 21, 2015, 11:31:16 pm »
setelah semua selesai saya instal, squid n squidguar n ccze. tapi saya liat log pake ccze tidak bisa bisa. pesan
ccze: Command not found

padahal sdah saya instal, pkg install ccze
sukses
mohon agan2 yg sukses pke ccze, sekiranya mau bagi tips
budayakan jangan oot di thread org gan

Offline shr_kaza

  • Jr. Member
  • **
  • Posts: 98
  • Karma: +1/-0
    • View Profile
Re: [Share] PFSense LANCard Tunggal untuk Proxy Server
« Reply #34 on: June 27, 2015, 10:43:54 pm »
setelah semua selesai saya instal, squid n squidguar n ccze. tapi saya liat log pake ccze tidak bisa bisa. pesan
ccze: Command not found

padahal sdah saya instal, pkg install ccze
sukses
mohon agan2 yg sukses pke ccze, sekiranya mau bagi tips
budayakan jangan oot di thread org gan

makasih gan sdah ingatkan, saya hapus karena saya sdah buat tread baru

Offline tendabiru

  • Jr. Member
  • **
  • Posts: 43
  • Karma: +0/-0
    • View Profile
Re: [Share] PFSense LANCard Tunggal untuk Proxy Server
« Reply #35 on: September 10, 2015, 09:46:19 pm »
Selamat pagi @spc.

Sekian lama saya tidak login forum ini, rupanya ada yang bikin tulisan persis yang saya butuhkan.
Kebutuhan saya persis dengan topologi yang kedua; dengan keterangan sebagai berikut:

Router menggunakan mikrotik 450G

IP LAN: 192.168.10.0/24
IP Proxy dari PFsense: 192.168.10.114

Jika boleh tahu, langkah selanjutnya setting di mikrotiknya seperti apa?
Karena saat ini jika saya klik di lightsquid / proxy report dinyatakan belum ada aktifitas sama sekali di squid tersebut.

Mohon pencerahan dari guru spc

Offline kentuss

  • Jr. Member
  • **
  • Posts: 49
  • Karma: +1/-2
    • View Profile
Re: [Share] PFSense LANCard Tunggal untuk Proxy Server
« Reply #36 on: October 13, 2015, 08:10:05 am »
Selamat pagi @spc.

Sekian lama saya tidak login forum ini, rupanya ada yang bikin tulisan persis yang saya butuhkan.
Kebutuhan saya persis dengan topologi yang kedua; dengan keterangan sebagai berikut:

Router menggunakan mikrotik 450G

IP LAN: 192.168.10.0/24
IP Proxy dari PFsense: 192.168.10.114

Jika boleh tahu, langkah selanjutnya setting di mikrotiknya seperti apa?
Karena saat ini jika saya klik di lightsquid / proxy report dinyatakan belum ada aktifitas sama sekali di squid tersebut.

Mohon pencerahan dari guru spc

tinggal dibelokkan saja om trafik http / https ke proxynya.

/ip firewall address-list
add address=192.168.90.0/24 list=ip-proxy
/ip firewall nat
add action=dst-nat chain=dstnat comment="transparent proxy" dst-port=80 protocol=tcp src-address-list=!ip-proxy to-addresses=192.168.10.114 to-ports=3128

/ip route
add check-gateway=ping distance=1 gateway=192.168.10.114 routing-mark=to-ext-proxy
/ip firewall mangle
add action=mark-routing chain=prerouting comment="mark routing to proxy" dst-port=80 new-routing-mark=to-ext-proxy protocol=tcp src-address=192.168.10.0/24


Offline darklords

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: [Share] PFSense LANCard Tunggal untuk Proxy Server
« Reply #37 on: October 27, 2015, 10:34:57 pm »
Selamat pagi @spc.

Sekian lama saya tidak login forum ini, rupanya ada yang bikin tulisan persis yang saya butuhkan.
Kebutuhan saya persis dengan topologi yang kedua; dengan keterangan sebagai berikut:

Router menggunakan mikrotik 450G

IP LAN: 192.168.10.0/24
IP Proxy dari PFsense: 192.168.10.114

Jika boleh tahu, langkah selanjutnya setting di mikrotiknya seperti apa?
Karena saat ini jika saya klik di lightsquid / proxy report dinyatakan belum ada aktifitas sama sekali di squid tersebut.

Mohon pencerahan dari guru spc

tinggal dibelokkan saja om trafik http / https ke proxynya.

/ip firewall address-list
add address=192.168.90.0/24 list=ip-proxy
/ip firewall nat
add action=dst-nat chain=dstnat comment="transparent proxy" dst-port=80 protocol=tcp src-address-list=!ip-proxy to-addresses=192.168.10.114 to-ports=3128

/ip route
add check-gateway=ping distance=1 gateway=192.168.10.114 routing-mark=to-ext-proxy
/ip firewall mangle
add action=mark-routing chain=prerouting comment="mark routing to proxy" dst-port=80 new-routing-mark=to-ext-proxy protocol=tcp src-address=192.168.10.0/24


cara ini kenapa ga bisa di pfsense 2.2.4 dengan squid3 tranparent proxy, selalu invalid request. klo dicoba setting di browser langsung bisa jalan jika di cek log nya. rules juga d allow. sementara balik pake squid 2.7 jalan normal.

Offline darklords

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: [Share] PFSense LANCard Tunggal untuk Proxy Server
« Reply #38 on: November 10, 2015, 07:43:43 pm »
Sorry,

redirect traffic dari klien ke squid3 transparent proxy udah jalan, rupanya butuh port forward di pfsense , permasalahan dah clear. cuman sedikit bingung port forward yg diset harus menggunakan interface WAN, klo pake LAN ga bisa. padahal WAN dah disable. sementara jalan normal sembari berusaha memahami pfsense nya.

Offline miftazuhan

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: [Share] PFSense LANCard Tunggal untuk Proxy Server
« Reply #39 on: September 07, 2017, 08:10:48 pm »
Mantap tutorialnya Gan



agan2 semua mau tanya gmana cara install lusca di pfsense banyak tutorial saya coba tapi ndak bisa install luscanya di package managernya

Offline landy..

  • Newbie
  • *
  • Posts: 3
  • Karma: +2/-1
    • View Profile
Re: [Share] PFSense LANCard Tunggal untuk Proxy Server
« Reply #40 on: September 27, 2017, 11:25:06 pm »
kayaknya sekarang memang sudah tidak bisa instal lusca lagi om, entahlah.. tapi kan bisa pakai squid default dari pfsense saja, bisa cache http dan https juga.