Netgate m1n1wall

Author Topic: SQUID + HAVP + LOADBalancing with Squid Transparent and HAVP Parent to SQUID  (Read 722 times)

0 Members and 1 Guest are viewing this topic.

Offline onkeldave83

  • Full Member
  • ***
  • Posts: 214
  • Karma: +0/-0
    • View Profile
hello at all,

i only success in squid as NOT transparent proxy with havp as transparent proxy with loadbalancing and failover!
(in squid with tcp_outgoing_address 127.0.0.1 and in havp config with parent entry to squid proxy)

in this case you dont get the real user ips in squid report tool.



i want to shema one on your havp package site.

Code: [Select]
Scheme: {inet}->[HAVP]->[Squid cache]->{clients}
Setup

Squid:

    Disable upstream proxy (also will auto-disabled by HAVP)

HAVP:

    Select Proxy mode field as Parent for Squid and Save
    Scan Squid cache with Antivirus: File scanner for removing cached viruses.
    If you are planning to use Transparent Proxy mode: Squid transparent on

(do not delete exists Squid Custom Options)


this is squid as transparent and havp as parent to squid!!!
this is the best way and you have the correct log ;)
BUT i dont get it to success with loadbalancing.

have someone the correct config to do this????

when i put squid as transparent and then havp as parent you get in squid costum options:
Code: [Select]
never_direct allow all;cache_peer 127.0.0.1 parent 4444 0 name=havp no-query no-digest no-netdb-exchange default;redirect_program /usr/local/bin/squidGuard -c /usr/local/etc/squidGuard/squidGuard.conf;redirector_bypass on;redirect_children 3

you cant put tcp_outgoing_address to local interface into this - this wrong, but what is the right way to do this???

please help to resolve problem!

i have test it with squid 2.7, squid3 and pfsense 2.01 and 2.1 development, but ever no success! :((((

« Last Edit: April 25, 2012, 08:23:53 am by onkeldave83 »