pfSense Gold Subscription

Author Topic: Inconsistent WAN Speeds with pfSense  (Read 1389 times)

0 Members and 1 Guest are viewing this topic.

Offline dchuraman

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Inconsistent WAN Speeds with pfSense
« on: April 25, 2012, 05:07:39 am »
Hi all

Ive had my new broadband installed for a few days now, its BT infinity 80/20 fibre service. I built a pfSense box and have it configured in a fairly simple set up as my gateway and not doing much else. I have the BT provided VDSL modem between the pfsense box and the outside which i dont have access to.

I have been testing my speeds with a couple of 50GB newsgroup downloads. When I use the BT HomeHub router they supply, i get a fairly consistent 8.9MB/s download speed on any newsgroup download i try. When using pfsense in exactly the same configuration (ie just swapping the bt router for the pfsense box), my downloads are anything but consistent. I can sometimes hit 8.9MB/s for a couple of seconds or so, but usually the speed fluctuates between 3.8 - 6MB/s and I have my download client set to update the speed on 1 second intervals so i can see the massive changes in speed every second. I cant seem to get a consistent speed to max out the connection like i used to with my ADSL service or like I do with the BT supplied router.

This is my traffic graph over the space of about 5 minutes from the pfSense dashboard:



Can anyone help?!

Offline podilarius

  • Hero Member
  • *****
  • Posts: 1768
  • Karma: +0/-0
    • View Profile
Re: Inconsistent WAN Speeds with pfSense
« Reply #1 on: April 25, 2012, 06:11:01 am »
Have you tried to adjust the MTU on the WAN interface? Are you using any traffic shaping?

Offline dchuraman

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: Inconsistent WAN Speeds with pfSense
« Reply #2 on: April 25, 2012, 06:12:53 am »
no traffic shaping in use. I havent tried adjusting the MTU, do you know what values should I experiment with?

Offline podilarius

  • Hero Member
  • *****
  • Posts: 1768
  • Karma: +0/-0
    • View Profile
Re: Inconsistent WAN Speeds with pfSense
« Reply #3 on: April 25, 2012, 06:42:41 am »
Not really. 1390 comes to mind. If you can look at the settings in the BT router, perhaps they have set a particular MTU and perhaps you could copy that. Otherwise, just lower it by a 100 and experiment with speed until it levels out. If that does not help, it could also be duplex and speed settings. The modem might be hard coded and you are using auto negotiate. Again, I would check the settings on the provided router if possible to get an idea of what you need to setup.

Offline dchuraman

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: Inconsistent WAN Speeds with pfSense
« Reply #4 on: April 25, 2012, 06:55:11 am »
unfortunately the homehub is very locked down, you cant see any of those settings. ive experimented with a few values and im still getting the same.

Offline podilarius

  • Hero Member
  • *****
  • Posts: 1768
  • Karma: +0/-0
    • View Profile
Re: Inconsistent WAN Speeds with pfSense
« Reply #5 on: April 25, 2012, 07:25:36 am »
If it is new, you might be able to contact your provider to get that information.

Offline stephenw10

  • Hero Member
  • *****
  • Posts: 8165
  • Karma: +7/-0
    • View Profile
Re: Inconsistent WAN Speeds with pfSense
« Reply #6 on: April 25, 2012, 03:38:34 pm »
I have personally found BT Infinity to be wildly varying in throughput.
I have the old 40/2 service but get anywhere from the expected 36-37Mbps at 2 AM to 15-16Mbps at 6 PM.
Try it late at night.
Try using the Windows PPPoE client directly (or whatever OS you are running).

Steve