The pfSense Store

Author Topic: Problem with PowerD tuning  (Read 1175 times)

0 Members and 1 Guest are viewing this topic.

Offline gregober

  • Jr. Member
  • **
  • Posts: 71
    • View Profile
    • OSNet your provider of Open Source appliances for pfSense
Problem with PowerD tuning
« on: May 11, 2012, 11:01:07 am »
Hi,

I am trying to have PowerD tuned correctly with a Lanner device that I am resaling.

By default sysctl dev.cpu gives the following :

Code: [Select]
# sysctl dev.cpu
dev.cpu.0.%desc: ACPI CPU
dev.cpu.0.%driver: cpu
dev.cpu.0.%location: handle=\_PR_.P001
dev.cpu.0.%pnpinfo: _HID=none _UID=0
dev.cpu.0.%parent: acpi0
dev.cpu.0.cx_supported: C1/0
dev.cpu.0.cx_lowest: C1
dev.cpu.0.cx_usage: 100.00% last 5000us
dev.cpu.1.%desc: ACPI CPU
dev.cpu.1.%driver: cpu
dev.cpu.1.%location: handle=\_PR_.P002
dev.cpu.1.%pnpinfo: _HID=none _UID=0
dev.cpu.1.%parent: acpi0
dev.cpu.1.cx_supported: C1/0
dev.cpu.1.cx_lowest: C1
dev.cpu.1.cx_usage: 100.00% last 5000us


I need to load the cpufreq using kldload to have It taken into account in the kernel :

Code: [Select]
# kldload cpufreq
# sysctl dev.cpu
dev.cpu.0.%desc: ACPI CPU
dev.cpu.0.%driver: cpu
dev.cpu.0.%location: handle=\_PR_.P001
dev.cpu.0.%pnpinfo: _HID=none _UID=0
dev.cpu.0.%parent: acpi0
dev.cpu.0.cx_supported: C1/0
dev.cpu.0.cx_lowest: C1
dev.cpu.0.cx_usage: 100.00% last 5000us
dev.cpu.0.freq: 1658
dev.cpu.0.freq_levels: 1658/-1 1450/-1 1243/-1 1036/-1 829/-1 621/-1 414/-1 207/
-1
dev.cpu.1.%desc: ACPI CPU
dev.cpu.1.%driver: cpu
dev.cpu.1.%location: handle=\_PR_.P002
dev.cpu.1.%pnpinfo: _HID=none _UID=0
dev.cpu.1.%parent: acpi0
dev.cpu.1.cx_supported: C1/0
dev.cpu.1.cx_lowest: C1
dev.cpu.1.cx_usage: 100.00% last 5000us


How can I had this so that the loadable module "cpufreq" will be taken into account at boot time ?
And PowerD will be optimized for my platform.


Thanks.

Online stephenw10

  • Hero Member
  • *****
  • Posts: 8097
    • View Profile
Re: Problem with PowerD tuning
« Reply #1 on: May 11, 2012, 02:44:59 pm »
Create a file /boot/loader.conf.local and put in it the line:
cpufreq_load="YES"

You can put this in loader.conf but it is sometimes overwritten, better to use the above file.

You probably also have to set the kernel timecounter to i8254 instead of TSC.
Go to System: Advanced: System Tunables: in the GUI. Add a new tunable called 'kern.timecounter.hardware' and set the value to 'i8254'.

See: http://forum.pfsense.org/index.php/topic,26238.msg136719.html#msg136719

Which Lanner device are you using?

Steve

Offline gregober

  • Jr. Member
  • **
  • Posts: 71
    • View Profile
    • OSNet your provider of Open Source appliances for pfSense
Re: Problem with PowerD tuning
« Reply #2 on: May 12, 2012, 08:47:47 am »
This is what I love about our community (pfSense fans and users) 

I have posted two questions yesterday and obtained 6 replies within a day !!!


This is so great.


Thank you so much for being so efficient.

I am reselling the FW-7535-G but I will have couple of new devices base on the Intel Atom (like FW-7540) 
I have also seen that there is a new upcoming option to have more options in PowerD management (seen that on github).

 ;D

Online stephenw10

  • Hero Member
  • *****
  • Posts: 8097
    • View Profile
Re: Problem with PowerD tuning
« Reply #3 on: May 12, 2012, 11:03:26 am »
Looks like a nice unit.
Are you using the status LED for anything?

I have to agree, this forum/community is by far the most helpful and satisfying I've ever been involved with.

Steve