The pfSense Store

Author Topic: Voucher Sync Https Port  (Read 1007 times)

0 Members and 1 Guest are viewing this topic.

Offline carbm1

  • Newbie
  • *
  • Posts: 5
    • View Profile
Voucher Sync Https Port
« on: May 28, 2012, 09:19:49 am »
I have two locations that users frequently travel back and forth between. I have vouchers setup and I would like to generate vouchers on one system and when the user goes to the other location they can use the same voucher and it work. However, I can't get the sync to work over https if the webconfigurator port is changed from 443.

Code: [Select]
The error recieved is:

The following input errors were detected:
An error code was received while attempting CaptivePortalVoucherSync XMLRPC sync with http://[ipaddress]:10443 - Code 2: Invalid return payload: enable debugging to examine incoming payload

You can see that is changes to http instead of https if I use any other port than 443.

I opened up /etc/inc/voucher.inc and modified the if statement in 3 places.

Code: [Select]
if($port == "10443")
$url = "https://{$syncip}";
else
$url = "https://{$syncip}";

However this doesn't make a difference. I can't seem to figure out where it is deciding to use https or http.

Anybody know how to fix this?

Thanks,

Craig



Offline carbm1

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Voucher Sync Https Port
« Reply #1 on: October 15, 2012, 07:03:00 pm »
Many moons later this issue came up again.

Edit /usr/local/www/services_captiveportal_vouchers.php

Line 234:
Code: [Select]
if($config['voucher']['vouchersyncport'] == "443")

Change to:
Code: [Select]
if($config['voucher']['vouchersyncport'] == "10443")

Hope this helps someone else.