Netgate m1n1wall

Author Topic: Problem with Collisions  (Read 1108 times)

0 Members and 1 Guest are viewing this topic.

Offline danesco

  • Jr. Member
  • **
  • Posts: 84
  • Karma: +0/-0
    • View Profile
Problem with Collisions
« on: July 03, 2012, 11:03:03 am »
Im having a lot of collisions in a wireless network where Pfsense acts like router. The weird thing its because i have 3 practically same topology (2 WAN 1 LAN Wireless Network), and the other two have 0 collisions, have checked with wireshark for strange packets or traffic but no luck, any idea of what can be happen?

Online mhab12

  • Hero Member
  • *****
  • Posts: 648
  • Karma: +0/-0
    • View Profile
Re: Problem with Collisions
« Reply #1 on: July 06, 2012, 11:50:59 am »
Check for duplex and/or link speed mismatch.  Try hard coding both sides of the interfaces to 100/FD or another setting and see if it helps.

Offline novacoresystems

  • Jr. Member
  • **
  • Posts: 30
  • Karma: +0/-0
    • View Profile
    • Novacore Systems
Re: Problem with Collisions
« Reply #2 on: July 07, 2012, 07:16:10 pm »
Yeah I agree, that usually is the culprit... auto negotiation doesn't always work well. Set 1000Gbps Full if both NICs support it, if not 100 Full. Also, sometimes forcing either one of the other regardless of what the cards support can solve these issues.

Offline danesco

  • Jr. Member
  • **
  • Posts: 84
  • Karma: +0/-0
    • View Profile
Re: Problem with Collisions
« Reply #3 on: July 07, 2012, 08:14:51 pm »
Ok i will start for checking that, this can be a missmatch in any place of the net right? or you mean in the pfsense interfaces

Offline stephenw10

  • Hero Member
  • *****
  • Posts: 8175
  • Karma: +8/-0
    • View Profile
Re: Problem with Collisions
« Reply #4 on: July 07, 2012, 09:26:24 pm »
The collisions are shown at those interfaces so the mismatch would be between the pfSense interface and whatever it's connected to.
However duplex mismatch is usually (always in my experience) associated with a massive reduction in throughput. Like <1Mbps.
It's still the first thing I'd check.

Steve