Netgate SG-1000 microFirewall

Author Topic: Known working Wireless cards  (Read 18847 times)

0 Members and 1 Guest are viewing this topic.

Offline lsf

  • Wireless Expert
  • Hero Member
  • *****
  • Posts: 3263
  • Karma: +5/-0
    • View Profile
Known working Wireless cards
« on: October 08, 2013, 03:42:39 pm »
Hi all,

Since the HW lists are getting old I'd like to have users report Cards that Works.

Please list the following output from Shell command:

pciconf -lv

Please also try to explain in detail:
  • Brand/Model/Version/ and how you used it (Client/AP/mesh etc.)
  • pfSense Version/build

No questions in this thread!
« Last Edit: January 26, 2014, 05:25:15 pm by lsf »
-lsf

Offline freebee

  • Full Member
  • ***
  • Posts: 134
  • Karma: +2/-0
    • View Profile
Re: Known working Wireless cards
« Reply #1 on: October 17, 2013, 10:41:59 am »
pfSense 2.1 - i386 (Alix Board, custom kernel, MWL_DEBUG=NO).

Marvell 88W8363
Rev A5 hardware, v3.6.2.2 firmware (regioncode 16)

2 AP (1 virtual for captive portal)

ifconfig output (some values hide):

mwl0_wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290
   ether 00:-:-:-:-:-
   inet6 fe80::21f:f3ff:fec3:730%mwl0_wlan0 prefixlen 64 scopeid 0x9
   inet 192.168.244.1 netmask 0xffffff00 broadcast 192.168.244.255
   nd6 options=1<PERFORMNUD>
   media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng <hostap>
   status: running
   ssid -- channel 6 (2437 MHz 11g ht/40+) bssid 00:--:--:--:--:--
   regdomain DEBUG indoor authmode WPA2/802.11i privacy MIXED deftxkey 3
   AES-CCM 2:128-bit AES-CCM 3:128-bit txpower 16 scanvalid 60
   protmode CTS -ampdu ampdulimit 64k ampdudensity 4 shortgi smps burst
   -apbridge dtimperiod 1

Offline Clear-Pixel

  • Full Member
  • ***
  • Posts: 262
  • Karma: +4/-5
    • View Profile
Re: Known working Wireless cards
« Reply #2 on: November 15, 2013, 06:30:25 pm »
See my Signature below for chipset I'm currently running.

Seems to run fine ..... I have had some stuck beacon problems in the past every now and than. I would be forced to do a reboot and would clear up ..... recently this has not been occurring which I find to be rather strange behavior .... knock on wood.

Wikidevi Link list all Atheros chipsets ever manufactured.

http://wikidevi.com/wiki/Atheros
« Last Edit: November 15, 2013, 06:57:55 pm by Clear-Pixel »
HP EliteBook 2530p Laptop - Core2 Duo SL9600 @ 2.13Ghz - 4 GB Ram -128GB SSD
Atheros Mini PCI-E as Access Point (AR5BXB63H/AR5007EG/AR2425)
Single Ethernet Port - VLAN
Cisco SG300 10-port Gigabit Managed Switch
Cisco DPC3008 Cable Modem  30/4 Mbps
Pfsense 2.1-RELEASE (amd64)
--------------------------------------------------------------
Total Network Power Consumption - 29 Watts

Offline bonzi

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Known working Wireless cards
« Reply #3 on: January 15, 2014, 11:08:47 am »
I'm running an atheros 9280 in AP on pfsense 2.1 that I picked up off of ebay:

ath0@pci0:3:0:0:   class=0x028000 card=0x655211ad chip=0x002a168c rev=0x01 hdr=0x00
    class      = network

Offline plong

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Known working Wireless cards
« Reply #4 on: January 21, 2014, 06:47:05 pm »
lsf, I believe you meant to say, "pciconf -lv" rather than "pciconfig -lv".

Offline Fevan

  • Jr. Member
  • **
  • Posts: 96
  • Karma: +2/-0
    • View Profile
Re: Known working Wireless cards
« Reply #5 on: February 10, 2014, 06:47:19 am »
Good this is sticky, I have read the last 10 pages and it appears varying results some guys use wireless adaptors/cards and still get the random rebooting/pfsense config crashing and getting wiped issues, even with compatible adaptors/cards !

Some people over the last few pages suggested these as options:

TP-Link TL-WN7200ND 150Mbps High Power Wireless USB Adapter
Ralink RT3072 Adapter (seemed good compatible wise)

Seems these maybe good options to go for but it appears some got them and still had similar issues some went for weeks without issues though. Obviously don't take my word for it on the above wireless adaptors since some suggested it was hit and miss for them also.

One guy posted Its better to get a wireless router and use that as an access point, I agree I think this is the best route and will give it a try perhaps.

Offline pvoigt

  • Full Member
  • ***
  • Posts: 248
  • Karma: +1/-0
    • View Profile
Re: Known working Wireless cards
« Reply #6 on: February 13, 2014, 05:40:02 am »
Well, I could recommend several cards working well with pfSense 2.0.3. But since pfSense 2.1.x I am having a lot of trouble with wireless at all. I think I have narroved it down to 802.1x authentication which makes any of may WLAN cards stop working as soon as it is enabled. Under 2.0.3 I am having no problem with 802.1x authentication. I have summarized my latest experiences with pfSense 2.1.1-PRERELEASE under:
https://forum.pfsense.org/index.php/topic,72483.0.html

Most interesting question for me is: Is anybody using successfully 802.1x authentication with pfSense 2.1.x? If so, please give me feedback, because I am close to openening a ticket for it.

Hope, my post is not off-topic as questions are not wanted  :) And I do not mind, if the thread opener feels, my post should be better moved to a new topic.

Regards,
Peter
« Last Edit: February 13, 2014, 05:49:59 am by pvoigt »

Offline pvoigt

  • Full Member
  • ***
  • Posts: 248
  • Karma: +1/-0
    • View Profile
Re: Known working Wireless cards
« Reply #7 on: February 24, 2014, 05:42:40 pm »
Well, the avove mentioned general WLAN issue under pfSense 2.1.x is solved now with the latest 2.1 snapshot and I can give some more detailed feedback on the actual topic of this thread.

This Atheros AR5213A based Wistron CM9 miniPCI card is working under 2.0.x and 2.1.x:
Code: [Select]
ath0: <Atheros 5212> mem 0xe00c0000-0xe00cffff irq 9 at device 12.0 on pci0     
ath0: [ITHREAD]                                                                 
ath0: AR5212 mac 5.9 RF5112 phy 4.3

And this Atheros 9280 based UBIQUITI SR71-E miniPCIe card is working under pfSense 2.0.x:
Code: [Select]
ath0: <Atheros 9280> mem 0xa3000000-0xa300ffff irq 17 at device 0.0 on pci7     
ath0: [ITHREAD]                                                                 
ath0: AR9280 mac 128.2 RF5133 phy 13.0
I could not yet test it under pfSense 2.1.x but expect  it working there as well.

Peter
« Last Edit: February 24, 2014, 05:44:32 pm by pvoigt »

Offline pvoigt

  • Full Member
  • ***
  • Posts: 248
  • Karma: +1/-0
    • View Profile
Re: Known working Wireless cards
« Reply #8 on: April 07, 2014, 10:41:29 am »
I have just upgraded my Soekris net6501 machine to pfSense 2.1.1 and can confirm the Atheros 9280 based UBIQUITI SR71-E miniPCIe card is still working nice - of course in abg modes only.

Regards,
Peter

Offline Elludium_Q-36

  • Jr. Member
  • **
  • Posts: 51
  • Karma: +1/-1
    • View Profile
Right now, I'm running:
Quote
pfSense 2.1.2-RELEASE (i386)
built on Thu Apr 10 05:23:34 EDT 2014
FreeBSD 8.3-RELEASE-p15


I bought a used BearExtender Mini b/g/n 1,000 mW / 1 Watt, USB 2.4 Ghz WiFi adapter, branded for Apple/Mac.



I think I ran a command on my linux box, which showed it to have a Ralink chip(set).



Within pfSense, it was able to associate it with a "guest" ssid, within range, but that's probably password redirected/port capture/walled garden/etc.

  • It can scan, as seen on webConfigurator/GUI page, Status: Wireless
Code: [Select]
../status_wireless.php
  • I pressed the DHCP "Renew" button on webConfigurator/GUI page, Status: Interfaces:
    Code: [Select]
    ../status_interfaces.php
             
    • This caused pfSense to crash, necessitating a reboot.
    • I've had one other, since then, which happened when there was no human activity.


Since it's a USB device, I didn't use command:
Code: [Select]
pciconf -lv

But ran:
Code: [Select]
$  ifconfig | grep -A4 -i wireless
   media: IEEE 802.11 Wireless Ethernet autoselect mode 11b
   status: associated
run0_wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
   ether 00:1e:97:xx:xx:xx
   inet6 xxxx::xxx:xxxx:xxxx:xxxx%run0_wlan0 prefixlen 64 scopeid 0xd
--
   media: IEEE 802.11 Wireless Ethernet autoselect mode 11g (autoselect)
   status: no carrier
   ssid "-------------" channel 9 (2452 MHz 11b)
   regdomain FCC country US outdoor authmode OPEN privacy OFF txpower 30
   bmiss 7 scanvalid 60

I also ran:
Code: [Select]
$ ifconfig run0_wlan0
run0_wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
   ether 00:1e:97:xx:xx:xx
   inet6 xxxx::xxx:xxxx:xxxx:xxxx%run0_wlan0 prefixlen 64 scopeid 0xd
   nd6 options=1<PERFORMNUD>
   media: IEEE 802.11 Wireless Ethernet autoselect mode 11g (autoselect)
   status: no carrier
   ssid "-------------" channel 9 (2452 MHz 11b)
   regdomain FCC country US outdoor authmode OPEN privacy OFF txpower 30
   bmiss 7 scanvalid 60
  • I see "txpower" = "30", but for the interface config, it's set to 99.  It's a 1,000 mW device. This is dictated by:
    Code: [Select]
    /etc/regdomain.xml


  • I did NOT find a setting for, 802.11n, but only "b" or "g", on the screen to setup the interface, the section:
    Quote
    Common wireless configuration - Settings apply to all wireless networks on run0.
         
  • The section: General configuration -> Speed and duplex -> Advanced, drop down list menu, had some entries without numbers.  Those with max speed numbers, listed 54 M/s, as the top.
The pfSense Docs page that came up in a search, make no mention of this:
https://doc.pfsense.org/index.php/Wireless_Interfaces
However, from that page, following the link: list of supported cards, shows that  this is normal.
This is spelled out in Category:Wireless -> Is 802.11n wireless supported


I also ran:
Code: [Select]
$ usbconfig
ugen4.2: <product 0x3070 vendor 0x148f> at usbus4, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON


An internet search yielded:
Quote
USB: 148F:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter


I'd much prefer a decent Atheros Chip.

:-| :-/ 
:-\
« Last Edit: May 31, 2014, 11:40:01 am by Elludium_Q-36 »

Offline amunrara

  • Newbie
  • *
  • Posts: 24
  • Karma: +3/-0
    • View Profile
Re: Known working Wireless cards
« Reply #10 on: December 11, 2014, 03:34:38 pm »
450 Mbit/s Original Atheros AR9380 AR5BXB112 Mini PCIe WLAN

Offline shaqan

  • Jr. Member
  • **
  • Posts: 75
  • Karma: +4/-0
    • View Profile
Re: Known working Wireless cards
« Reply #11 on: January 07, 2015, 02:27:27 pm »
DELL DW1525 works (PCI-Express 1x card),  Atheros AR9280 chipset.

Depending where you live, you might need to change regdomain in EEPROM.

there is link in one of the Mac forums with a good tool: (downloading presumes registration in forum)
http://www.insanelymac.com/forum/topic/299732-atheros-9k-series-rom-modding-tools-and-recovery-kit/

aet_rw512_AnV.zip - contains source code, x86/x64 executables of eeprom tool and some sample firmwares
atheros_eeprom_tool-WIN8.1.zip - contains only executables modified for compatibility with Windows 8.1

warning: if you go and try to change regdomain it must be in form of two digits (for example 37 for EU) or you are going to brick the card.

Why would you need EEPROM tools? In order to unlock "N" for AP mode or modification of regdomain (unlock "g" channels 11-14 where you should have them but don't)

Offline CFMunster

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: Known working Wireless cards
« Reply #12 on: January 11, 2015, 05:03:07 am »
pciconf -lvc

ral0@pci0:0:17:0:   class=0x028000 card=0x28601814 chip=0x06011814 rev=0x00 hdr=0x00
    class      = network
    cap 01[40] = powerspec 3  supports D0 D3  current D0

card: EMP 9701
size: half-length mini-PCI
chipset: RT2860+RT2820
driver: ral

http://www.freebsd.org/cgi/man.cgi?query=ral

AP mode, WPA2 security

2.2-RC 32 bit on Soekris NET6501

Only b/g mode supported in the driver, so if you are looking for n speeds, I recommend Atheros.

Offline BoMbY

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-1
    • View Profile
Re: Known working Wireless cards
« Reply #13 on: February 22, 2015, 08:08:06 am »
Asus USB-N66 working as Access Point out of the box on pfSense 2.2-RELEASE (amd64). Only 802.11a/b/g though - 802.11n does not seem to be supported by pfSense or the driver:

filtered output from dmesg (if it helps anyone):

Code: [Select]
usbus0 on xhci0
usbus0: 5.0Gbps Super Speed USB v3.0
ugen0.1: <0x1912> at usbus0
uhub1: <0x1912 XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus0
run0: <1.0> on usbus0
run0: MAC/BBP RT3593 (rev 0x0402), RF RT3053 (MIMO 3T3R), address 08:xx:xx:xx:xx:xx
wlan0: changing name to 'run0_wlan1'
run0: firmware RT3071 ver. 0.33 loaded

Offline jonesr

  • Full Member
  • ***
  • Posts: 100
  • Karma: +16/-0
    • View Profile
Re: Known working Wireless cards
« Reply #14 on: March 19, 2015, 01:26:01 pm »
Quote
Please also try to explain in detail:

    Brand/Model/Version/ and how you used it (Client/AP/mesh etc.)
    pfSense Version/build

Mini PCIe card pulled from broken laptop, not sure of exact device beyond AR9285, HostAP mode. pfSense AMD64 VGA 2.2.1.




This isn't the fairest test in the world but here are the results of speed tests to www.speedtest.net:


Wired network - D/L 66Mbs U/L 12Mb/s - My ISP baseline.

Wireless network - D/L 25Mb/s U/L 12Mb/s


--After setting the minimum standard to 802.11n (was g).

Wireless network D/L 36Mb/s U/L 12Mb/s


Two configuration changes (min standard 802.11n requires WME tickbox to be checked) and my throughput has increased 40%. All results are the average of three tests each so it isn't a glitch. It may be a fraction of what you might expect but exceeds my personal requirements.


Code: [Select]
$ pciconf -lv

ath0@pci0:2:0:0: class=0x028000 card=0x10891a3b chip=0x002b168c rev=0x01 hdr=0x00
    class      = network

 
pfSense AMD64 VGA - Assume latest version.
Suricata, pfBlockerNG, SquidGuard, squid3.