pfSense Support Subscription

Author Topic: Source Dedicated Server & pfSense  (Read 22725 times)

0 Members and 1 Guest are viewing this topic.

Offline KingJ

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Source Dedicated Server & pfSense
« on: November 28, 2007, 11:43:35 am »
This combination has caused me much agony, but I (with the help of a few others) found a solution. Bascially, due to NAT issues, the wrong IP is reported to Valve's Master Servers and hence your server fails to appear on their master server list. The result of this is that no one connects to your server.

Okay, first of all, go to the NAT page, click the outbound tab. Select to enable Advanced Outbound NAT. Don't worry, a new rule will automatically be created to replace the existing automatic one.
Then, create a new rule. The source should be the subnet your server is on (for me, it was 10.0.1.0 /24) and a source port of 27015 (or another port if your server runs on a different one). Check the box that says Static Port and click save.
Now, move the rule up above the default rule that was created. All you need to do now is to reset the state table and your server will now show up in the master server list after a period of time. To help speed up the server synchronization with Valve's Master Servers, type heartbeat into the server console.

Thanks to thezfunk and brown on srcds.com's forums for helping with this. Thought i'd post it here as some people will more than likely come here as opposed to searching for the obscure answer :)

(For those who are wondering what Source Dedicated Server or SRCDS is, its the server application that hosts games based upon Valve's Source Engine, including Counter Strike: Source, Half Life 2 Deathmatch, Team Fortress 2 and more)

Offline cmb

  • Hero Member
  • *****
  • Posts: 11230
  • Karma: +893/-7
    • View Profile
    • Chris Buechler
Re: Source Dedicated Server & pfSense
« Reply #1 on: November 28, 2007, 09:46:21 pm »
That's why one of the sticky posts on this thread, "PROBLEMS WITH A GAME? Try this first", recommends static port. :) 

Good description though, making this a sticky.

Offline waltl

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Source Dedicated Server & pfSense
« Reply #2 on: December 25, 2008, 10:47:27 pm »
KingJ, thanks for this post. I'm going to try this change to my pfSense firewall in the next few days, hopefully resolving the problem of my CS:Source game server not showing up in the Steam master servers list.

There's a bunch of non-game (business) servers behind my firewall, as well. Hopefully, this change will not break outside access to those servers. I've backed up my pfSense config before making this change, of course, just in case.

Offline waltl

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Source Dedicated Server & pfSense
« Reply #3 on: March 19, 2009, 10:30:37 pm »
This worked great for me, thanks!

jigglywiggly

  • Guest
Re: Source Dedicated Server & pfSense
« Reply #4 on: May 18, 2009, 01:41:51 am »
THANK YOU SO MUCH! I was wondering why people couldn't see my server, and other connection issues.
But why do we have to do this? I mean what is this doing? I am a pfsense noob obviously, and I mean why do we have to do this in the first place if it's already port forwarded?

EDIT: I still don't think it's working :o
Ok so in nat I went to outbound I make a new rule called obsidian conflict(hl2 mod) and set it at as 192.168.1.0 (Is that right? I connect to my router via 192.168.1.1) and I set the checkbox for static and select port 27016(because this is the port it's on)
I put the rule above the default one and I hit save then apply. Should work right? I also have it correctly port forwarded too. Any ideas? (PS this router wants me to grind my face on a cheese grater lol, I mean it's so hard to get stuff that should work by default... also why is upnp disabled by default :o and xbl should work outa the box imo. Like profiles of common things would make life a lot better. However the amazing QoS on this router is hard to beat, argh life is so tough  :D)
« Last Edit: May 18, 2009, 01:59:49 am by jigglywiggly »

Offline krosseyed

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Source Dedicated Server & pfSense
« Reply #5 on: May 24, 2009, 02:35:25 am »
I have followed these instructions to the dot, yet I am unable to get my server on the master list! other people can connect, and i can see that the port is accessable via WAN.'

Edit: sv_lan is 0, yet it reports that it is a LAN server (No heartbeat, no authentication, no non-class c addresses)
« Last Edit: May 24, 2009, 02:41:48 am by krosseyed »

Offline GruensFroeschli

  • Little Green Frog
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 5423
  • Karma: +86/-3
  • No i will not fix your computer!
    • View Profile
Re: Source Dedicated Server & pfSense
« Reply #6 on: May 24, 2009, 07:28:47 am »
If people can connect, but you cannot get the server listed, it's a config problem of your server.
Try the support channels of the hlds.
We do what we must, because we can.

Asking questions the smart way: http://www.catb.org/esr/faqs/smart-questions.html

Offline krosseyed

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Source Dedicated Server & pfSense
« Reply #7 on: May 24, 2009, 06:19:40 pm »
Well, I have found out what the problem might be.

http://forums.srcds.com/viewtopic/9380

The error I am getting (sv_lan is 0...) could be due to a bug. If I could get another person to test this out that would make me feel better.

Edit: Also, make sure that you have your sv_region set to anything but -1, or the server will not show up on the master list!