Netgate SG-1000 microFirewall

Author Topic: HEADS UP: Updated em/igb/ixgbe back in snapshots  (Read 7676 times)

0 Members and 1 Guest are viewing this topic.

Offline athurdent

  • Hero Member
  • *****
  • Posts: 650
  • Karma: +36/-7
  • N00b.
    • View Profile
Re: HEADS UP: em/igb/ixgbe reverted to older drivers
« Reply #15 on: March 03, 2014, 07:09:10 am »
Maybe running pfSense from USB flash is an option?

Offline qseb

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: HEADS UP: em/igb/ixgbe reverted to older drivers
« Reply #16 on: March 04, 2014, 05:32:11 am »
Hello

is it still possible to insert manually new igb drivers to boot.conf for next 2.1.1 snaphots?
Currently, I have a 2.1.1 from january with new igb, how to extract modules?

Offline stephenw10

  • Administrator
  • Hero Member
  • *****
  • Posts: 11912
  • Karma: +467/-15
    • View Profile
Re: HEADS UP: em/igb/ixgbe reverted to older drivers
« Reply #17 on: March 04, 2014, 05:46:03 am »
The drivers are compiled into the kernel so you can't extract them as modules. However if you did get hold of the modules there should be no problem loading them via loader.conf.local.

Steve

Offline demco

  • Jr. Member
  • **
  • Posts: 41
  • Karma: +5/-0
    • View Profile
Re: HEADS UP: em/igb/ixgbe reverted to older drivers
« Reply #18 on: March 04, 2014, 06:18:32 am »
Hi,

Anyone know if the snapshot dated 20140217-1607 contains the newer driver?

Tried the image on a Rangeley box and boot log seem to indicate no network driver.

pci0: <network, ethernet> at device 20.0 (no driver attached)
pci0: <network, ethernet> at device 20.1 (no driver attached)
pci0: <network, ethernet> at device 20.2 (no driver attached)
pci0: <network, ethernet> at device 20.3 (no driver attached)

Just want to confirm that it is the driver and not something else, before trying to build the new driver.

full boot log attached.

Thanks.

Offline qseb

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: HEADS UP: em/igb/ixgbe reverted to older drivers
« Reply #19 on: March 04, 2014, 07:39:16 am »
The drivers are compiled into the kernel so you can't extract them as modules. However if you did get hold of the modules there should be no problem loading them via loader.conf.local.

Steve
Yes I saw kldstat not returning modules. How to get the igb module file?

Offline stephenw10

  • Administrator
  • Hero Member
  • *****
  • Posts: 11912
  • Karma: +467/-15
    • View Profile
Re: HEADS UP: em/igb/ixgbe reverted to older drivers
« Reply #20 on: March 04, 2014, 07:50:35 am »
Compile it yourself.
Ask ESF nicely.
Search the forum, I think a few others have compiled newer modules but I also think that the version included in earlier 2.1.1 snapshots had patches.

They were removed from 2.1.1 for good reason though. I guess if it works at all for you that's better than than nothing.

Steve

Offline ermal

  • Hero Member
  • *****
  • Posts: 3832
  • Karma: +85/-5
    • View Profile
Re: HEADS UP: em/igb/ixgbe reverted to older drivers
« Reply #21 on: March 10, 2014, 04:28:51 pm »
The drivers from HEAD have been enabled again in the snapshots after fixing the cause of panics.

Please try them again in later snapshots.

Offline stephenw10

  • Administrator
  • Hero Member
  • *****
  • Posts: 11912
  • Karma: +467/-15
    • View Profile
Re: HEADS UP: em/igb/ixgbe reverted to older drivers
« Reply #22 on: March 10, 2014, 04:43:56 pm »
Woot!  ;D
Great news. Updating...
They are in current snapshots I presume? (08-Mar-2014) Or wait for new builds?

Steve

Offline maverick_slo

  • Hero Member
  • *****
  • Posts: 809
  • Karma: +37/-2
    • View Profile
Re: HEADS UP: em/igb/ixgbe reverted to older drivers
« Reply #23 on: March 11, 2014, 03:12:06 am »
So *NEW* drivers are again included?
Also em drivers?

Thanks!

Offline maverick_slo

  • Hero Member
  • *****
  • Posts: 809
  • Karma: +37/-2
    • View Profile
Re: HEADS UP: em/igb/ixgbe reverted to older drivers
« Reply #24 on: March 11, 2014, 10:51:18 am »
Huh only March 8 snapshots are available...
Something went wrong?

Offline stephenw10

  • Administrator
  • Hero Member
  • *****
  • Posts: 11912
  • Karma: +467/-15
    • View Profile
Re: HEADS UP: em/igb/ixgbe reverted to older drivers
« Reply #25 on: March 11, 2014, 11:41:31 am »
The build server maybe not running for some other reason. The new drivers may be in the 8/3/14 build. Unfortunately we I ...uh...can't check the (cough) tools.  ;)
Logs show it built images successfully yesterday but hasn't uploaded them.
I'll check my test box.

Looks 8/3/14 is still using the 7.3.2 em driver so wait for a new snapshot.
Code: [Select]
[2.1.1-PRERELEASE][root@pfsense.localdomain]/root(1): uname -a
FreeBSD pfsense.localdomain 8.3-RELEASE-p14 FreeBSD 8.3-RELEASE-p14 #0: Sat Mar  8 12:47:31 EST 2014     root@snapshots-8_3-i386.builders.pfsense.org:/usr/obj.pfSense/usr/pfSensesrc/src/sys/pfSense_wrap.8.i386  i386
[2.1.1-PRERELEASE][root@pfsense.localdomain]/root(2): sysctl dev.em
dev.em.0.%desc: Intel(R) PRO/1000 Network Connection 7.3.2
dev.em.0.%driver: em

Steve
« Last Edit: March 11, 2014, 05:05:26 pm by stephenw10 »

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 21378
  • Karma: +1431/-26
    • View Profile
Re: HEADS UP: em/igb/ixgbe reverted to older drivers
« Reply #26 on: March 11, 2014, 12:09:52 pm »
Builder VMs are offline at the moment, shuffling some things around again completely unrelated to anything else. Once things settle we'll fire them back up and get new snapshots out.

stephenw10 - you can get access to the tools repo if you follow the instructions on the list, mail in a copy of your ssh public key to the address given on the list in the thread.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline stephenw10

  • Administrator
  • Hero Member
  • *****
  • Posts: 11912
  • Karma: +467/-15
    • View Profile
Re: HEADS UP: em/igb/ixgbe reverted to older drivers
« Reply #27 on: March 11, 2014, 12:43:41 pm »
Yes, I realise I could but thanks. I haven't done so because this is the first time I've had reason to look at the tools repo. I have (currently) no need to modify or compile the code only occasionally reviewing what's been changed.

Steve

Offline Jason Litka

  • Hero Member
  • *****
  • Posts: 1294
  • Karma: +53/-1
    • View Profile
    • Utter Ramblings
Re: HEADS UP: em/igb/ixgbe reverted to older drivers
« Reply #28 on: March 11, 2014, 07:53:29 pm »
The drivers from HEAD have been enabled again in the snapshots after fixing the cause of panics.

Please try them again in later snapshots.

SWEET!

I'll update to a newer snapshot next week.  Right now I'm in the middle of trying to migrate about 55TB of data from two failed storage arrays...
I can break anything.

Offline stephenw10

  • Administrator
  • Hero Member
  • *****
  • Posts: 11912
  • Karma: +467/-15
    • View Profile
Re: HEADS UP: em/igb/ixgbe reverted to older drivers
« Reply #29 on: March 12, 2014, 10:10:23 pm »
em drivers back to current.  :)
Code: [Select]
[2.1.1-PRERELEASE][root@pfsense.localdomain]/root(3): sysctl dev.em.0
dev.em.0.%desc: Intel(R) PRO/1000 Network Connection 7.3.8

Steve