Netgate SG-1000 microFirewall

Author Topic: Problema al validar usuario con el AD usando LDAP  (Read 2963 times)

0 Members and 1 Guest are viewing this topic.

Offline j.sejo1

  • Full Member
  • ***
  • Posts: 258
  • Karma: +31/-2
    • View Profile
    • Smartit Business Corp
Re: Problema al validar usuario con el AD usando LDAP
« Reply #15 on: February 06, 2018, 09:59:07 am »
Adicional, y notas para futuros casos de Squid+SquidGuard con AD.

1) Traten de que los grupos esten creados sin espacios, en ou sin espacios, cuestion de que sea mas facil la ubicacion ej:  cn=GrupoVIP,ou=Internet,dc=dominio,dc=local

2) Traten de que el usuario no tenga ni apellidos ni nombre (me refiero al usuario que usa Squidguard para leer el LDAP) , ya que el Squid usa el ID puro ejemplo  pperez, pero el squidGuard utiliza el CN completo:  Pedro Perez,  por lo que el estring quedara en el squidguard seria: cn=Pedro Perez,ou=Usuarios,dc=dominio,dc=local

Y en el Squid: cn=pperez,ou=Usuarios,dc=dominio,dc=local

3) Eviten ACL o GPO en el AD donde el usuario se pueda conectar en una sola maquina, esto debido a que al AD llega la peticion del usuario como si intentara conectarse al squid. Por lo que el AD no lo dejara autenticar.  Esto lo pueden arreglar haciendo desde el squid con ma_user_ip Acl pura del squid.  Asi evitan que el usuario preste su contraseņa.







« Last Edit: February 08, 2018, 05:17:28 pm by j.sejo1 »
Pfsense - Bacula - NagiosZabbix - Zimbra - AlienVault
Hardening Linux
http://www.smartitbc.com/en/contact.html