pfSense Support Subscription

Author Topic: XS4All IPv6 gebruiken  (Read 2896 times)

0 Members and 1 Guest are viewing this topic.

Offline Eltomation

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
XS4All IPv6 gebruiken
« on: September 03, 2015, 08:04:11 am »
Hallo allemaal,

Recent overgestapt van M0n0wall naar pfSense omdat we 1 firewall willen gaan gebruiken ipv 5.
We hebben zowel een UPC WAN (dyn IPv4) als een XS4All WAN (Fixed IPv4, 6 fixed IPv4 VIP en een native /48 IPv6) en 3x LAN (Normaal netwerk, beperkt netwerk en een gastennetwerk).

De UPC verbinding doet het gewoon zoals t moet, al duurt t wel héél erg lang voordat er een IP wordt toegewezen.
De XS4All verbinding doet t deel. Alles qua IPv4 doet het, ook de VIPs, maar de IPv6 wil niet lukken. (IPv6 doet het via M0n0wall wel gewoon (PPPoE voor IPv4 en PPP voor IPv6)

Wie kan mij vertellen wat ik precies moet doen op IPv6 werkende te krijgen?
Krijg wel een fe80 gateway op de WAN, maar ipv6-test.com meld dat het niet werkt. Ook een ping6 naar google vanaf de pfSense geeft 100% package loss
Huidige instellingen:

IPv4 = PPPoE
IPv6 = DHCP6
MTU = 1492
Use IPv4 connectivity as parent interface = checked (ook getest unchecked)
Request only an IPv6 prefix = checked (ook getest unchecked)
DHCPv6 Prefix Delegation size = 48
PPPoE login ingevuld
Block private networks en Block bogon networks = checked

de WAN interface XS4All zit via PPPoE, VLAN6 op vmx0
WAN UPC is vmx2
LAN is vmx1
(systeem draait binnen ESXi 5.5 met vmxnet 3 als adapters)

Offline hda

  • Sr. Member
  • ****
  • Posts: 589
  • Karma: +30/-3
    • View Profile
Re: XS4All IPv6 gebruiken
« Reply #1 on: September 03, 2015, 10:40:54 am »
Direct PPPoE on ISP:

2.2.4 & 2.2.5, use Interfaces-WAN with DHCP6 & DHCP6c config:

 Check, Request a IPv6 prefix/information through the IPv4 connectivity link
 Check, Only request an IPv6 prefix, do not request an IPv6 address
 DHCPv6 Prefix Delegation size == 48
 Check, Send an IPv6 prefix hint to indicate the desired prefix size for delegation

 & Advanced config, no more needed than:
 (send options(ia-pd 0) and Prefix delegation = checked only).

« Last Edit: December 21, 2015, 03:36:45 pm by hda »

Offline Eltomation

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: XS4All IPv6 gebruiken
« Reply #2 on: September 04, 2015, 01:13:59 am »
Ok, will try.

And this:
Use IPv4 connectivity as parent interface = checked (ook getest unchecked)
Request only an IPv6 prefix = checked (ook getest unchecked)
DHCPv6 Prefix Delegation size = 48

also needed, or not?


Thanks!!!
This works as it should.

Why is it so hard to find these settings?
« Last Edit: September 04, 2015, 01:23:12 am by Eltomation »

Offline M_Devil

  • Jr. Member
  • **
  • Posts: 97
  • Karma: +7/-0
    • View Profile
Re: XS4All IPv6 gebruiken
« Reply #3 on: December 29, 2015, 05:00:00 pm »
IPv6 werkte aan lange tijd maar redelijk in mijn setup (XS4All, glas 500/500). Traag laden sites (probeer zelf eens www.cbs.nl via IPv6).

De laatste paar dagen bezig geweest met pfSense 2.3 en in dit topic https://forum.pfsense.org/index.php?topic=100219.0 vindt je redelijk aan het einde informatie om 2 patch'es (van David_W) draaiend te krijgen waarmee ik nu IPv6 goed werkend heb. Zowel een MTU van 1500 (Baby jumbo frames) en connectie probleem na (re)boot opgelost. Ik heb begrepen dat er in 2.3 al veel IPv6 verbeteringen zijn doorgevoerd.